ioBroker Forum


Nutzungsbedingungen |Datenschutzrichtlinie
Cloud |Dokumentation
Aktuelle Zeit: 24.01.2018, 06:14

Alle Zeiten sind UTC+01:00




Ein neues Thema erstellen  Auf das Thema antworten  [ 311 Beiträge ]  Gehe zu Seite Vorherige 112 13 14 15 16 Nächste
Autor Nachricht
BeitragVerfasst: 21.09.2017, 21:35 
Offline

Registriert: 26.01.2017, 22:38
Beiträge: 9
kmxak hat geschrieben:
Du solltest am besten direkt hier eine Issue schreiben und dort sagen das die Mac noch nicht drin ist.

Wenn es dringend ist kannst du temporär bis zum nächsten adapter update bei dir die main.js editierien und die mac's manuell hinzufügen.
Schau mal ein paar Seiten zurück da stehts beschrieben


Habe es gerade selbst hinbekommen über die main.js
Danke für den Tipp!

Wo meinst Du soll ich den Issue schreiben? Hier? https://github.com/PArns/ioBroker.amazon-dash/issues


Nach oben
   
BeitragVerfasst: 21.09.2017, 21:43 
Offline
professional

Registriert: 10.03.2017, 21:00
Beiträge: 814
Hat sich bedankt: 59 Mal
Danksagung erhalten: 41 Mal
Wenn du eingeloggt bist oben rechts new issue

_________________
Gruß Alex

HP Gen 8 ESXi + HP Gen 7 ESXi Backup Server - VM Debian FHEM + ioBroker
Pi3 RaspberryMatic, Wemos D1, NodeMCU, Odroid C2, Pi3 + Zero W


Nach oben
   
BeitragVerfasst: 22.09.2017, 17:01 
Offline
starter

Registriert: 20.06.2016, 19:23
Beiträge: 36
Hat sich bedankt: 9 Mal
Ich würde auch hier auf die Schnelle noch eine MAC weitergeben:

78E103

Grüße


Nach oben
   
BeitragVerfasst: 24.09.2017, 14:58 
Offline
starter

Registriert: 29.06.2017, 12:56
Beiträge: 12
Hat sich bedankt: 2 Mal
Ich habe gerade ioBroker neu von einem Image installiert:
http://www.iobroker.net/docu/?page_id=7241&lang=de

Danach habe ich:
Code:
sudo raspi-config
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install libpcap-dev
sudo apt-get install git
sudo apt-get install git-core


Beim Installieren von Dash Button bekomme ich dann folgende Ausgabe:
Code:
$ ./iobroker add amazon-dash
npm install iobroker.amazon-dash --production --prefix "/opt/iobroker" (System call)
npm WARN lifecycle iobroker.amazon-dash@0.2.4~preinstall: cannot run in wd %s %s (wd=%s) iobroker.amazon-dash@0.2.4 apt-get install libpcap-dev -y || true /opt/iobroker/node_modules/.staging/iobroker.amazon-dash-eb5038e9
../socket_watcher.cpp: In static member function ‘static void SocketWatcher::New(const Nan::FunctionCallbackInfo<v8::Value>&)’:../socket_watcher.cpp:104:49: warning: ‘v8::Local<v8::Object> v8::Function::NewInstance() const’ is deprecated: Use maybe version [-Wdeprecated-declarations]
     info.GetReturnValue().Set(cons->NewInstance());
                                                 ^
In file included from /root/.node-gyp/6.11.3/include/node/v8.h:25:0,
                 from /root/.node-gyp/6.11.3/include/node/node.h:42,
                 from ../../nan/nan.h:49,
                 from ../socket_watcher.hpp:8,
                 from ../socket_watcher.cpp:5:
/root/.node-gyp/6.11.3/include/node/v8.h:3276:52: note: declared here
   V8_DEPRECATED("Use maybe version", Local<Object> NewInstance() const);
                                                    ^
/root/.node-gyp/6.11.3/include/node/v8config.h:333:3: note: in definition of macro ‘V8_DEPRECATED’
   declarator __attribute__((deprecated(message)))
   ^~~~~~~~~~

../pcap_session.cc: In static member function ‘static void PcapSession::New(const Nan::FunctionCallbackInfo<v8::Value>&)’:../pcap_session.cc:46:49: warning: ‘v8::Local<v8::Object> v8::Function::NewInstance() const’ is deprecated: Use maybe version [-Wdeprecated-declarations]
     info.GetReturnValue().Set(cons->NewInstance());
                                                 ^

In file included from /root/.node-gyp/6.11.3/include/node/v8.h:25:0,                 from /root/.node-gyp/6.11.3/include/node/node.h:42,
                 from ../../nan/nan.h:49,
                 from ../pcap_session.h:4,
                 from ../pcap_session.cc:7:
/root/.node-gyp/6.11.3/include/node/v8.h:3276:52: note: declared here
   V8_DEPRECATED("Use maybe version", Local<Object> NewInstance() const);
                                                    ^
/root/.node-gyp/6.11.3/include/node/v8config.h:333:3: note: in definition of macro ‘V8_DEPRECATED’
   declarator __attribute__((deprecated(message)))
   ^~~~~~~~~~

host.iobroker install adapter amazon-dash
npm install --production (System call) in "/opt/iobroker/node_modules/iobroker.amazon-dash"
npm
 WARN
 lifecycle iobroker.amazon-dash@0.2.4~preinstall: cannot run in wd %s %s (wd=%s) iobroker.amazon-dash@0.2.4 apt-get install libpcap-dev -y || true /opt/iobroker/node_modules/iobroker.amazon-dash
../socket_watcher.cpp: In static member function ‘static void SocketWatcher::New(const Nan::FunctionCallbackInfo<v8::Value>&)’:../socket_watcher.cpp:104:49: warning: ‘v8::Local<v8::Object> v8::Function::NewInstance() const’ is deprecated: Use maybe version [-Wdeprecated-declarations]
     info.GetReturnValue().Set(cons->NewInstance());
                                                 ^

In file included from /root/.node-gyp/6.11.3/include/node/v8.h:25:0,                 from /root/.node-gyp/6.11.3/include/node/node.h:42,
                 from ../../nan/nan.h:49,
                 from ../socket_watcher.hpp:8,
                 from ../socket_watcher.cpp:5:
/root/.node-gyp/6.11.3/include/node/v8.h:3276:52: note: declared here
   V8_DEPRECATED("Use maybe version", Local<Object> NewInstance() const);
                                                    ^
/root/.node-gyp/6.11.3/include/node/v8config.h:333:3: note: in definition of macro ‘V8_DEPRECATED’
   declarator __attribute__((deprecated(message)))
   ^~~~~~~~~~


Stimmt etwas nicht mit meiner node Version?
Unter Objekte sehe ich keine Dash Buttons. :-(

Danke,
Tobi


Nach oben
   
BeitragVerfasst: 19.10.2017, 10:01 
Offline

Registriert: 19.10.2017, 09:32
Beiträge: 7
Wohnort: Berlin
Hat sich bedankt: 2 Mal
meome hat geschrieben:
Kurze Frage: Kann man den Adapter irgendwie unter Windows 10 zum Laufen bringen?

Habe mir jetzt alles hier durchgelesen, bin mir aber nich tsicher, ob ich alles zuordnen konnte.

Meine eigenen Installation habe ich upgedated: npm = 3.10.10, node = 6.10.2
Auch WinPcap 4.1.3 installiert (die .exe).
Python 2.7. läuft auch.

Ich bekomme aber immer die Fehlermeldung:
...


Hallo,

ich bin Alex, komme aus Berlin und versuche mich grad an ioBroker.

Geile Software, macht richtig Spass und der heftige Frustlevel den ich bei FHEM relativ schnell erlebt habe ist hier (noch) nicht in Sicht.
Konnte, in überraschend schneller Zeit, meine IOT-Systeme und div. Adapter installieren und konfigurieren. Bin echt begeistert!!!

Nun versuche ich den Dash Adapter auf meinem WIN7 System zu installieren. Leider läuft die Installation nicht durch. Ohne jetzt das Problem näher zu beschreiben...

Gibt es ioBroker-User die den Dash Button erfolgreich auf ihrem WIN System zum laufen gebracht haben?

Vielen Dank!

Gruß
@lex


Nach oben
   
BeitragVerfasst: 21.10.2017, 14:08 
Offline

Registriert: 19.10.2017, 09:32
Beiträge: 7
Wohnort: Berlin
Hat sich bedankt: 2 Mal
Hat sich erledigt!
Windows hat das Gerät verlassen! ;)

Nun ist es Lubuntu, was super performant läuft UND meine Dash Buttons funktionieren ohne Probleme.

Gruß
@lex


Nach oben
   
BeitragVerfasst: 01.11.2017, 10:14 
Offline
starter

Registriert: 26.08.2017, 20:04
Beiträge: 34
Hat sich bedankt: 10 Mal
Ist jetzt nicht wirklich dramatisch, aber ich habe heute einen neuen Dash-Button hinzugefügt.
Statt lediglich dem neuen Button, wurden aber gleich 2 weitere Dash-Buttons als Objekt angelegt.
"Last Pressed 30.10. 2:35 Uhr"

Diese exitieren hier nicht, meine Amazon-App zeigt die Button auch korrekt an.
(Die MAC-Adresse ist auch jeweils unterschiedlich.)


Nach oben
   
BeitragVerfasst: 01.11.2017, 22:00 
Offline
starter

Registriert: 25.06.2017, 19:29
Beiträge: 85
Hat sich bedankt: 5 Mal
Danksagung erhalten: 1 Mal
PArt hat geschrieben:
Der Adapter benötigt zusätzlich noch pcap auf eurem System.
In der Regel lässt sich dieser durch apt-get install libpcap-dev installieren


So! Wollte mich jetzt auch mal an den Dash Button ran trauen.

Hab aber schon der erste problem auf meinen pi

folgender fehler erscheint:
Code:
root@ioBroker-RasPi:/home/pi# apt-get install libpcap-de
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
E: Paket libpcap-de kann nicht gefunden werden.


Jemand eine Idee für mich?
*edit* mein fehler selber gefunden! v vergessen

Gruss Danyel


Nach oben
   
BeitragVerfasst: 19.11.2017, 18:55 
Offline
starter

Registriert: 05.11.2017, 02:52
Beiträge: 29
leider wird einer meiner Dash-Buttons nicht erkannt, hab sie schon in die main.js eingetragen wie die anderen aber es ändert sich nichts. MAC wäre 00:FC:8B


Nach oben
   
BeitragVerfasst: 19.11.2017, 20:03 
Offline
professional
Benutzeravatar

Registriert: 29.04.2017, 22:59
Beiträge: 117
Wohnort: Velbert
Hat sich bedankt: 11 Mal
Danksagung erhalten: 4 Mal
VANTOM hat geschrieben:
leider wird einer meiner Dash-Buttons nicht erkannt, hab sie schon in die main.js eingetragen wie die anderen aber es ändert sich nichts. MAC wäre 00:FC:8B


Das Problem hatte ich auch. Mac Adresse selbst eingetragen, brachte aber leider auch nichts. Ich habe den Adapter dann wieder gelöscht. Habe jetzt hier halt einen hübschen Taster an der Wand hängen.

_________________
ioBroker auf Raspberry 3 - Homematic CCU2 - Netatmo Wetterstation, Thermostat - Alexa - ioBroker cloud Pro


Nach oben
   
BeitragVerfasst: 19.12.2017, 21:41 
Offline
starter

Registriert: 30.11.2017, 12:24
Beiträge: 18
Hallo, ich wollte meinen dash installieren und irgendwie klappt garnix. Den adapter habe ich mir paar fehlermeldungen installiert. Was für eine PCAP muss ich da eingeben? Mein PI ist mit LAN verbunden. Habe dann den Dash mit der App via smartphone installiert und bei der produktwahl abgebrochen. Dann den adapter in iobrocker installiert und nun komme ich nicht mehr weiter. Anbei ein paar Bilder


Dateianhänge:
006.png
006.png [ 108.03 KiB | 320 mal betrachtet ]
005.png
005.png [ 58.93 KiB | 320 mal betrachtet ]
004.png
004.png [ 99.25 KiB | 320 mal betrachtet ]
Nach oben
   
BeitragVerfasst: 20.12.2017, 07:01 
Offline
guru
Benutzeravatar

Registriert: 02.10.2016, 13:52
Beiträge: 1004
Hat sich bedankt: 42 Mal
Danksagung erhalten: 74 Mal
Espace0401 hat geschrieben:
VANTOM hat geschrieben:
leider wird einer meiner Dash-Buttons nicht erkannt, hab sie schon in die main.js eingetragen wie die anderen aber es ändert sich nichts. MAC wäre 00:FC:8B


Das Problem hatte ich auch. Mac Adresse selbst eingetragen, brachte aber leider auch nichts. Ich habe den Adapter dann wieder gelöscht. Habe jetzt hier halt einen hübschen Taster an der Wand hängen.



hast den io broker gestoppt....

dann mac addresse eintragen

da stehen schon welche .. also erstmal schauen ob die nicht schon da steht..
wenn nicht nach dem gleichen schema eintragen

iobroker starten

WARTEN.... es dauert bis der Adapter den Button findet ..wenn nicht knopp drücken wieder WARTEN


Nach oben
   
BeitragVerfasst: 20.12.2017, 07:42 
Offline
guru
Benutzeravatar

Registriert: 02.10.2016, 13:52
Beiträge: 1004
Hat sich bedankt: 42 Mal
Danksagung erhalten: 74 Mal
Jan201 hat geschrieben:
Hallo, ich wollte meinen dash installieren und irgendwie klappt garnix. Den adapter habe ich mir paar fehlermeldungen installiert. Was für eine PCAP muss ich da eingeben? Mein PI ist mit LAN verbunden. Habe dann den Dash mit der App via smartphone installiert und bei der produktwahl abgebrochen. Dann den adapter in iobrocker installiert und nun komme ich nicht mehr weiter. Anbei ein paar Bilder



stoppe den adapter mal.. und dann neu starten.. schau im LOG ob da jetzt was an fehler auftaucht...

wenn nicht..

welche MAC adresse hat der Knopp


Nach oben
   
BeitragVerfasst: 20.12.2017, 15:49 
Offline
starter

Registriert: 30.11.2017, 12:24
Beiträge: 18
Hallo, also der Knopf hat: 00:FC:8B:34:AF:41
Habe den Adapter neu gestartet und es kam folgendes:
amazon-dash.0 2017-12-20 15:41:25.253 info starting pcap session on interface wlan0
amazon-dash.0 2017-12-20 15:41:25.243 info starting. Version 0.2.5 in /opt/iobroker/node_modules/iobroker.amazon-dash, node: v6.12.0
amazon-dash.0 2017-12-20 15:41:25.185 info States connected to redis: 127.0.0.1:6379
host.ioBroker-Pi 2017-12-20 15:41:23.503 info instance system.adapter.amazon-dash.0 started with pid 10227
host.ioBroker-Pi 2017-12-20 15:41:23.456 info object change system.adapter.amazon-dash.0
host.ioBroker-Pi 2017-12-20 15:41:07.040 info instance system.adapter.amazon-dash.0 terminated with code 0 (OK)
amazon-dash.0 2017-12-20 15:41:06.904 info terminating
amazon-dash.0 2017-12-20 15:41:06.881 info cleaned everything up...
host.ioBroker-Pi 2017-12-20 15:41:06.875 info stopInstance system.adapter.amazon-dash.0 killing pid 3657
host.ioBroker-Pi 2017-12-20 15:41:06.872 info stopInstance system.adapter.amazon-dash.0

Das mit der MAC manuell eintragen in der main.js habe ich noch nicht so richtig verstanden. Wo kann ich das machen?


Nach oben
   
BeitragVerfasst: 20.12.2017, 22:09 
Offline
starter

Registriert: 30.11.2017, 12:24
Beiträge: 18
arteck hat geschrieben:
die MAC ist so wie ich das sehe nicht im Adapter eingetragen

du könntest probeweise diesen erweitern

stoppe den iobroker

öffne die datei /iobroker/node_modules/iobroker.amazon-dash/main.js

dort findest du ein array mit den MAC adressen ganz am anfang

Code:
var MACs = [
    "747548",
    "F0D2F1",
    "8871E5",
    "74C246",
    "F0272D",
    "34D270",
    "0C47C9",
    "A002DC",
    "AC63BE",
    "44650D",
    "50F5DA",
    "84D6D0",
    "B47C9C",
    "FCA667"
];


ersetzte es durch diese

Code:
var MACs = [
    "747548",
    "F0D2F1",
    "8871E5",
    "74C246",
    "F0272D",
    "34D270",
    "0C47C9",
    "A002DC",
    "AC63BE",
    "44650D",
    "50F5DA",
    "84D6D0",
    "B47C9C",
    "FCA667",
    "40B4CD"
];


speichern und iobroker wieder starten...
der adapter sollte jetzt auch deine MAC kennen


bedenke bitte aktualisierst du diesen Adapter ist deine Änderung wieder futsch

Wie kann ich die Datei mit einem Windows10 rechner öffen? muss ich dazu die karte aus dem PI nehmen? habe jetzt alles durchgelesen aber keine antwort gefunden. Die sechs zahlen/Buchstaben, sind das die ersten von meiner MAC adresse nur ohne ":" ? Wird der ordner "amazon-dash.0" automatisch erzeugt wenn er ein objekt findet? Ich habe auch einen Echo am laufen der wird auch nicht gefunden.


Nach oben
   
BeitragVerfasst: 21.12.2017, 08:07 
Offline
guru
Benutzeravatar

Registriert: 02.10.2016, 13:52
Beiträge: 1004
Hat sich bedankt: 42 Mal
Danksagung erhalten: 74 Mal
log dich an der konsole an
Code:
sudo nano /opt/iobroker/node_modules/iobroker.amazon-dash/main.js


dor deine MAC adresse hinten drann eintragen

Code:
00FC8B


komma nicht vergessen...

mit strg+x kannst du den editor verlassen..speichern nicht vergessen


Nach oben
   
BeitragVerfasst: 21.12.2017, 22:31 
Offline
starter

Registriert: 30.11.2017, 12:24
Beiträge: 18
Hat super geklappt, vielen dank :)


Nach oben
   
BeitragVerfasst: 03.01.2018, 22:01 
Offline
starter

Registriert: 30.12.2017, 03:19
Beiträge: 16
Hat sich bedankt: 6 Mal
Hallo Zusammen,

würde gerne meinen Amazon Dash nicht nur für Hundefutter nutzen bekommen den adapter aber nicht zum Laufen, ich habe bereits die https://github.com/PArns/ioBroker.amazo ... /README.md befolgt sowie http://www.iobroker.net/docu/?page_id=5510&lang=de versucht leider ohne Erfolg. Python 3, node v6.11.2, npm v3.10.10.

Synology DS 216play ohne Docker

Code:
$ ./iobroker add amazon-dash
npm install iobroker.amazon-dash --production --prefix "/opt/iobroker" (System call)
npm
 WARN lifecycle iobroker.amazon-dash@0.2.7~preinstall: cannot run in wd %s %s (wd=%s) iobroker.amazon-dash@0.2.7 apt-get install libpcap-dev -y || true /opt/iobroker/node_modules/.staging/iobroker.amazon-dash-eb5038e9
gyp
 ERR! build error
gyp ERR! stack Error: not found: makegyp ERR! stack
     at getNotFoundError (/usr/local/lib/node_modules/npm/node_modules/which/which.js:14:12)gyp ERR! stack     at F (/usr/local/lib/node_modules/npm/node_modules/which/which.js:69:19)
gyp
 
ERR! stack     at E (/usr/local/lib/node_modules/npm/node_modules/which/which.js:81:29)gyp ERR! stack
     at /usr/local/lib/node_modules/npm/node_modules/which/which.js:90:16gyp ERR!
 stack     at /usr/local/lib/node_modules/npm/node_modules/which/node_modules/isexe/index.js:44:5gyp ERR! stack     at /usr/local/lib/node_modules/npm/node_modules/which/node_modules/isexe/access.js:8:5
gyp ERR!
 stack     at FSReqWrap.oncomplete (fs.js:123:15)gyp
ERR! System
 Linux 3.10.102gyp ERR! command "/volume1/@appstore/Node.js_v6/usr/local/bin/node" "/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
gyp ERR! cwd /opt/iobroker/node_modules/bufferutil
gyp ERR! node -v v6.11.2
gyp ERR! node-gyp -v v3.4.0
gyp ERR! not ok

node-pre-gyp
 
ERR!
 
Tried to download(404): https://github.com/EmergingTechnologyAdvisors/node-serialport/releases/download/4.0.7/serialport-v4.0.7-node-v48-linux-arm.tar.gz
 node-pre-gyp
 ERR! Pre-built binaries not found for serialport@4.0.7 and node@6.11.2 (node-v48 ABI) (falling back to source compile with node-gyp)
gyp
 
ERR!
 build error gyp ERR! stack Error: not found: make
gyp ERR! stack     at getNotFoundError (/volume1/@appstore/Node.js_v6/usr/local/lib/node_modules/npm/node_modules/which/which.js:14:12)
gyp ERR! stack
     at F (/volume1/@appstore/Node.js_v6/usr/local/lib/node_modules/npm/node_modules/which/which.js:69:19)
gyp ERR! stack     at E (/volume1/@appstore/Node.js_v6/usr/local/lib/node_modules/npm/node_modules/which/which.js:81:29)gyp ERR! stack     at /volume1/@appstore/Node.js_v6/usr/local/lib/node_modules/npm/node_modules/which/which.js:90:16
gyp ERR! stack     at /volume1/@appstore/Node.js_v6/usr/local/lib/node_modules/npm/node_modules/which/node_modules/isexe/index.js:44:5
gyp ERR! stack     at /volume1/@appstore/Node.js_v6/usr/local/lib/node_modules/npm/node_modules/which/node_modules/isexe/access.js:8:5
gyp ERR! stack     at FSReqWrap.oncomplete (fs.js:123:15)
gyp ERR! System Linux 3.10.102
gyp ERR! command "/volume1/@appstore/Node.js_v6/usr/local/bin/node" "/volume1/@appstore/Node.js_v6/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "build" "--fallback-to-build" "--module=/opt/iobroker/node_modules/serialport/build/Release/serialport.node" "--module_name=serialport" "--module_path=/opt/iobroker/node_modules/serialport/build/Release"
gyp ERR! cwd /opt/iobroker/node_modules/serialport
gyp ERR! node -v v6.11.2
gyp ERR! node-gyp -v v3.4.0
gyp ERR! not ok
node-pre-gyp ERR! build error
node-pre-gyp ERR! stack Error: Failed to execute '/volume1/@appstore/Node.js_v6/usr/local/bin/node /volume1/@appstore/Node.js_v6/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js build --fallback-to-build --module=/opt/iobroker/node_modules/serialport/build/Release/serialport.node --module_name=serialport --module_path=/opt/iobroker/node_modules/serialport/build/Release' (1)
node-pre-gyp ERR! stack     at ChildProcess.<anonymous> (/opt/iobroker/node_modules/serialport/node_modules/node-pre-gyp/lib/util/compile.js:83:29)
node-pre-gyp ERR! stack     at emitTwo (events.js:106:13)
node-pre-gyp ERR! stack     at ChildProcess.emit (events.js:191:7)
node-pre-gyp ERR! stack     at maybeClose (internal/child_process.js:891:16)
node-pre-gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:226:5)
node-pre-gyp ERR! System Linux 3.10.102
node-pre-gyp ERR! command "/volume1/@appstore/Node.js_v6/usr/local/bin/node" "/opt/iobroker/node_modules/serialport/node_modules/.bin/node-pre-gyp" "install" "--fallback-to-build"
node-pre-gyp ERR! cwd /opt/iobroker/node_modules/serialport
node-pre-gyp ERR! node -v v6.11.2
node-pre-gyp ERR! node-pre-gyp -v v0.6.32
node-pre-gyp ERR! not ok

gyp
 
ERR!
build error
 
gyp ERR! stack Error: not found: makegyp ERR! stack     at getNotFoundError (/usr/local/lib/node_modules/npm/node_modules/which/which.js:14:12)
gyp ERR! stack     at F (/usr/local/lib/node_modules/npm/node_modules/which/which.js:69:19)
gyp ERR! stack     at E (/usr/local/lib/node_modules/npm/node_modules/which/which.js:81:29)
gyp ERR! stack     at /usr/local/lib/node_modules/npm/node_modules/which/which.js:90:16
gyp ERR! stack     at /usr/local/lib/node_modules/npm/node_modules/which/node_modules/isexe/index.js:44:5
gyp ERR! stack     at /usr/local/lib/node_modules/npm/node_modules/which/node_modules/isexe/access.js:8:5
gyp ERR! stack     at FSReqWrap.oncomplete (fs.js:123:15)
gyp ERR! System Linux 3.10.102
gyp ERR! command "/volume1/@appstore/Node.js_v6/usr/local/bin/node" "/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
gyp ERR! cwd /opt/iobroker/node_modules/socketwatcher
gyp ERR! node -v v6.11.2
gyp ERR! node-gyp -v v3.4.0
gyp ERR! not ok

npm
 WARN
 optional SKIPPING OPTIONAL DEPENDENCY: bufferutil@1.1.0 (node_modules/bufferutil):npm WARN optional SKIPPING OPTIONAL DEPENDENCY: bufferutil@1.1.0 install: `node-gyp rebuild`
npm WARN
optional SKIPPING OPTIONAL DEPENDENCY: Exit status 1npm WARN
optional SKIPPING OPTIONAL DEPENDENCY: serialport@4.0.7 (node_modules/serialport):npm WARN optional SKIPPING OPTIONAL DEPENDENCY: serialport@4.0.7 install: `node-pre-gyp install --fallback-to-build`
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: Exit status 1

npm
 ERR! Linux 3.10.102
npm
 ERR!
argv "/volume1/@appstore/Node.js_v6/usr/local/bin/node" "/usr/local/bin/npm" "install" "iobroker.amazon-dash" "--production" "--prefix" "/opt/iobroker"npm ERR!
 node v6.11.2npm ERR! npm  v3.10.10
npm ERR! code ELIFECYCLE

npm ERR! socketwatcher@0.3.0 install: `node-gyp rebuild`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the socketwatcher@0.3.0 install script 'node-gyp rebuild'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the socketwatcher package,
npm ERR! not with npm itself.
npm ERR!
 Tell the author that this fails on your system:npm ERR!     node-gyp rebuild
npm ERR! You can get information on how to open an issue for this project with:
npm ERR!     npm bugs socketwatcher
npm ERR! Or if that isn't available, you can get their info via:

npm ERR!     npm owner ls socketwatchernpm ERR! There is likely additional logging output above.


npm ERR! Please include the following file with any support request:npm ERR!     /npm-debug.log

host.NAS0815 install adapter amazon-dash
npm install iobroker.amazon-dash --production --prefix "/opt/iobroker" (System call)
npm WARN lifecycle iobroker.amazon-dash@0.2.7~preinstall: cannot run in wd %s %s (wd=%s) iobroker.amazon-dash@0.2.7 apt-get install libpcap-dev -y || true /opt/iobroker/node_modules/.staging/iobroker.amazon-dash-eb5038e9
gyp
 ERR! build error gyp ERR! stack Error: not found: make
gyp ERR! stack     at getNotFoundError (/usr/local/lib/node_modules/npm/node_modules/which/which.js:14:12)
gyp ERR! stack     at F (/usr/local/lib/node_modules/npm/node_modules/which/which.js:69:19)
gyp ERR! stack     at E (/usr/local/lib/node_modules/npm/node_modules/which/which.js:81:29)
gyp ERR! stack     at /usr/local/lib/node_modules/npm/node_modules/which/which.js:90:16
gyp ERR! stack     at /usr/local/lib/node_modules/npm/node_modules/which/node_modules/isexe/index.js:44:5
gyp ERR! stack     at /usr/local/lib/node_modules/npm/node_modules/which/node_modules/isexe/access.js:8:5
gyp ERR! stack     at FSReqWrap.oncomplete (fs.js:123:15)
gyp ERR! System Linux 3.10.102
gyp ERR! command "/volume1/@appstore/Node.js_v6/usr/local/bin/node" "/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
gyp ERR! cwd /opt/iobroker/node_modules/bufferutil
gyp ERR! node -v v6.11.2
gyp ERR! node-gyp -v v3.4.0
gyp ERR! not ok

node-pre-gyp
 ERR! Tried to download(404): https://github.com/EmergingTechnologyAdvisors/node-serialport/releases/download/4.0.7/serialport-v4.0.7-node-v48-linux-arm.tar.gz node-pre-gyp ERR! Pre-built binaries not found for serialport@4.0.7 and node@6.11.2 (node-v48 ABI) (falling back to source compile with node-gyp)

gyp
 ERR! build error gyp ERR! stack Error: not found: make
gyp ERR! stack     at getNotFoundError (/volume1/@appstore/Node.js_v6/usr/local/lib/node_modules/npm/node_modules/which/which.js:14:12)
gyp ERR! stack     at F (/volume1/@appstore/Node.js_v6/usr/local/lib/node_modules/npm/node_modules/which/which.js:69:19)
gyp ERR! stack     at E (/volume1/@appstore/Node.js_v6/usr/local/lib/node_modules/npm/node_modules/which/which.js:81:29)
gyp ERR! stack     at /volume1/@appstore/Node.js_v6/usr/local/lib/node_modules/npm/node_modules/which/which.js:90:16
gyp ERR! stack     at /volume1/@appstore/Node.js_v6/usr/local/lib/node_modules/npm/node_modules/which/node_modules/isexe/index.js:44:5
gyp ERR! stack     at /volume1/@appstore/Node.js_v6/usr/local/lib/node_modules/npm/node_modules/which/node_modules/isexe/access.js:8:5
gyp ERR! stack     at FSReqWrap.oncomplete (fs.js:123:15)
gyp ERR! System Linux 3.10.102
gyp ERR! command "/volume1/@appstore/Node.js_v6/usr/local/bin/node" "/volume1/@appstore/Node.js_v6/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "build" "--fallback-to-build" "--module=/opt/iobroker/node_modules/serialport/build/Release/serialport.node" "--module_name=serialport" "--module_path=/opt/iobroker/node_modules/serialport/build/Release"
gyp ERR! cwd /opt/iobroker/node_modules/serialport
gyp ERR! node -v v6.11.2
gyp ERR! node-gyp -v v3.4.0
gyp ERR! not ok
node-pre-gyp ERR! build error
node-pre-gyp ERR! stack Error: Failed to execute '/volume1/@appstore/Node.js_v6/usr/local/bin/node /volume1/@appstore/Node.js_v6/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js build --fallback-to-build --module=/opt/iobroker/node_modules/serialport/build/Release/serialport.node --module_name=serialport --module_path=/opt/iobroker/node_modules/serialport/build/Release' (1)
node-pre-gyp ERR! stack     at ChildProcess.<anonymous> (/opt/iobroker/node_modules/serialport/node_modules/node-pre-gyp/lib/util/compile.js:83:29)
node-pre-gyp ERR! stack     at emitTwo (events.js:106:13)
node-pre-gyp ERR! stack     at ChildProcess.emit (events.js:191:7)
node-pre-gyp ERR! stack     at maybeClose (internal/child_process.js:891:16)
node-pre-gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:226:5)
node-pre-gyp ERR! System Linux 3.10.102
node-pre-gyp ERR! command "/volume1/@appstore/Node.js_v6/usr/local/bin/node" "/opt/iobroker/node_modules/serialport/node_modules/.bin/node-pre-gyp" "install" "--fallback-to-build"
node-pre-gyp ERR! cwd /opt/iobroker/node_modules/serialport
node-pre-gyp ERR! node -v v6.11.2
node-pre-gyp ERR! node-pre-gyp -v v0.6.32
node-pre-gyp ERR! not ok

gyp
 ERR! build error gyp ERR! stack Error: not found: make
gyp ERR! stack     at getNotFoundError (/usr/local/lib/node_modules/npm/node_modules/which/which.js:14:12)
gyp ERR! stack     at F (/usr/local/lib/node_modules/npm/node_modules/which/which.js:69:19)
gyp ERR! stack     at E (/usr/local/lib/node_modules/npm/node_modules/which/which.js:81:29)
gyp ERR! stack     at /usr/local/lib/node_modules/npm/node_modules/which/which.js:90:16
gyp ERR! stack     at /usr/local/lib/node_modules/npm/node_modules/which/node_modules/isexe/index.js:44:5
gyp ERR! stack     at /usr/local/lib/node_modules/npm/node_modules/which/node_modules/isexe/access.js:8:5
gyp ERR! stack     at FSReqWrap.oncomplete (fs.js:123:15)
gyp ERR! System Linux 3.10.102
gyp ERR! command "/volume1/@appstore/Node.js_v6/usr/local/bin/node" "/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
gyp ERR! cwd /opt/iobroker/node_modules/socketwatcher
gyp ERR! node -v v6.11.2
gyp ERR! node-gyp -v v3.4.0
gyp ERR! not ok

npm
 WARN optional SKIPPING OPTIONAL DEPENDENCY: bufferutil@1.1.0 (node_modules/bufferutil):npm WARN optional SKIPPING OPTIONAL DEPENDENCY: bufferutil@1.1.0 install: `node-gyp rebuild`
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: Exit status 1
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: serialport@4.0.7 (node_modules/serialport):
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: serialport@4.0.7 install: `node-pre-gyp install --fallback-to-build`
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: Exit status 1

npm ERR! Linux 3.10.102
npm ERR! argv "/volume1/@appstore/Node.js_v6/usr/local/bin/node" "/usr/local/bin/npm" "install" "iobroker.amazon-dash" "--production" "--prefix" "/opt/iobroker"npm ERR! node v6.11.2
npm ERR! npm  v3.10.10
npm ERR! code
 ELIFECYCLE
npm ERR! socketwatcher@0.3.0 install: `node-gyp rebuild`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the socketwatcher@0.3.0 install script 'node-gyp rebuild'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the socketwatcher package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node-gyp rebuild
npm ERR! You can get information on how to open an issue for this project with:
npm ERR!     npm bugs socketwatcher
npm ERR! Or if that isn't available, you can get their info via:

npm ERR!     npm owner ls socketwatchernpm
ERR! There is likely additional logging output above.
npm ERR! Please include the following file with any support request:
npm ERR!     /npm-debug.log

host.NAS0815 install adapter amazon-dash
npm install iobroker.amazon-dash --production --prefix "/opt/iobroker" (System call)
npm
 WARN lifecycle iobroker.amazon-dash@0.2.7~preinstall: cannot run in wd %s %s (wd=%s) iobroker.amazon-dash@0.2.7 apt-get install libpcap-dev -y || true /opt/iobroker/node_modules/.staging/iobroker.amazon-dash-eb5038e9
gyp
 ERR! build error gyp ERR! stack Error: not found: make
gyp ERR! stack     at getNotFoundError (/usr/local/lib/node_modules/npm/node_modules/which/which.js:14:12)
gyp ERR! stack     at F (/usr/local/lib/node_modules/npm/node_modules/which/which.js:69:19)
gyp ERR! stack     at E (/usr/local/lib/node_modules/npm/node_modules/which/which.js:81:29)
gyp ERR! stack     at /usr/local/lib/node_modules/npm/node_modules/which/which.js:90:16
gyp ERR! stack     at /usr/local/lib/node_modules/npm/node_modules/which/node_modules/isexe/index.js:44:5
gyp ERR! stack     at /usr/local/lib/node_modules/npm/node_modules/which/node_modules/isexe/access.js:8:5
gyp ERR! stack     at FSReqWrap.oncomplete (fs.js:123:15)
gyp ERR! System Linux 3.10.102
gyp ERR! command "/volume1/@appstore/Node.js_v6/usr/local/bin/node" "/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
gyp ERR! cwd /opt/iobroker/node_modules/bufferutil
gyp ERR! node -v v6.11.2
gyp ERR! node-gyp -v v3.4.0
gyp ERR! not ok

node-pre-gyp
 
ERR! Tried to download(404): https://github.com/EmergingTechnologyAdvisors/node-serialport/releases/download/4.0.7/serialport-v4.0.7-node-v48-linux-arm.tar.gz node-pre-gyp ERR! Pre-built binaries not found for serialport@4.0.7 and node@6.11.2 (node-v48 ABI) (falling back to source compile with node-gyp)

gyp ERR! build error
gyp ERR! stack Error: not found: makegyp ERR! stack     at getNotFoundError (/volume1/@appstore/Node.js_v6/usr/local/lib/node_modules/npm/node_modules/which/which.js:14:12)
gyp ERR! stack     at F (/volume1/@appstore/Node.js_v6/usr/local/lib/node_modules/npm/node_modules/which/which.js:69:19)
gyp ERR! stack     at E (/volume1/@appstore/Node.js_v6/usr/local/lib/node_modules/npm/node_modules/which/which.js:81:29)
gyp ERR! stack     at /volume1/@appstore/Node.js_v6/usr/local/lib/node_modules/npm/node_modules/which/which.js:90:16
gyp ERR! stack     at /volume1/@appstore/Node.js_v6/usr/local/lib/node_modules/npm/node_modules/which/node_modules/isexe/index.js:44:5
gyp ERR! stack     at /volume1/@appstore/Node.js_v6/usr/local/lib/node_modules/npm/node_modules/which/node_modules/isexe/access.js:8:5
gyp ERR! stack     at FSReqWrap.oncomplete (fs.js:123:15)
gyp ERR! System Linux 3.10.102
gyp ERR! command "/volume1/@appstore/Node.js_v6/usr/local/bin/node" "/volume1/@appstore/Node.js_v6/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "build" "--fallback-to-build" "--module=/opt/iobroker/node_modules/serialport/build/Release/serialport.node" "--module_name=serialport" "--module_path=/opt/iobroker/node_modules/serialport/build/Release"
gyp ERR! cwd /opt/iobroker/node_modules/serialport
gyp ERR! node -v v6.11.2
gyp ERR! node-gyp -v v3.4.0
gyp ERR! not ok

node-pre-gyp ERR! build error node-pre-gyp ERR! stack Error: Failed to execute '/volume1/@appstore/Node.js_v6/usr/local/bin/node /volume1/@appstore/Node.js_v6/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js build --fallback-to-build --module=/opt/iobroker/node_modules/serialport/build/Release/serialport.node --module_name=serialport --module_path=/opt/iobroker/node_modules/serialport/build/Release' (1)
node-pre-gyp ERR! stack     at ChildProcess.<anonymous> (/opt/iobroker/node_modules/serialport/node_modules/node-pre-gyp/lib/util/compile.js:83:29)
node-pre-gyp ERR! stack     at emitTwo (events.js:106:13)
node-pre-gyp ERR! stack     at ChildProcess.emit (events.js:191:7)
node-pre-gyp ERR! stack     at maybeClose (internal/child_process.js:891:16)
node-pre-gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:226:5)
node-pre-gyp ERR! System Linux 3.10.102
node-pre-gyp ERR! command "/volume1/@appstore/Node.js_v6/usr/local/bin/node" "/opt/iobroker/node_modules/serialport/node_modules/.bin/node-pre-gyp" "install" "--fallback-to-build"
node-pre-gyp ERR! cwd /opt/iobroker/node_modules/serialport
node-pre-gyp ERR! node -v v6.11.2
node-pre-gyp ERR! node-pre-gyp -v v0.6.32
node-pre-gyp ERR! not ok

gyp
 
ERR!
 
build error
 gyp ERR! stack Error: not found: make
gyp ERR! stack     at getNotFoundError (/usr/local/lib/node_modules/npm/node_modules/which/which.js:14:12)
gyp ERR! stack     at F (/usr/local/lib/node_modules/npm/node_modules/which/which.js:69:19)
gyp ERR! stack     at E (/usr/local/lib/node_modules/npm/node_modules/which/which.js:81:29)
gyp ERR! stack     at /usr/local/lib/node_modules/npm/node_modules/which/which.js:90:16
gyp ERR! stack     at /usr/local/lib/node_modules/npm/node_modules/which/node_modules/isexe/index.js:44:5
gyp ERR! stack     at /usr/local/lib/node_modules/npm/node_modules/which/node_modules/isexe/access.js:8:5
gyp ERR! stack     at FSReqWrap.oncomplete (fs.js:123:15)
gyp ERR! System Linux 3.10.102
gyp ERR! command "/volume1/@appstore/Node.js_v6/usr/local/bin/node" "/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
gyp ERR! cwd /opt/iobroker/node_modules/socketwatcher
gyp ERR! node -v v6.11.2
gyp ERR! node-gyp -v v3.4.0
gyp ERR! not ok

npm
 WARN optional SKIPPING OPTIONAL DEPENDENCY: bufferutil@1.1.0 (node_modules/bufferutil):npm WARN optional SKIPPING OPTIONAL DEPENDENCY: bufferutil@1.1.0 install: `node-gyp rebuild`
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: Exit status 1
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: serialport@4.0.7 (node_modules/serialport):
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: serialport@4.0.7 install: `node-pre-gyp install --fallback-to-build`
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: Exit status 1
npm ERR! Linux 3.10.102
npm ERR! argv "/volume1/@appstore/Node.js_v6/usr/local/bin/node" "/usr/local/bin/npm" "install" "iobroker.amazon-dash" "--production" "--prefix" "/opt/iobroker"
npm ERR! node v6.11.2
npm ERR! npm  v3.10.10
npm ERR! code ELIFECYCLE

npm ERR! socketwatcher@0.3.0 install: `node-gyp rebuild`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the socketwatcher@0.3.0 install script 'node-gyp rebuild'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the socketwatcher package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node-gyp rebuild
npm ERR! You can get information on how to open an issue for this project with:
npm ERR!     npm bugs socketwatcher
npm ERR! Or if that isn't available, you can get their info via:

npm ERR!     npm owner ls socketwatchernpm ERR!
 There is likely additional logging output above.

npm ERR!
 Please include the following file with any support request:npm ERR!
     /npm-debug.log
host.NAS0815 install adapter amazon-dash
ERROR: host.NAS0815 Cannot install amazon-dash
ERROR: process exited with code 13


vielen DAnk


Nach oben
   
BeitragVerfasst: 03.01.2018, 22:33 
Offline
professional

Registriert: 10.02.2017, 22:32
Beiträge: 232
Wohnort: Münsterland
Hat sich bedankt: 23 Mal
Danksagung erhalten: 5 Mal
j3sk0 hat geschrieben:
Hallo Zusammen,

würde gerne meinen Amazon Dash nicht nur für Hundefutter nutzen bekommen den adapter aber nicht zum Laufen, ich habe bereits die https://github.com/PArns/ioBroker.amazo ... /README.md befolgt sowie http://www.iobroker.net/docu/?page_id=5510&lang=de versucht leider ohne Erfolg. Python 3, node v6.11.2, npm v3.10.10.

Synology DS 216play ohne Docker

vielen DAnk



Verusch mal

apt-get install libpcap-dev

Gruß Christian


Nach oben
   
BeitragVerfasst: 04.01.2018, 07:09 
Offline
starter

Registriert: 30.12.2017, 03:19
Beiträge: 16
Hat sich bedankt: 6 Mal
Code:
Verusch mal 

apt-get install libpcap-dev

Gruß Christian


Hab ich bereits da es so auch in der redme von GitHub steht... Leider ohne Erfolg


Nach oben
   
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen  Auf das Thema antworten  [ 311 Beiträge ]  Gehe zu Seite Vorherige 112 13 14 15 16 Nächste

Alle Zeiten sind UTC+01:00


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste


Du darfst keine neuen Themen in diesem Forum erstellen.
Du darfst keine Antworten zu Themen in diesem Forum erstellen.
Du darfst deine Beiträge in diesem Forum nicht ändern.
Du darfst deine Beiträge in diesem Forum nicht löschen.
Du darfst keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Gehe zu Forum:  
Powered by phpBB® Forum Software © phpBB Limited
Deutsche Übersetzung durch phpBB.de