Admin nicht mehr erreichbar Fehler HTTP/1.1 404 Not Found

Allgemeine Fragen und Info rund um ioBroker
Antworten
Heiko2018
Beiträge: 5
Registriert: 15.06.2018, 07:10
Wohnort: Kerpen

Admin nicht mehr erreichbar Fehler HTTP/1.1 404 Not Found

Beitrag von Heiko2018 » 15.06.2018, 07:17

Hallo,

ich bin hier totaler Anfänger und habe iobroker installiert. Jetzt ist der Admin nicht mehr erreichbar. Es dreht sich nur noch das "Zahnrad" und in der Console kommt immer der Fehler HTTP/1.1 404 Not Found. Bis jetzt habe ich im Forum dazu nichts gefunden. Ich hoffe, es kann mir jemand helfen.
Läuft iobroker auf dem Raspberry Pi stabiler?

Viele Grüße

Heiko

Benutzeravatar
eric2905
guru
Beiträge: 3254
Registriert: 23.03.2015, 18:41
Wohnort: Wuppertal

Re: Admin nicht mehr erreichbar Fehler HTTP/1.1 404 Not Found

Beitrag von eric2905 » 15.06.2018, 07:31

Moin Heiko,
Heiko2018 hat geschrieben:Läuft iobroker auf dem Raspberry Pi stabiler?
um das, und Deine andere Frage beantworten zu können, wäre es interessant zu wissen, wo ioBroker jetzt läuft/installiert ist.


Gruß,
Eric

Von unterwegs getippert
-----------------------------------------------------------------------------------------------
Roses are red, violets are blue,
if I listen to heavy metal, my neighbours do too

Heiko2018
Beiträge: 5
Registriert: 15.06.2018, 07:10
Wohnort: Kerpen

Re: Admin nicht mehr erreichbar Fehler HTTP/1.1 404 Not Found

Beitrag von Heiko2018 » 15.06.2018, 08:52

Hallo,

es ist auf Win10 Home 64-bit installiert.

Viele Grüße

Heiko

Benutzeravatar
wendy2702
guru
Beiträge: 2984
Registriert: 18.01.2016, 22:12
Wohnort: Herzogenrath

Re: Admin nicht mehr erreichbar Fehler HTTP/1.1 404 Not Found

Beitrag von wendy2702 » 15.06.2018, 09:03

Hi Heiko,

ob es stabiler läuft kann ich dir nicht sagen. ich nutze für "Server" Anwendungen lieber Linux statt Windows. Hat aber alles seine Vor und Nachteile.

Zu deinem Problem, also der Admin lief schon mal?

Was hast du gemacht? Läuft der eventuell nicht nach einem System restart?

Kannst du in einer Admin Konsole mal das eingeben:

Code: Alles auswählen

iobroker list instances
iobroker status
Wobei ich hoffe das die Befehle genauso wie bei Linux funktionieren :?
Bitte keine Fragen per PN, die gehören ins Forum!

Heiko2018
Beiträge: 5
Registriert: 15.06.2018, 07:10
Wohnort: Kerpen

Re: Admin nicht mehr erreichbar Fehler HTTP/1.1 404 Not Found

Beitrag von Heiko2018 » 15.06.2018, 12:20

Hallo,

gelaufen ist es schon mal. Im Moment läuft es zu Testzwecken auf meinen Desktop-PC, den ich abends immer runterfahre.
Nach der Eingabe kam folgendes:

Code: Alles auswählen

C:\ioBroker>node node_modules/iobroker.js-controller/iobroker.js list instances
system.adapter.admin.0                 : admin       -  enabled, port: 8081, bind: 192.168.178.45, run as: admin
system.adapter.b-control-em.0          : b-control-em -  enabled
system.adapter.discovery.0             : discovery   -  enabled
system.adapter.fronius.0               : fronius     -  enabled
system.adapter.history.0               : history     -  enabled
system.adapter.hue.0                   : hue         -  enabled, port: 80
system.adapter.javascript.0            : javascript  -  enabled
system.adapter.knx.0                   : knx         -  enabled
system.adapter.mobile.0                : mobile      -  enabled
system.adapter.modbus.0                : modbus      -  enabled
system.adapter.ping.0                  : ping        -  enabled
system.adapter.sonos.0                 : sonos       -  enabled
system.adapter.vis-history.0           : vis-history -  enabled
system.adapter.vis.0                   : vis         -  enabled
system.adapter.web.0                   : web         -  enabled, port: 8082, bind: 0.0.0.0, run as: admin

C:\ioBroker>iobroker status

C:\ioBroker>node node_modules/iobroker.js-controller/iobroker.js status
iobroker is running

kmxak
professional
Beiträge: 905
Registriert: 10.03.2017, 21:00

Re: Admin nicht mehr erreichbar Fehler HTTP/1.1 404 Not Found

Beitrag von kmxak » 15.06.2018, 12:24

versuch mal folgendes:

Code: Alles auswählen

iobroker.js set admin.0 --bind 0.0.0.0
Gruß Alex

HP Gen 8 ESXi + HP Gen 7 ESXi Backup Server - VM Debian FHEM + ioBroker
Pi3 RaspberryMatic, Wemos D1, NodeMCU, Odroid C2, Pi3 + Zero W

Heiko2018
Beiträge: 5
Registriert: 15.06.2018, 07:10
Wohnort: Kerpen

Re: Admin nicht mehr erreichbar Fehler HTTP/1.1 404 Not Found

Beitrag von Heiko2018 » 15.06.2018, 12:30

Hallo,

jetzt läuft es wieder. Aber warum der genau ausgestiegen ist, weißt du auch nicht, oder?

LG Grüße

Heiko :D

kmxak
professional
Beiträge: 905
Registriert: 10.03.2017, 21:00

Re: Admin nicht mehr erreichbar Fehler HTTP/1.1 404 Not Found

Beitrag von kmxak » 15.06.2018, 12:35

ich hoffe ich erzähle jetzt keinen quatsch sonst bitte berichtigen.

Dein ioBroker hörte nur noch auf die IP Adresse: 192.168.178.45
mit den 0.0.0.0 hört er wieder auf jede IP die mit ihm sprechen will.

Woher die IP in deiner Config kommt weiß ich leider nicht.
Gruß Alex

HP Gen 8 ESXi + HP Gen 7 ESXi Backup Server - VM Debian FHEM + ioBroker
Pi3 RaspberryMatic, Wemos D1, NodeMCU, Odroid C2, Pi3 + Zero W

Benutzeravatar
wendy2702
guru
Beiträge: 2984
Registriert: 18.01.2016, 22:12
Wohnort: Herzogenrath

Re: Admin nicht mehr erreichbar Fehler HTTP/1.1 404 Not Found

Beitrag von wendy2702 » 15.06.2018, 12:40

Kein quatsch...

ich war gerade dabei deine Lösung zu tippen als mein Telefon gebimmelt hast.

Denke das wurde im Admin Adapter "versehentlich" hier eingestellt:
Admin_Listen_IP.jpg
Bitte keine Fragen per PN, die gehören ins Forum!

Heiko2018
Beiträge: 5
Registriert: 15.06.2018, 07:10
Wohnort: Kerpen

Re: Admin nicht mehr erreichbar Fehler HTTP/1.1 404 Not Found

Beitrag von Heiko2018 » 15.06.2018, 12:59

Hallo,

ich denke, du hast recht. Das werde ich so eingestellt haben, weil mein Rechner diese IP hat. Das hat dann erst mal funktioniert und nach dem Neustart das Ding "zerschossen". Danke dir für die schnelle Hilfe.

LG Heiko

Antworten