MagicMirror

Allgemeine Fragen und Info rund um ioBroker
schittl
professional
Beiträge: 122
Registriert: 19.07.2017, 20:57

Re: MagicMirror

Beitrag von schittl » 09.05.2018, 11:47

profimong hat geschrieben:
08.02.2018, 11:13
Wenn Interesse besteht kann ich die Scripte und Views gern zur Verfügung stellen.
Hallo profimong,

Mich würde interessieren wie Du folgendes umgesetzt hast:

- Ausschalten wir per Cronjob der Browser geschlossen und der Raspi heruntergefahren
- Autostartscript der Browser im Kioskmodus

Ebenfalls würde ich mich über die Views per Export freuen. Tolle Arbeit! Danke.

mfg
Falk
HW: 1 x Rock64 (ioBroker), 2 x Raspi 3 (CCU & MySQL/pihole), 2 x Arduino Mega 2560 R3 (I2C DS18B20 + LED)
SW: IOBroker, RaspberryMatic (2.31.25.20180324)
IO-Versionen: Host 1.2.3, Admin 2.0.9, node / nodejs 6.12.2, npm 3.10.10

Bradock
professional
Beiträge: 173
Registriert: 30.01.2017, 12:22

Re: MagicMirror

Beitrag von Bradock » 11.05.2018, 06:47

arteck hat geschrieben:
09.02.2018, 12:47
OstfrieseUnterwegs hat geschrieben:Kennt Ihr
https://www.fibaro.com/de/products/swipe/

Vlt kann man damit eine einfache Steuerung bauen. Leider nicht ganz billig.

vergis es zumindest jetzt.. openzwave unterstützt es noch nicht
Das mit Gestensteuerung hatte ich auch schon mal in meiner gedanklichen Planung. Da jedoch der Smart Mirror ins Bad in den Spiegelschrank integriert werden soll, dachte ich mir das da ganz schnell der WAF nach unten geht, wenn Frauchen vorm Spiegel das ausgiebige Haare kämmen prozessiert :lol:

Benutzeravatar
Bluefox
Site Admin
Beiträge: 8001
Registriert: 13.07.2014, 14:42
Kontaktdaten:

Re: MagicMirror

Beitrag von Bluefox » 13.05.2018, 23:11

Kannst du im Browser schauen ob die Daten kommen?

schittl
professional
Beiträge: 122
Registriert: 19.07.2017, 20:57

Re: MagicMirror

Beitrag von schittl » 14.05.2018, 10:39

Bluefox hat geschrieben:
13.05.2018, 23:11
Kannst du im Browser schauen ob die Daten kommen?
Aufruf per Browser funktioniert "http://192.168.2.xxx:8082/get/hm-rpc.0. ... EMPERATURE" oder meinst Du etwas anderes?
Ich versuche gerade den Fehler im "node_helper.js" zu finden... Vllt finde ich ja was ;)
HW: 1 x Rock64 (ioBroker), 2 x Raspi 3 (CCU & MySQL/pihole), 2 x Arduino Mega 2560 R3 (I2C DS18B20 + LED)
SW: IOBroker, RaspberryMatic (2.31.25.20180324)
IO-Versionen: Host 1.2.3, Admin 2.0.9, node / nodejs 6.12.2, npm 3.10.10

mertedav
Beiträge: 5
Registriert: 04.12.2017, 09:16

Re: MagicMirror

Beitrag von mertedav » 16.05.2018, 09:06

schittl hat geschrieben:
14.05.2018, 10:39
Bluefox hat geschrieben:
13.05.2018, 23:11
Kannst du im Browser schauen ob die Daten kommen?
Aufruf per Browser funktioniert "http://192.168.2.xxx:8082/get/hm-rpc.0. ... EMPERATURE" oder meinst Du etwas anderes?
Ich versuche gerade den Fehler im "node_helper.js" zu finden... Vllt finde ich ja was ;)
Hi schittl ,

hast du schon was herausgefunden?
Ich habe das gleiche Problem mit dem Adapter.

Benutzeravatar
Schaxxe
Beiträge: 7
Registriert: 29.01.2018, 13:48

Re: MagicMirror

Beitrag von Schaxxe » 16.05.2018, 12:13

mertedav hat geschrieben:
16.05.2018, 09:06
schittl hat geschrieben:
14.05.2018, 10:39
Bluefox hat geschrieben:
13.05.2018, 23:11
Kannst du im Browser schauen ob die Daten kommen?
Aufruf per Browser funktioniert "http://192.168.2.xxx:8082/get/hm-rpc.0. ... EMPERATURE" oder meinst Du etwas anderes?
Ich versuche gerade den Fehler im "node_helper.js" zu finden... Vllt finde ich ja was ;)
Hi schittl ,

hast du schon was herausgefunden?
Ich habe das gleiche Problem mit dem Adapter.
Same here

schittl
professional
Beiträge: 122
Registriert: 19.07.2017, 20:57

Re: MagicMirror

Beitrag von schittl » 16.05.2018, 14:34

mertedav hat geschrieben:
16.05.2018, 09:06
hast du schon was herausgefunden?
Ich habe das gleiche Problem mit dem Adapter.
Schaxxe hat geschrieben:
16.05.2018, 12:13
Same here
Bin leider noch nicht dazu gekommen. Melde mich sobald ich etwas finde... Sorry
HW: 1 x Rock64 (ioBroker), 2 x Raspi 3 (CCU & MySQL/pihole), 2 x Arduino Mega 2560 R3 (I2C DS18B20 + LED)
SW: IOBroker, RaspberryMatic (2.31.25.20180324)
IO-Versionen: Host 1.2.3, Admin 2.0.9, node / nodejs 6.12.2, npm 3.10.10

schittl
professional
Beiträge: 122
Registriert: 19.07.2017, 20:57

Re: MagicMirror

Beitrag von schittl » 16.05.2018, 19:04

Folgende Fehlermeldung bekomme ich:

Code: Alles auswählen

0|mm       | Invalid content-type.Expected application/json but received text/plain; charset=utf-8
0|mm       | Invalid content-type.Expected application/json but received text/plain; charset=utf-8
0|mm       | Invalid content-type.Expected application/json but received text/plain; charset=utf-8
0|mm       | Invalid content-type.Expected application/json but received text/plain; charset=utf-8
Aber wie ich das umgehen kann bin ich noch am forschen.
HW: 1 x Rock64 (ioBroker), 2 x Raspi 3 (CCU & MySQL/pihole), 2 x Arduino Mega 2560 R3 (I2C DS18B20 + LED)
SW: IOBroker, RaspberryMatic (2.31.25.20180324)
IO-Versionen: Host 1.2.3, Admin 2.0.9, node / nodejs 6.12.2, npm 3.10.10

xlitemk
Beiträge: 1
Registriert: 11.06.2018, 09:00

Re: MagicMirror

Beitrag von xlitemk » 11.06.2018, 09:13

Hallo zusammen,

das Problem mit dem dunklen Spiegel hatte ich auch und löste ichwie folgt:

bin im Internet auf mehrere Glaslieferanten gestoßen und letztlich
bei einem hängen geblieben.

Hier einmal ein link: https://www.brigla-shop.de/spiegel-spio ... irror.html

Die Kollegen vom Team haben sogar Mustersets im Angebot und laut Aussage eines Mitarbeiters
am Tel. kommt in naher Zukunft ein weiterer Spiegel auf den Markt der das Musterset
erweitert: :!: :)

nick21
starter
Beiträge: 21
Registriert: 20.10.2017, 12:47

Re: MagicMirror

Beitrag von nick21 » 01.07.2018, 13:24

gibt es schon neue Erkenntnisse bezüglich der Dateneinbindung in das MMM modul?

clabbo
Beiträge: 1
Registriert: 31.07.2018, 22:16

Re: MagicMirror

Beitrag von clabbo » 31.07.2018, 22:53

Hi.
Not sure if this is relevant to the discussion here but I noticed an error in the readme.md. I was looking into the code since I always had "undefined" as header for my devices and couldn't understand why.

This is what the documentation says:

Code: Alles auswählen

          { deviceName: 'writeHereTheName1',
            deviceStates: [
                              { id: 'mqtt.0.sensorX.temperature', icon: 'wi wi-thermometer', suffix: '°' },
                              { id: 'mqtt.0.sensorX.humidity',    icon: 'wi wi-humidity',    suffix: '%' }
                          ]
          },
...but I think it should "name" instead of "deviceName":

Code: Alles auswählen

          { name: 'writeHereTheName1',
            deviceStates: [
                              { id: 'mqtt.0.sensorX.temperature', icon: 'wi wi-thermometer', suffix: '°' },
                              { id: 'mqtt.0.sensorX.humidity',    icon: 'wi wi-humidity',    suffix: '%' }
                          ]
          },
At least it works for me :)

I do have one problem though - the module seems to fetch the right data and shows it on the screen for a minute. When the module is refreshed by the built in timer I get "---" instead of the correct data. It stays like this 2-3 minutes and then the right data is shown again for a minute. It sounds like a network issue but my other MagicMirror modules are working well and the iobroker server is indeed active on the network. Has anyone else noticed something similar.

/Claes

fischi87
professional
Beiträge: 232
Registriert: 29.11.2015, 14:01

Re: MagicMirror

Beitrag von fischi87 » 19.08.2018, 08:02

Hallo,

wie clabbo geschrieben hat, hat es bei mir auch so funktioniert das änder von "deviceName" zu "name" des wenigstens der name angezeigt wird.

mein problem ist jetzt noch das ich keine Daten bekommen.
hab mal im browser versucht aber da bekommen ich auch keine Daten unter "http://192.168.xxx.x:xxxx/hm-rpc.0.OEQ0xxxxxx.4.ACTUAL_TEMPERATURE
bekomme immer die Nachricht im browser "Cannot get ...."

kann mir da jemand helfen?

Antworten