js-controller 1.5.3 in latest verfügbar

Bitter aller die testen können, hier melden.
aleks-83
professional
Beiträge: 100
Registriert: 30.05.2018, 11:23

Re: js-controller 1.5.3 in latest verfügbar

Beitrag von aleks-83 » 18.09.2018, 08:42

Moin,

Ich habe gestern meinen Pi 3B neu aufgesetzt.
Also Rapsbian geflasht, ioBroker installiert. Alles manuell nach Anleitung.
Lief alles gut durch.

Dann direkt als erstes den JS Controller auf 1.5.3 geupdatet.
Anschließend Admin auf 3.5.9. (Weitere Daten in meiner Sig)

Bisher sind nur Admin, Discovery und der Web Adapter isntalliert.
Weiter keine Änderungen vorgenommen.

Im Log erhalte ich die folgende Meldungen:

Code: Alles auswählen

admin.0	2018-09-18 05:39:30.073	warn	Disable logging, because no one socket connected
admin.0	2018-09-18 05:39:21.710	info	Repository received successfully.
admin.0	2018-09-18 05:39:21.400	info	Use link "https://localhost:8081" to configure.
admin.0	2018-09-18 05:39:21.400	info	https server listening on port 8081
admin.0	2018-09-18 05:39:21.340	info	created middleware
admin.0	2018-09-18 05:39:20.585	info	received all states
admin.0	2018-09-18 05:39:20.568	warn	No repository source configured
:arrow: = Raspberry Pi 3B = Raspbian light Stretch = USB boot = no SD = JS 1.5.3 = Node.js v8.12.0 = NPM 4.6.1

Benutzeravatar
Stabilostick
professional
Beiträge: 809
Registriert: 23.05.2018, 14:52

js-controller 1.5.3 in latest verfügbar

Beitrag von Stabilostick » 18.09.2018, 08:43

Hört sich doch gut an. Jetzt noch den Verwahrungsort auswählen in der Admin-Konfiguration.....


Edit: woher kommt dann die letzte Zeile?
Zuletzt geändert von Stabilostick am 18.09.2018, 08:43, insgesamt 1-mal geändert.

aleks-83
professional
Beiträge: 100
Registriert: 30.05.2018, 11:23

Re: js-controller 1.5.3 in latest verfügbar

Beitrag von aleks-83 » 18.09.2018, 09:00

Das habe ich ja. der steht auf latest.
URL habe ich auch gecheckt.

In der zweiten Zeile meine log oben steht ja auch "repository received successfully".
Was bedeutet das denn dann?
:arrow: = Raspberry Pi 3B = Raspbian light Stretch = USB boot = no SD = JS 1.5.3 = Node.js v8.12.0 = NPM 4.6.1

Benutzeravatar
Homoran
guru
Beiträge: 13027
Registriert: 08.08.2014, 16:50

Re: js-controller 1.5.3 in latest verfügbar

Beitrag von Homoran » 18.09.2018, 10:44

aleks-83 hat geschrieben:
18.09.2018, 09:00
In der zweiten Zeile meine log oben steht ja auch "repository received successfully".
Was bedeutet das denn dann?
Das bedeutet, dass iobroker die aktuellen Versionen abfragen konnte.
Wenn danach keine Zahl in dem Adapter-"Reiter" steht bist du aktuell.

Gruß
Rainer
kein Support per PN!
Fragen im Forum stellen - es gibt fast nichts, was nicht auch für andere interessant ist.

aleks-83
professional
Beiträge: 100
Registriert: 30.05.2018, 11:23

Re: js-controller 1.5.3 in latest verfügbar

Beitrag von aleks-83 » 18.09.2018, 11:13

OK, dann verwirrt mich die Meldung "no repository source configured" und "disable logging, because no one socket connected" :|

Die sollten doch nicht auftaucehn, oder?
:arrow: = Raspberry Pi 3B = Raspbian light Stretch = USB boot = no SD = JS 1.5.3 = Node.js v8.12.0 = NPM 4.6.1

Benutzeravatar
smartboart
professional
Beiträge: 291
Registriert: 23.03.2018, 03:08
Wohnort: Deutschland

Re: js-controller 1.5.3 in latest verfügbar

Beitrag von smartboart » 18.09.2018, 22:12

Diese Meldung habe ich auch, kam aber mit dem Update auf Admin 3.5.9. ..jscontroller habe ich noch nicht hochgezogen...Verprobe das gerade in meinem Testfeld, nach dem letzten Alptraum im life system...

Benutzeravatar
smartboart
professional
Beiträge: 291
Registriert: 23.03.2018, 03:08
Wohnort: Deutschland

Re: js-controller 1.5.3 in latest verfügbar

Beitrag von smartboart » 18.09.2018, 22:16

nach dem upddate des js-controller habe ich in meinem Testfeld auch das Problem mit iobroker stop... killall.sh...
hier auch schon mehrfach beschrieben...

jscontroller 1.5.0 und Admin 3.5.8 funktionieren im zusammenspiel einwandfrei... Damit fahre ich gerade mein lifesystem bzw. bin nach dem Update wieder mit meinem Backup darauf zurück...

Benutzeravatar
apollon77
guru
Beiträge: 6556
Registriert: 10.04.2015, 12:27

Re: js-controller 1.5.3 in latest verfügbar

Beitrag von apollon77 » 18.09.2018, 23:27

Controller 1.5.0 bitte nicht nutzen!!! Wenn dann 1.5.3.


Gesendet vom Handy ...
How-to:
* Debug-Log für einen Adapter/Instanz einschalten? -> Instanzen -> Expertenomodus -> Spalte Loglevel/Log-Stufe

BigTastyBacon
Beiträge: 6
Registriert: 09.09.2017, 13:27

Re: js-controller 1.5.3 in latest verfügbar

Beitrag von BigTastyBacon » 19.09.2018, 07:33

Hallo zusammen,

ich hatte bis heute Früh die Controller-Version 1.5.0 laufen (ohne Probleme). Habe dann upgegraded auf 1.5.3 und dann hat alles verrückt gespielt. Im Reiter "Hosts" war ersichtlich, dass mehr als 2000 Ereignisse am Laufen waren, diverse Adapter haben Fehlermeldungen ausgegeben und der Slave-Pi wurde nicht mehr erkannt.

Bin wieder zurück auf 1.4.2 und nach einigen Restarts und viel Schwitzen rennt jetzt alles wieder :).

Konfig: Habe zwei Pi's im Multihost laufen.

Benutzeravatar
Kueppert
professional
Beiträge: 624
Registriert: 13.05.2017, 15:18
Wohnort: NRW

Re: js-controller 1.5.3 in latest verfügbar

Beitrag von Kueppert » 19.09.2018, 08:03

Hi, hab auch Multihost im Betrieb. Ich hab gestern das Update gemacht und bei mir sieht alles normal aus. Hab parallel node.js von 6 auf 8 aktualisiert.
Ich hatte erst den Host auf 1.5.3 angehoben, dann direkt hinterher den Slave. Auf dem master dann via reinstall.sh erst Mal bei kompilieren lassen (wegen node8) und dann beide Maschinen neu gestartet...

Gesendet von meinem HUAWEI RIO-L01 mit Tapatalk

Hardware: Raspberry Pi2 (als CCU) + Pi3 (SLAVE) + Intel NUC,Proxmox -> Debian 9 in VM (MASTER)
Ausstattung: Philips Hue, Synology 415+, RaZberry, FIBARO, HM Door Sensor & Messdose, div. Xiaomi-Sensoren

Benutzeravatar
arteck
guru
Beiträge: 1886
Registriert: 02.10.2016, 13:52
Wohnort: NRW

Re: js-controller 1.5.3 in latest verfügbar

Beitrag von arteck » 19.09.2018, 11:41

Kueppert hat geschrieben:
19.09.2018, 08:03
Hi, hab auch Multihost im Betrieb. Ich hab gestern das Update gemacht und bei mir sieht alles normal aus. Hab parallel node.js von 6 auf 8 aktualisiert.
Ich hatte erst den Host auf 1.5.3 angehoben, dann direkt hinterher den Slave. Auf dem master dann via reinstall.sh erst Mal bei kompilieren lassen (wegen node8) und dann beide Maschinen neu gestartet...

Gesendet von meinem HUAWEI RIO-L01 mit Tapatalk
bis auf das HTTPS Problem lief bei mir auch alles reibungslos...
auf alles Maschinen.. incl. node.js von 6 auf 8

@apollon77 : seid ihr an der Auth Problematik drann.. oder lohnt noch wenn ich die nutzen will der Rücksprung auf 1.4.2.. woche , 2, 3 ....

Benutzeravatar
apollon77
guru
Beiträge: 6556
Registriert: 10.04.2015, 12:27

Re: js-controller 1.5.3 in latest verfügbar

Beitrag von apollon77 » 19.09.2018, 12:41

Da die 1.5.x leider weiterhin noch Probleme hat und aber auch gerade andere Baustellen (z.B. Cloud Timeouts manchmal) sehr wichtig sind haben wir entschieden die 1.4.2 vom js-controller wieder als "latest" zu flaggen. Ab dem nächsten Repo-Update nächste Nacht sollte damit keiner mehr die 1.5.x als "latest" angezeigt bekommen.
Wer auf 1.5.x ist und alles tut kann gern dort bleiben.

Sobald die anderen Themen gefixt sind werden wir einen neuen Anlauf mit der 1.5.x machen.

So lange Danke für Eure Unterstützung und Geduld! Die nächste Runde kommt bald :-)

Ingo & Bluefox
How-to:
* Debug-Log für einen Adapter/Instanz einschalten? -> Instanzen -> Expertenomodus -> Spalte Loglevel/Log-Stufe

Benutzeravatar
arteck
guru
Beiträge: 1886
Registriert: 02.10.2016, 13:52
Wohnort: NRW

Re: js-controller 1.5.3 in latest verfügbar

Beitrag von arteck » 19.09.2018, 17:03

na das ist ne Ansage..

akamia
professional
Beiträge: 166
Registriert: 17.08.2014, 14:07

Re: js-controller 1.5.3 in latest verfügbar

Beitrag von akamia » 19.09.2018, 17:24

Hallo Ingo,

kannst Du auch eine Aussage zu node.js 10 treffen? Mein eines Testsystem läuft damit. Allerdings hagelt es weiterhin viele Fehlermeldungen bei js-Controler und Adapterinstallationen.

Helle

NUC6i3 / ProxMox 5.2 HM/FHEM/WifiLight/HUE/Tradfri/KM200/InfluxDB/RFlink/Plex/Smartmeter...
Equi: piVCCU, Arduinos, X4000, Z2000, Solo4K, SAMSUNG C & H, NAS OMV4/Win10Pro (JRMC/JRemote), 4x4 HDMImatrix, etc.

Benutzeravatar
Kueppert
professional
Beiträge: 624
Registriert: 13.05.2017, 15:18
Wohnort: NRW

Re: js-controller 1.5.3 in latest verfügbar

Beitrag von Kueppert » 19.09.2018, 19:34

Have auch festgestellt, dass meine einfachen Skripte nicht mehr laufen... Hab neue geschrieben, "Trigger auf zwave Bewegungssensor, dann Lampe an" Ich sehe, dass das Objekt auf true geht, Lampe bleibt aus. Sehr komisch, gehe dann auch zurück auf js1.4.2. Update war zwar reibungslos wie oben geschrieben, keine Fehler im log, aber Skripte laufen bei mir nicht mehr :D

Gesendet von meinem HUAWEI RIO-L01 mit Tapatalk

PS: beim Downgrade nur Fehler erhalten. EIn Hoch auf das Backup dass ich bei Proxmox vorher angelegt hatte...evtl schreibt hier jemand wissendes, wie man einen downgrade richtig macht. Der folgende Code scheint nicht richtig gewesen zu sein (hab drüberinstalliert):
NICHT NACHMACHEN

Code: Alles auswählen

npm install iobroker.js-controller@1.4.2 --production
NICHT NACHMACHEN

und der Vollständigkeit halber noch der Fehleroutput zu meinem fehlgeschlagenen Versuch:
Spoiler: Show hidden text

Code: Alles auswählen

thorsten@iobrokerNUC:~$ sudo su
[sudo] Passwort für thorsten:
root@iobrokerNUC:/home/thorsten# cd /opt/iobroker
root@iobrokerNUC:/opt/iobroker# iobroker stop
Stopping iobroker controller daemon...
iobroker controller daemon stopped.
fs.js:1123
  return binding.chmod(pathModule._makeLong(path), modeNum(mode));
                 ^

Error: ENOENT: no such file or directory, chmod '/opt/iobroker/node_modules/iobroker.js-controller/lib/../killall.sh'
    at Object.fs.chmodSync (fs.js:1123:18)
    at Daemon.daemon.on (/opt/iobroker/node_modules/iobroker.js-controller/lib/setup.js:286:32)
    at emitOne (events.js:121:20)
    at Daemon.emit (events.js:211:7)
    at Daemon.<anonymous> (/opt/iobroker/node_modules/daemonize2/lib/daemonize.js:267:14)
    at Daemon._tryKill (/opt/iobroker/node_modules/daemonize2/lib/daemonize.js:277:23)
    at ontimeout (timers.js:498:11)
    at tryOnTimeout (timers.js:323:5)
    at Timer.listOnTimeout (timers.js:290:5)
root@iobrokerNUC:/opt/iobroker# npm install iobroker.js-controller@1.4.2 --production

> iobroker.js-controller@1.4.2 preinstall /opt/iobroker/node_modules/iobroker.js-controller
> node lib/preinstall_check.js

NPM version: 6.4.1
npm version >= 5: disabling package-lock

> iobroker.js-controller@1.4.2 install /opt/iobroker/node_modules/iobroker.js-controller
> node iobroker.js setup first

Cannot delete file. Not critical: Error: EACCES: permission denied, unlink '/opt/iobroker/node_modules/iobroker.js-controller/lib/setup/../../_service_iobroker.bat'
Cannot delete file. Not critical: Error: EACCES: permission denied, unlink '/opt/iobroker/node_modules/iobroker.js-controller/lib/setup/../../iobroker.bat'
fs.js:885
  return binding.mkdir(pathModule._makeLong(path),
                 ^

Error: EACCES: permission denied, mkdir '/opt/iobroker/node_modules/iobroker.js-controller/lib/setup/../../tmp'
    at Object.fs.mkdirSync (fs.js:885:18)
    at Setup.setup (/opt/iobroker/node_modules/iobroker.js-controller/lib/setup/setupSetup.js:143:58)
    at /opt/iobroker/node_modules/iobroker.js-controller/lib/setup.js:629:27
    at processCommand (/opt/iobroker/node_modules/iobroker.js-controller/lib/setup.js:661:15)
    at Object.module.exports.execute (/opt/iobroker/node_modules/iobroker.js-controller/lib/setup.js:3166:5)
    at Object.<anonymous> (/opt/iobroker/node_modules/iobroker.js-controller/iobroker.js:1:100)
    at Module._compile (module.js:653:30)
    at Object.Module._extensions..js (module.js:664:10)
    at Module.load (module.js:566:32)
    at tryModuleLoad (module.js:506:12)
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! iobroker.js-controller@1.4.2 install: `node iobroker.js setup first`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the iobroker.js-controller@1.4.2 install script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /root/.npm/_logs/2018-09-19T21_12_59_931Z-debug.log
root@iobrokerNUC:/opt/iobroker#
Hardware: Raspberry Pi2 (als CCU) + Pi3 (SLAVE) + Intel NUC,Proxmox -> Debian 9 in VM (MASTER)
Ausstattung: Philips Hue, Synology 415+, RaZberry, FIBARO, HM Door Sensor & Messdose, div. Xiaomi-Sensoren

dtp
professional
Beiträge: 890
Registriert: 18.01.2016, 13:06

Re: js-controller 1.5.3 in latest verfügbar

Beitrag von dtp » 21.09.2018, 13:43

Nur kurz die Info, dass bei mir alle bisherigen Versionen des js-controllers problemlos im Docker-Abbild auf der Synology DiskStation liefen. Das gilt auch für die Version 1.5.3.
ioBroker im Docker-Container auf Synology DiskStation DS718+, HomeMatic mit über 100 HM-Geräten, DoorPi-Videosprechanlage auf Raspi 3, Homebridge und Viessmann-Steuerung per vcontrold und Optolink auf Raspi 3, Sprachsteuerung mit Siri und Alexa, etc.

Benutzeravatar
arteck
guru
Beiträge: 1886
Registriert: 02.10.2016, 13:52
Wohnort: NRW

Re: js-controller 1.5.3 in latest verfügbar

Beitrag von arteck » 21.09.2018, 17:50

dtp hat geschrieben:
21.09.2018, 13:43
Nur kurz die Info, dass bei mir alle bisherigen Versionen des js-controllers problemlos im Docker-Abbild auf der Synology DiskStation liefen. Das gilt auch für die Version 1.5.3.
dann schalte mal https mit auth ein ....

aftershowman
starter
Beiträge: 55
Registriert: 01.04.2016, 20:19

Re: js-controller 1.5.3 in latest verfügbar

Beitrag von aftershowman » 21.09.2018, 21:27

Hallo,

hab jetzt auf meinem PI erfolgreich den Downgrad von 1.53 - 1.42 gemacht.

HTTPS Webserver Instance läuft jetzt auch wieder.

Hier beschrieben:
viewtopic.php?f=22&t=16866
Homematic: CCU2 (2.17.15) ; 56 RF Geräte, 4 wired Geräte
ioBroker PC: Intel celeron 1007U 1.5GHz, 4GB RAM, 128 GB SSD

Antworten