[Aufruf] Philips-TV v0.1.0 testen

Bitter aller die testen können, hier melden.
Benutzeravatar
AlCalzone
guru
Beiträge: 2572
Registriert: 01.03.2016, 15:16

Re: [Aufruf] Philips-TV v0.1.0 testen

Beitrag von AlCalzone » 11.07.2018, 08:35

NemoN hat geschrieben:
10.07.2018, 21:31
leider nicht (Log vom Versuch "AmbilightOnOff" zu setzen):

Code: Alles auswählen

Cannot read property 'username' of undefined
Ein Großteil des Logs sieht gut aus. Das hier lässt mich vermuten, dass du nicht alle beschriebenen Schritte durchgeführt hast (Upload und anschließendes manuelles Setzen von Username + Passwort)
Meine Adapter:
IKEA Trådfri: GitHub | Test & Hilfe
G-Homa: GitHub | Test & Hilfe

PRozAC
starter
Beiträge: 15
Registriert: 31.05.2018, 07:18

Re: [Aufruf] Philips-TV v0.1.0 testen

Beitrag von PRozAC » 11.07.2018, 16:16

Ich komme auch nicht weiter...

User und pass sind generiert und im skript hinterlegt. Leider werden die Punkte nicht im Adapter system.adapter.philips-tv.0 angelegt.
Somit meckert das log natürlich, dass der TV erst gepaired werden muss.

Ich hatte die Punkte obj.native.username und obj.native.password auch schon händisch mit demselben Ergebnis angelegt.

Was kann ich denn sonst noch tun :)

Benutzeravatar
AlCalzone
guru
Beiträge: 2572
Registriert: 01.03.2016, 15:16

Re: [Aufruf] Philips-TV v0.1.0 testen

Beitrag von AlCalzone » 11.07.2018, 18:21

PRozAC hat geschrieben:
11.07.2018, 16:16
User und pass sind generiert und im skript hinterlegt. Leider werden die Punkte nicht im Adapter system.adapter.philips-tv.0 angelegt.
Zeig mir mal wie das Objekt aussieht (Reiter Raw).
Meine Adapter:
IKEA Trådfri: GitHub | Test & Hilfe
G-Homa: GitHub | Test & Hilfe

PRozAC
starter
Beiträge: 15
Registriert: 31.05.2018, 07:18

Re: [Aufruf] Philips-TV v0.1.0 testen

Beitrag von PRozAC » 11.07.2018, 18:27

Meinst du das?
44A9D6A9-4E08-40D8-86AA-9AFB766453D1.jpeg
8BCF9D76-5C74-4657-8257-E9070AB750FE.jpeg
9E55F4F1-FDAF-42B3-B23B-D81A47B7152E.jpeg
Falls nicht: bitte nochmal genauer erklären was gebraucht wird :D

schmuh
starter
Beiträge: 25
Registriert: 04.10.2016, 10:51

Re: [Aufruf] Philips-TV v0.1.0 testen

Beitrag von schmuh » 11.07.2018, 18:53

Ich schliesse mich an, ich bekomme die gleiche Fehlermeldung bei pressKey:
philips-tv.0 2018-07-11 19:49:10.871 debug connection is ALIVE
philips-tv.0 2018-07-11 19:49:10.858 debug checking if connection is alive
philips-tv.0 2018-07-11 19:49:00.851 debug connection is ALIVE
philips-tv.0 2018-07-11 19:49:00.840 debug checking if connection is alive
philips-tv.0 2018-07-11 19:48:56.494 error Error handling state change philips-tv.0.pressKey => Mute: Cannot read property 'username' of undefined
philips-tv.0 2018-07-11 19:48:56.494 debug <span style="color: #0087cb"> state with id philips-tv.0.pressKey updated: ack=false; val=Mute</span>

Hier das RAW aus system.adapter.philips-tv.0
Spoiler: Show hidden text
{
"from": "system.adapter.admin.0",
"ts": 1531331139693,
"common": {
"name": "philips-tv",
"version": "0.3.0-alpha4",
"title": "Philips TV",
"platform": "Javascript/Node.js",
"mode": "daemon",
"extIcon": "https://raw.githubusercontent.com/AlCal ... ips-tv.png",
"readme": "https://github.com/AlCalzone/ioBroker.p ... /README.md",
"loglevel": "debug",
"type": "multimedia",
"installedVersion": "0.3.0-alpha4",
"host": "SRV-IOB-002",
"enabled": true,
"messagebox": true,
"news": {
"0.3.0-alpha4": {
"en": "Support for TVs with API v5",
"de": "Fernseher mit API v5 unterstützt"
},
"0.2.0": {
"en": "Support sending key presses",
"de": "Senden von Tastendrücken unterstützt"
},
"0.1.0": {
"en": "Initial release",
"de": "Initiale Version"
}
},
"desc": {
"en": "Controls Philips TVs over the network",
"de": "Steuert Philips Fernseher über das Netzwerk"
},
"authors": [
"AlCalzone <d.griesel@gmx.net>"
],
"keywords": [
"philips",
"tv",
"remote"
],
"icon": "philips-tv.png"
},
"native": {
"host": "192.168.1.200",
"username": "vAGJGsrPDAvAKDZj",
"password": "e0eb098647dd3f205bb38ce75ada9060e3a6454d4e4423dc2cfcd09b8fa0f1a2"
},
"acl": {
"object": 1636,
"owner": "system.user.admin",
"ownerGroup": "system.group.administrator"
},
"_id": "system.adapter.philips-tv.0",
"type": "instance",
"enums": {}
}
Wenn ich beim Testen helfen kann, dann gerne.
Beste Grüße
Werner

Benutzeravatar
AlCalzone
guru
Beiträge: 2572
Registriert: 01.03.2016, 15:16

Re: [Aufruf] Philips-TV v0.1.0 testen

Beitrag von AlCalzone » 11.07.2018, 20:11

Was soll ich sagen... ich bin dumm :roll:

Die Zugangsdaten werden zwar eingelesen, aber nie verwendet. Ich darf euch nochmal bitten zu updaten und es damit zu probieren (alpha7).
Meine Adapter:
IKEA Trådfri: GitHub | Test & Hilfe
G-Homa: GitHub | Test & Hilfe

Ulfhednir
starter
Beiträge: 17
Registriert: 07.12.2016, 18:45

Re: [Aufruf] Philips-TV v0.1.0 testen

Beitrag von Ulfhednir » 11.07.2018, 21:13

Nachdem ich einige Zeit hier abstinent war und nicht wusste, ob es mit v6 weitergeht, bin ich nun doch positiv überrascht.
Ich habe mit deiner aktuellen Version soeben angesetzt. Die Pairingdaten konnte ich hinterlegen. Der Adapter ist grün.

Beim Tastendruck hänge ich nun auch. Ich habe per VIS versucht den Tastendruck zu simulieren.
Der Log sagt:

philips-tv.0 2018-07-11 20:11:55.979 error Error handling state change philips-tv.0.pressKey => true: Error: ESOCKETTIMEDOUT

schmuh
starter
Beiträge: 25
Registriert: 04.10.2016, 10:51

Re: [Aufruf] Philips-TV v0.1.0 testen

Beitrag von schmuh » 12.07.2018, 06:02

AlCalzone hat geschrieben:
11.07.2018, 20:11
Was soll ich sagen... ich bin dumm :roll:

Die Zugangsdaten werden zwar eingelesen, aber nie verwendet. Ich darf euch nochmal bitten zu updaten und es damit zu probieren (alpha7).
Ach komm, ich bitte dich. Wenn alle sich so einsetzen würden. Top Arbeit und mal herzlichen Dank. Ich versuche es heute Abend und gebe Bescheid.
Beste Grüße
Werner

Benutzeravatar
AlCalzone
guru
Beiträge: 2572
Registriert: 01.03.2016, 15:16

Re: [Aufruf] Philips-TV v0.1.0 testen

Beitrag von AlCalzone » 12.07.2018, 07:38

Ulfhednir hat geschrieben:
11.07.2018, 21:13
philips-tv.0 2018-07-11 20:11:55.979 error Error handling state change philips-tv.0.pressKey => true: Error: ESOCKETTIMEDOUT
Danke, dann bitte mal den Adapter auf Loglevel Debug stellen und den kompletten Auszug hier posten (Adapterstart bis Fehlschlagen des Tastendrucks).

Wenn es für jemanden möglich ist, wäre auch ein Traffic-Log zwischen Adapter und TV interessant (Wireshark).

Und wer ESOCKETTIMEDOUT bekommt und Lust hat darf gerne auch mal diesen Branch testen:
https://github.com/AlCalzone/ioBroker.p ... stom-agent
Meine Adapter:
IKEA Trådfri: GitHub | Test & Hilfe
G-Homa: GitHub | Test & Hilfe

schmuh
starter
Beiträge: 25
Registriert: 04.10.2016, 10:51

Re: [Aufruf] Philips-TV v0.1.0 testen

Beitrag von schmuh » 12.07.2018, 18:05

Hallo AlCalzone

mit der neuen Alpha sieht es nun anders aus, allerdings passiert am TV nichts beim sendKey. Hier das debug log.
Spoiler: Show hidden text
philips-tv.0 2018-07-12 09:54:58.595 debug no further attempts
philips-tv.0 2018-07-12 09:54:58.595 debug error is not recoverable
philips-tv.0 2018-07-12 09:54:58.595 debug attempt 1 failed with code undefined
philips-tv.0 2018-07-12 09:54:53.579 debug attempt 1 of 3
philips-tv.0 2018-07-12 09:54:53.579 debug getWithDigestAuth("audio/volume")
philips-tv.0 2018-07-12 09:54:53.575 debug connection is ALIVE
philips-tv.0 2018-07-12 09:54:53.562 debug attempt 1 of 3
philips-tv.0 2018-07-12 09:54:53.562 debug checking if connection is alive
philips-tv.0 2018-07-12 09:54:43.557 debug no further attempts
philips-tv.0 2018-07-12 09:54:43.556 debug error is not recoverable
philips-tv.0 2018-07-12 09:54:43.556 debug attempt 1 failed with code undefined
philips-tv.0 2018-07-12 09:54:38.544 debug attempt 1 of 3
philips-tv.0 2018-07-12 09:54:38.544 debug getWithDigestAuth("audio/volume")
philips-tv.0 2018-07-12 09:54:38.542 debug connection is ALIVE
philips-tv.0 2018-07-12 09:54:38.529 debug attempt 1 of 3
philips-tv.0 2018-07-12 09:54:38.529 debug checking if connection is alive
philips-tv.0 2018-07-12 09:54:31.410 error Error handling state change philips-tv.0.pressKey => VolumeUp: Error: ESOCKETTIMEDOUT
philips-tv.0 2018-07-12 09:54:31.410 debug no further attempts
philips-tv.0 2018-07-12 09:54:31.410 debug error is not recoverable
philips-tv.0 2018-07-12 09:54:31.409 debug attempt 1 failed with code undefined
philips-tv.0 2018-07-12 09:54:28.528 debug no further attempts
philips-tv.0 2018-07-12 09:54:28.528 debug error is not recoverable
philips-tv.0 2018-07-12 09:54:28.528 debug attempt 1 failed with code undefined
philips-tv.0 2018-07-12 09:54:26.392 debug attempt 1 of 3
philips-tv.0 2018-07-12 09:54:26.392 debug postJSONwithDigestAuth("input/key", {"key":"VolumeUp"})
philips-tv.0 2018-07-12 09:54:26.391 debug <span style="color: #0087cb"> state with id philips-tv.0.pressKey updated: ack=false; val=VolumeUp</span>
philips-tv.0 2018-07-12 09:54:23.513 debug attempt 1 of 3
philips-tv.0 2018-07-12 09:54:23.513 debug getWithDigestAuth("audio/volume")
philips-tv.0 2018-07-12 09:54:23.511 debug connection is ALIVE
philips-tv.0 2018-07-12 09:54:23.497 debug attempt 1 of 3
philips-tv.0 2018-07-12 09:54:23.496 debug checking if connection is alive
philips-tv.0 2018-07-12 09:54:13.493 debug no further attempts
philips-tv.0 2018-07-12 09:54:13.492 debug error is not recoverable
philips-tv.0 2018-07-12 09:54:13.492 debug attempt 1 failed with code undefined
philips-tv.0 2018-07-12 09:54:08.473 debug attempt 1 of 3
philips-tv.0 2018-07-12 09:54:08.473 debug getWithDigestAuth("audio/volume")
philips-tv.0 2018-07-12 09:54:08.471 debug connection is ALIVE
philips-tv.0 2018-07-12 09:54:08.451 debug attempt 1 of 3
philips-tv.0 2018-07-12 09:54:08.443 debug checking if connection is alive
philips-tv.0 2018-07-12 09:53:58.435 debug no further attempts
philips-tv.0 2018-07-12 09:53:58.434 debug error is not recoverable
philips-tv.0 2018-07-12 09:53:58.434 debug attempt 1 failed with code undefined
philips-tv.0 2018-07-12 09:53:53.419 debug attempt 1 of 3
philips-tv.0 2018-07-12 09:53:53.419 debug getWithDigestAuth("audio/volume")
philips-tv.0 2018-07-12 09:53:53.416 debug connection is ALIVE
philips-tv.0 2018-07-12 09:53:53.398 debug attempt 1 of 3
philips-tv.0 2018-07-12 09:53:53.397 debug checking if connection is alive
philips-tv.0 2018-07-12 09:53:43.396 debug no further attempts
philips-tv.0 2018-07-12 09:53:43.396 debug error is not recoverable
philips-tv.0 2018-07-12 09:53:43.395 debug attempt 1 failed with code undefined
philips-tv.0 2018-07-12 09:53:38.380 debug attempt 1 of 3
philips-tv.0 2018-07-12 09:53:38.380 debug getWithDigestAuth("audio/volume")
philips-tv.0 2018-07-12 09:53:38.377 debug connection is ALIVE
philips-tv.0 2018-07-12 09:53:38.349 debug attempt 1 of 3
philips-tv.0 2018-07-12 09:53:38.349 debug checking if connection is alive
philips-tv.0 2018-07-12 09:53:37.958 error Error handling state change philips-tv.0.pressKey => Mute: Error: ESOCKETTIMEDOUT
philips-tv.0 2018-07-12 09:53:37.957 debug no further attempts
philips-tv.0 2018-07-12 09:53:37.957 debug error is not recoverable
philips-tv.0 2018-07-12 09:53:37.957 debug attempt 1 failed with code undefined
philips-tv.0 2018-07-12 09:53:32.900 debug attempt 1 of 3
philips-tv.0 2018-07-12 09:53:32.900 debug postJSONwithDigestAuth("input/key", {"key":"Mute"})
philips-tv.0 2018-07-12 09:53:32.899 debug <span style="color: #0087cb"> state with id philips-tv.0.pressKey updated: ack=false; val=Mute</span>
philips-tv.0 2018-07-12 09:53:28.339 debug no further attempts
philips-tv.0 2018-07-12 09:53:28.339 debug error is not recoverable
philips-tv.0 2018-07-12 09:53:28.339 debug attempt 1 failed with code undefined
philips-tv.0 2018-07-12 09:53:23.320 debug attempt 1 of 3
philips-tv.0 2018-07-12 09:53:23.320 debug getWithDigestAuth("audio/volume")
philips-tv.0 2018-07-12 09:53:23.319 debug connection is ALIVE
philips-tv.0 2018-07-12 09:53:23.302 debug attempt 1 of 3
philips-tv.0 2018-07-12 09:53:23.302 debug checking if connection is alive
philips-tv.0 2018-07-12 09:53:13.296 debug no further attempts
philips-tv.0 2018-07-12 09:53:13.296 debug error is not recoverable
philips-tv.0 2018-07-12 09:53:13.295 debug attempt 1 failed with code undefined
philips-tv.0 2018-07-12 09:53:08.281 debug attempt 1 of 3
philips-tv.0 2018-07-12 09:53:08.280 debug getWithDigestAuth("audio/volume")
philips-tv.0 2018-07-12 09:53:08.278 info The TV at 192.168.1.200 is now reachable.
philips-tv.0 2018-07-12 09:53:08.277 debug <span style="color: #0087cb"> state with id philips-tv.0.info.connection updated: ack=true; val=true</span>
philips-tv.0 2018-07-12 09:53:08.270 debug <span style="color: #0087cb"> state with id philips-tv.0.info.paired updated: ack=true; val=true</span>
philips-tv.0 2018-07-12 09:53:08.265 debug <span style="color: #0087cb"> state with id philips-tv.0.info.requiresPairing updated: ack=true; val=true</span>
philips-tv.0 2018-07-12 09:53:08.262 debug <span style="color: #0087cb"> state with id philips-tv.0.info.apiVersion updated: ack=true; val=v6</span>
philips-tv.0 2018-07-12 09:53:08.255 debug TV has APIv6
philips-tv.0 2018-07-12 09:53:08.193 debug attempt 1 of 3
philips-tv.0 2018-07-12 09:53:08.193 debug get("audio/volume")
philips-tv.0 2018-07-12 09:53:08.190 debug testing APIv6
philips-tv.0 2018-07-12 09:53:08.083 debug API test for v5 failed. Reason: [undefined] 404 - "<html>\n<head>\n <title>Status page</title>\n</head>\n<body style=\"font-family: sans-serif;\">\n<p style=\"font-size: 1.2em;font-weight: bold;mar
philips-tv.0 2018-07-12 09:53:08.082 debug no further attempts
philips-tv.0 2018-07-12 09:53:08.082 debug error is not recoverable
philips-tv.0 2018-07-12 09:53:08.082 debug attempt 1 failed with code undefined
philips-tv.0 2018-07-12 09:53:08.066 debug attempt 1 of 3
philips-tv.0 2018-07-12 09:53:08.065 debug get("audio/volume")
philips-tv.0 2018-07-12 09:53:08.063 debug testing APIv5
philips-tv.0 2018-07-12 09:53:07.906 debug API test for v1 failed. Reason: [undefined] 404 - "<html>\n<head>\n <title>Status page</title>\n</head>\n<body style=\"font-family: sans-serif;\">\n<p style=\"font-size: 1.2em;font-weight: bold;mar
philips-tv.0 2018-07-12 09:53:07.905 debug no further attempts
philips-tv.0 2018-07-12 09:53:07.905 debug error is not recoverable
philips-tv.0 2018-07-12 09:53:07.905 debug attempt 1 failed with code undefined
philips-tv.0 2018-07-12 09:53:07.893 debug attempt 1 of 3
philips-tv.0 2018-07-12 09:53:07.893 debug get("audio/volume")
philips-tv.0 2018-07-12 09:53:07.891 debug testing APIv1
philips-tv.0 2018-07-12 09:53:07.891 debug detecting API version
philips-tv.0 2018-07-12 09:53:07.891 debug connection is ALIVE
philips-tv.0 2018-07-12 09:53:07.871 debug attempt 1 of 3
philips-tv.0 2018-07-12 09:53:07.871 debug checking if connection is alive
philips-tv.0 2018-07-12 09:53:07.869 debug initializing connection to 192.168.1.200
philips-tv.0 2018-07-12 09:53:07.838 info starting. Version 0.3.0-alpha7 in /opt/iobroker/node_modules/iobroker.philips-tv, node: v6.14.2
philips-tv.0 2018-07-12 09:53:07.708 debug statesDB connected
philips-tv.0 2018-07-12 09:53:07.691 debug objectDB connected
philips-tv.0 2018-07-12 09:53:04.787 info terminating
philips-tv.0 2018-07-12 09:53:04.785 debug <span style="color: #0087cb"> state with id philips-tv.0.info.connection updated: ack=true; val=false</span>
philips-tv.0 2018-07-12 09:53:02.211 debug attempt 1 of 3
philips-tv.0 2018-07-12 09:53:02.210 debug getWithDigestAuth("audio/volume")
philips-tv.0 2018-07-12 09:53:02.208 debug connection is ALIVE
philips-tv.0 2018-07-12 09:53:02.190 debug attempt 1 of 3
philips-tv.0 2018-07-12 09:53:02.189 debug checking if connection is alive
philips-tv.0 2018-07-12 09:52:52.184 debug no further attempts
philips-tv.0 2018-07-12 09:52:52.184 debug error is not recoverable
Ich habe dann auch mal die Version installiert:
https://github.com/AlCalzone/ioBroker.p ... stom-agent
Da kam allerdings folgende Meldung:
Spoiler: Show hidden text
philips-tv.0 2018-07-12 10:03:05.180 debug <span style="color: #0087cb"> state with id philips-tv.0.info.apiVersion updated: ack=true; val=unknown</span>
philips-tv.0 2018-07-12 10:03:05.175 warn The TV at 192.168.1.200 has an API version incompatible with this adapter!
philips-tv.0 2018-07-12 10:03:05.074 debug API test for v6 failed. Reason: [undefined] Error: Protocol "https:" not supported. Expected "http:"
philips-tv.0 2018-07-12 10:03:05.074 debug no further attempts
philips-tv.0 2018-07-12 10:03:05.073 debug error is not recoverable
philips-tv.0 2018-07-12 10:03:05.072 debug attempt 1 failed with code undefined
philips-tv.0 2018-07-12 10:03:05.066 debug attempt 1 of 3
philips-tv.0 2018-07-12 10:03:05.066 debug get("audio/volume")
philips-tv.0 2018-07-12 10:03:05.063 debug testing APIv6
philips-tv.0 2018-07-12 10:03:04.961 debug API test for v5 failed. Reason: [undefined] 404 - "<html>\n<head>\n <title>Status page</title>\n</head>\n<body style=\"font-family: sans-serif;\">\n<p style=\"font-size: 1.2em;font-weight: bold;mar
philips-tv.0 2018-07-12 10:03:04.961 debug no further attempts
philips-tv.0 2018-07-12 10:03:04.961 debug error is not recoverable
philips-tv.0 2018-07-12 10:03:04.960 debug attempt 1 failed with code undefined
philips-tv.0 2018-07-12 10:03:04.944 debug attempt 1 of 3
philips-tv.0 2018-07-12 10:03:04.944 debug get("audio/volume")
philips-tv.0 2018-07-12 10:03:04.941 debug testing APIv5
philips-tv.0 2018-07-12 10:03:04.840 debug API test for v1 failed. Reason: [undefined] 404 - "<html>\n<head>\n <title>Status page</title>\n</head>\n<body style=\"font-family: sans-serif;\">\n<p style=\"font-size: 1.2em;font-weight: bold;mar
philips-tv.0 2018-07-12 10:03:04.840 debug no further attempts
philips-tv.0 2018-07-12 10:03:04.840 debug error is not recoverable
philips-tv.0 2018-07-12 10:03:04.840 debug attempt 1 failed with code undefined
philips-tv.0 2018-07-12 10:03:04.828 debug attempt 1 of 3
philips-tv.0 2018-07-12 10:03:04.828 debug get("audio/volume")
philips-tv.0 2018-07-12 10:03:04.827 debug testing APIv1
philips-tv.0 2018-07-12 10:03:04.827 debug detecting API version
philips-tv.0 2018-07-12 10:03:04.826 debug connection is ALIVE
philips-tv.0 2018-07-12 10:03:04.807 debug attempt 1 of 3
philips-tv.0 2018-07-12 10:03:04.806 debug checking if connection is alive
philips-tv.0 2018-07-12 10:03:04.804 debug initializing connection to 192.168.1.200
philips-tv.0 2018-07-12 10:03:04.758 info starting. Version 0.3.0-alpha7 in /opt/iobroker/node_modules/iobroker.philips-tv, node: v6.14.2
philips-tv.0 2018-07-12 10:03:04.625 debug statesDB connected
philips-tv.0 2018-07-12 10:03:04.597 debug objectDB connected
philips-tv.0 2018-07-12 10:03:01.691 info terminating
philips-tv.0 2018-07-12 10:03:01.690 debug <span style="color: #0087cb"> state with id philips-tv.0.info.connection updated: ack=true; val=false</span>
philips-tv.0 2018-07-12 10:02:59.706 debug no further attempts
philips-tv.0 2018-07-12 10:02:59.706 debug error is not recoverable
philips-tv.0 2018-07-12 10:02:59.705 debug attempt 1 failed with code undefined
philips-tv.0 2018-07-12 10:02:54.695 debug attempt 1 of 3
philips-tv.0 2018-07-12 10:02:54.695 debug getWithDigestAuth("audio/volume")
philips-tv.0 2018-07-12 10:02:54.693 debug connection is ALIVE
philips-tv.0 2018-07-12 10:02:54.681 debug attempt 1 of 3
philips-tv.0 2018-07-12 10:02:54.680 debug checking if connection is alive
philips-tv.0 2018-07-12 10:02:44.677 debug no further attempts
philips-tv.0 2018-07-12 10:02:44.677 debug error is not recoverable
philips-tv.0 2018-07-12 10:02:44.677 debug attempt 1 failed with code undefined
philips-tv.0 2018-07-12 10:02:39.666 debug attempt 1 of 3
philips-tv.0 2018-07-12 10:02:39.666 debug getWithDigestAuth("audio/volume")
philips-tv.0 2018-07-12 10:02:39.664 debug connection is ALIVE
philips-tv.0 2018-07-12 10:02:39.652 debug attempt 1 of 3
philips-tv.0 2018-07-12 10:02:39.652 debug checking if connection is alive
philips-tv.0 2018-07-12 10:02:29.649 debug no further attempts
philips-tv.0 2018-07-12 10:02:29.649 debug error is not recoverable
philips-tv.0 2018-07-12 10:02:29.649 debug attempt 1 failed with code undefined
philips-tv.0 2018-07-12 10:02:24.638 debug attempt 1 of 3
philips-tv.0 2018-07-12 10:02:24.638 debug getWithDigestAuth("audio/volume")
philips-tv.0 2018-07-12 10:02:24.637 debug connection is ALIVE
philips-tv.0 2018-07-12 10:02:24.613 debug attempt 1 of 3
philips-tv.0 2018-07-12 10:02:24.613 debug checking if connection is alive
philips-tv.0 2018-07-12 10:02:14.610 debug no further attempts
philips-tv.0 2018-07-12 10:02:14.610 debug error is not recoverable
philips-tv.0 2018-07-12 10:02:14.609 debug attempt 1 failed with code undefined
philips-tv.0 2018-07-12 10:02:09.597 debug attempt 1 of 3
philips-tv.0 2018-07-12 10:02:09.597 debug getWithDigestAuth("audio/volume")
philips-tv.0 2018-07-12 10:02:09.594 debug connection is ALIVE
philips-tv.0 2018-07-12 10:02:09.580 debug attempt 1 of 3
philips-tv.0 2018-07-12 10:02:09.580 debug checking if connection is alive
philips-tv.0 2018-07-12 10:01:59.569 debug no further attempts
philips-tv.0 2018-07-12 10:01:59.569 debug error is not recoverable
philips-tv.0 2018-07-12 10:01:59.569 debug attempt 1 failed with code undefined
philips-tv.0 2018-07-12 10:01:54.555 debug attempt 1 of 3
philips-tv.0 2018-07-12 10:01:54.555 debug getWithDigestAuth("audio/volume")
philips-tv.0 2018-07-12 10:01:54.553 debug connection is ALIVE
philips-tv.0 2018-07-12 10:01:54.540 debug attempt 1 of 3
philips-tv.0 2018-07-12 10:01:54.539 debug checking if connection is alive
philips-tv.0 2018-07-12 10:01:44.537 debug no further attempts
philips-tv.0 2018-07-12 10:01:44.536 debug error is not recoverable
philips-tv.0 2018-07-12 10:01:44.536 debug attempt 1 failed with code undefined
philips-tv.0 2018-07-12 10:01:39.526 debug attempt 1 of 3
philips-tv.0 2018-07-12 10:01:39.526 debug getWithDigestAuth("audio/volume")
philips-tv.0 2018-07-12 10:01:39.523 debug connection is ALIVE
philips-tv.0 2018-07-12 10:01:39.511 debug attempt 1 of 3
philips-tv.0 2018-07-12 10:01:39.511 debug checking if connection is alive
philips-tv.0 2018-07-12 10:01:29.508 debug no further attempts
philips-tv.0 2018-07-12 10:01:29.508 debug error is not recoverable
philips-tv.0 2018-07-12 10:01:29.508 debug attempt 1 failed with code undefined
philips-tv.0 2018-07-12 10:01:24.498 debug attempt 1 of 3
philips-tv.0 2018-07-12 10:01:24.498 debug getWithDigestAuth("audio/volume")
philips-tv.0 2018-07-12 10:01:24.496 debug connection is ALIVE
philips-tv.0 2018-07-12 10:01:24.485 debug attempt 1 of 3
philips-tv.0 2018-07-12 10:01:24.484 debug checking if connection is alive
philips-tv.0 2018-07-12 10:01:14.482 debug no further attempts
philips-tv.0 2018-07-12 10:01:14.482 debug error is not recoverable
philips-tv.0 2018-07-12 10:01:14.482 debug attempt 1 failed with code undefined
philips-tv.0 2018-07-12 10:01:09.471 debug attempt 1 of 3
philips-tv.0 2018-07-12 10:01:09.471 debug getWithDigestAuth("audio/volume")
philips-tv.0 2018-07-12 10:01:09.469 debug connection is ALIVE
philips-tv.0 2018-07-12 10:01:09.452 debug attempt 1 of 3
philips-tv.0 2018-07-12 10:01:09.452 debug checking if connection is alive
philips-tv.0 2018-07-12 10:00:59.446 debug no further attempts
philips-tv.0 2018-07-12 10:00:59.446 debug error is not recoverable
philips-tv.0 2018-07-12 10:00:59.446 debug attempt 1 failed with code undefined
philips-tv.0 2018-07-12 10:00:54.435 debug attempt 1 of 3
philips-tv.0 2018-07-12 10:00:54.435 debug getWithDigestAuth("audio/volume")
philips-tv.0 2018-07-12 10:00:54.433 debug connection is ALIVE
philips-tv.0 2018-07-12 10:00:54.419 debug attempt 1 of 3
philips-tv.0 2018-07-12 10:00:54.419 debug checking if connection is alive
philips-tv.0 2018-07-12 10:00:44.397 debug no further attempts
philips-tv.0 2018-07-12 10:00:44.396 debug error is not recoverable
Beste Grüße
Werner

Ulfhednir
starter
Beiträge: 17
Registriert: 07.12.2016, 18:45

Re: [Aufruf] Philips-TV v0.1.0 testen

Beitrag von Ulfhednir » 12.07.2018, 19:10

Bei mir erfolgt das selbe Spielchen wie bei schmuh.
Spoiler: Show hidden text
philips-tv.0 2018-07-12 17:56:54.779 debug <span style="color: #0087cb"> state with id philips-tv.0.info.apiVersion updated: ack=true; val=unknown</span>
philips-tv.0 2018-07-12 17:56:54.765 warn The TV at 192.168.178.24 has an API version incompatible with this adapter!
philips-tv.0 2018-07-12 17:56:54.663 debug API test for v6 failed. Reason: [undefined] Error: Protocol "https:" not supported. Expected "http:"
philips-tv.0 2018-07-12 17:56:54.661 debug no further attempts
philips-tv.0 2018-07-12 17:56:54.661 debug error is not recoverable
philips-tv.0 2018-07-12 17:56:54.660 debug attempt 1 failed with code undefined
philips-tv.0 2018-07-12 17:56:54.650 debug attempt 1 of 3
philips-tv.0 2018-07-12 17:56:54.649 debug get("audio/volume")
philips-tv.0 2018-07-12 17:56:54.642 debug testing APIv6
philips-tv.0 2018-07-12 17:56:54.540 debug API test for v5 failed. Reason: [undefined] 404 - "<html>\n<head>\n <title>Status page</title>\n</head>\n<body style=\"font-family: sans-serif;\">\n<p style=\"font-size: 1.2em;font-weight: bold;mar
philips-tv.0 2018-07-12 17:56:54.538 debug no further attempts
philips-tv.0 2018-07-12 17:56:54.537 debug error is not recoverable
philips-tv.0 2018-07-12 17:56:54.535 debug attempt 1 failed with code undefined
philips-tv.0 2018-07-12 17:56:54.512 debug attempt 1 of 3
philips-tv.0 2018-07-12 17:56:54.511 debug get("audio/volume")
philips-tv.0 2018-07-12 17:56:54.505 debug testing APIv5
philips-tv.0 2018-07-12 17:56:54.404 debug API test for v1 failed. Reason: [undefined] 404 - "<html>\n<head>\n <title>Status page</title>\n</head>\n<body style=\"font-family: sans-serif;\">\n<p style=\"font-size: 1.2em;font-weight: bold;mar
philips-tv.0 2018-07-12 17:56:54.402 debug no further attempts
philips-tv.0 2018-07-12 17:56:54.401 debug error is not recoverable
philips-tv.0 2018-07-12 17:56:54.400 debug attempt 1 failed with code undefined
philips-tv.0 2018-07-12 17:56:54.366 debug attempt 1 of 3
philips-tv.0 2018-07-12 17:56:54.365 debug get("audio/volume")
philips-tv.0 2018-07-12 17:56:54.359 debug testing APIv1
philips-tv.0 2018-07-12 17:56:54.358 debug detecting API version
philips-tv.0 2018-07-12 17:56:54.357 debug connection is ALIVE
philips-tv.0 2018-07-12 17:56:54.182 debug attempt 1 of 3
philips-tv.0 2018-07-12 17:56:54.178 debug checking if connection is alive
philips-tv.0 2018-07-12 17:56:54.168 debug initializing connection to 192.168.178.24
philips-tv.0 2018-07-12 17:56:54.094 info starting. Version 0.3.0-alpha7 in /opt/iobroker/node_modules/iobroker.philips-tv, node: v6.14.3
philips-tv.0 2018-07-12 17:56:54.045 debug statesDB connected
philips-tv.0 2018-07-12 17:56:53.974 debug objectDB connected
Ich habe auch mal per FritzBox eine .eth aufgenommen und mal kurz mit Wireshark betrachtet. Allerdings bin ich mir unsicher, ob da etwas brauchbares dabei ist. Mal so am Rande: Wäre eine gemeinsame Teamviewer-Session zum Debuggen einmal sinnvoll? :geek:

Benutzeravatar
AlCalzone
guru
Beiträge: 2572
Registriert: 01.03.2016, 15:16

Re: [Aufruf] Philips-TV v0.1.0 testen

Beitrag von AlCalzone » 13.07.2018, 09:59

https://github.com/AlCalzone/ioBroker.p ... stom-agent bitte nochmal testen, ich hatte da was vergessen.

Der ursprüngliche Branch erfordert noch etwas mehr Arbeit meinerseits, da der Fehler nicht richtig erkannt wird.

@Ulfhednir: Magst du mir den Trafficlog mal zukommen lassen?
Meine Adapter:
IKEA Trådfri: GitHub | Test & Hilfe
G-Homa: GitHub | Test & Hilfe

schmuh
starter
Beiträge: 25
Registriert: 04.10.2016, 10:51

Re: [Aufruf] Philips-TV v0.1.0 testen

Beitrag von schmuh » 13.07.2018, 11:03

AlCalzone hat geschrieben:
13.07.2018, 09:59
https://github.com/AlCalzone/ioBroker.p ... stom-agent bitte nochmal testen, ich hatte da was vergessen.

Der ursprüngliche Branch erfordert noch etwas mehr Arbeit meinerseits, da der Fehler nicht richtig erkannt wird.

@Ulfhednir: Magst du mir den Trafficlog mal zukommen lassen?
Kann leider erst nach dem Urlaub weitertesten. Bis denne.
Beste Grüße
Werner

Ulfhednir
starter
Beiträge: 17
Registriert: 07.12.2016, 18:45

Re: [Aufruf] Philips-TV v0.1.0 testen

Beitrag von Ulfhednir » 13.07.2018, 18:36

AlCalzone hat geschrieben:
13.07.2018, 09:59
https://github.com/AlCalzone/ioBroker.p ... stom-agent bitte nochmal testen, ich hatte da was vergessen.
Spoiler: Show hidden text
philips-tv.0 2018-07-13 17:29:34.372 debug attempt 1 of 3
philips-tv.0 2018-07-13 17:29:34.370 debug getWithDigestAuth("audio/volume")
philips-tv.0 2018-07-13 17:29:34.362 info The TV at 192.168.178.24 is now reachable.
philips-tv.0 2018-07-13 17:29:34.358 debug <span style="color: #0087cb"> state with id philips-tv.0.info.connection updated: ack=true; val=true</span>
philips-tv.0 2018-07-13 17:29:34.328 debug <span style="color: #0087cb"> state with id philips-tv.0.info.paired updated: ack=true; val=true</span>
philips-tv.0 2018-07-13 17:29:34.314 debug <span style="color: #0087cb"> state with id philips-tv.0.info.requiresPairing updated: ack=true; val=true</span>
philips-tv.0 2018-07-13 17:29:34.296 debug <span style="color: #0087cb"> state with id philips-tv.0.info.apiVersion updated: ack=true; val=v6</span>
philips-tv.0 2018-07-13 17:29:34.264 debug TV has APIv6
philips-tv.0 2018-07-13 17:29:33.984 debug attempt 1 of 3
philips-tv.0 2018-07-13 17:29:33.982 debug get("audio/volume")
philips-tv.0 2018-07-13 17:29:33.969 debug testing APIv6
philips-tv.0 2018-07-13 17:29:33.866 debug API test for v5 failed. Reason: [undefined] 404 - "<html>\n<head>\n <title>Status page</title>\n</head>\n<body style=\"font-family: sans-serif;\">\n<p style=\"font-size: 1.2em;font-weight: bold;mar
philips-tv.0 2018-07-13 17:29:33.863 debug no further attempts
philips-tv.0 2018-07-13 17:29:33.861 debug error is not recoverable
philips-tv.0 2018-07-13 17:29:33.858 debug attempt 1 failed with code undefined
philips-tv.0 2018-07-13 17:29:33.824 debug attempt 1 of 3
philips-tv.0 2018-07-13 17:29:33.822 debug get("audio/volume")
philips-tv.0 2018-07-13 17:29:33.811 debug testing APIv5
philips-tv.0 2018-07-13 17:29:33.707 debug API test for v1 failed. Reason: [undefined] 404 - "<html>\n<head>\n <title>Status page</title>\n</head>\n<body style=\"font-family: sans-serif;\">\n<p style=\"font-size: 1.2em;font-weight: bold;mar
philips-tv.0 2018-07-13 17:29:33.704 debug no further attempts
philips-tv.0 2018-07-13 17:29:33.702 debug error is not recoverable
philips-tv.0 2018-07-13 17:29:33.699 debug attempt 1 failed with code undefined
philips-tv.0 2018-07-13 17:29:33.652 debug attempt 1 of 3
philips-tv.0 2018-07-13 17:29:33.650 debug get("audio/volume")
philips-tv.0 2018-07-13 17:29:33.636 debug testing APIv1
philips-tv.0 2018-07-13 17:29:33.635 debug detecting API version
philips-tv.0 2018-07-13 17:29:33.631 debug connection is ALIVE
philips-tv.0 2018-07-13 17:29:33.517 debug attempt 1 of 3
philips-tv.0 2018-07-13 17:29:33.508 debug checking if connection is alive
philips-tv.0 2018-07-13 17:29:33.489 debug initializing connection to 192.168.178.24
philips-tv.0 2018-07-13 17:29:33.292 info starting. Version 0.3.0-alpha7 in /opt/iobroker/node_modules/iobroker.philips-tv, node: v6.14.3
philips-tv.0 2018-07-13 17:29:33.157 debug statesDB connected
philips-tv.0 2018-07-13 17:29:32.990 debug objectDB connected
Beim Klick über VIS passiert noch nicht viel. Der Ereignisse-Log ist allerdings interessant, da Zustandsänderungen (Lautstärke mit Fernseh-Fernbedienung geändert) am TV erkannt werden.
Spoiler: Show hidden text
stateChange system.adapter.philips-tv.0.outputCount 9 true philips-tv.0 2018-07-13 19:31:48.417 2018-07-13 19:31:48.417
stateChange system.adapter.philips-tv.0.inputCount 1 true philips-tv.0 2018-07-13 19:31:48.413 2018-07-13 19:31:18.426
stateChange system.adapter.philips-tv.0.uptime 139 true philips-tv.0 2018-07-13 19:31:48.404 2018-07-13 19:31:48.404
stateChange system.adapter.philips-tv.0.memHeapUsed 15.43 true philips-tv.0 2018-07-13 19:31:48.403 2018-07-13 19:31:48.403
stateChange system.adapter.philips-tv.0.memHeapTotal 17.98 true philips-tv.0 2018-07-13 19:31:48.401 2018-07-13 19:31:48.401
stateChange system.adapter.philips-tv.0.memRss 38.26 true philips-tv.0 2018-07-13 19:31:48.399 2018-07-13 19:31:48.399
stateChange system.adapter.philips-tv.0.connected true true philips-tv.0 2018-07-13 19:31:48.398 2018-07-13 19:29:33.398
stateChange system.adapter.philips-tv.0.alive true true philips-tv.0 2018-07-13 19:31:48.393 2018-07-13 19:29:33.394
stateChange philips-tv.0.volume 40 true philips-tv.0 2018-07-13 19:31:46.592 2018-07-13 19:31:46.592
stateChange system.adapter.philips-tv.0.outputCount 8 true philips-tv.0 2018-07-13 19:31:33.403 2018-07-13 19:31:03.390
stateChange system.adapter.philips-tv.0.inputCount 1 true philips-tv.0 2018-07-13 19:31:33.401 2018-07-13 19:31:18.426
stateChange system.adapter.philips-tv.0.uptime 124 true philips-tv.0 2018-07-13 19:31:33.400 2018-07-13 19:31:33.400
stateChange system.adapter.philips-tv.0.memHeapUsed 20.59 true philips-tv.0 2018-07-13 19:31:33.398 2018-07-13 19:31:33.398
stateChange system.adapter.philips-tv.0.memHeapTotal 30.98 true philips-tv.0 2018-07-13 19:31:33.396 2018-07-13 19:29:48.321
stateChange system.adapter.philips-tv.0.memRss 46.81 true philips-tv.0 2018-07-13 19:31:33.395 2018-07-13 19:31:33.395
stateChange system.adapter.philips-tv.0.connected true true philips-tv.0 2018-07-13 19:31:33.393 2018-07-13 19:29:33.398
stateChange system.adapter.philips-tv.0.alive true true philips-tv.0 2018-07-13 19:31:33.389 2018-07-13 19:29:33.394
stateChange philips-tv.0.pressKey
AlCalzone hat geschrieben:
13.07.2018, 09:59
@Ulfhednir: Magst du mir den Trafficlog mal zukommen lassen?
Auf meiner Fritte ist einiges an Traffic, auch einige unverschlüsselte Dienste. Die eth-Datei müsste ich erst entsprechend aufbereiten.

Jan201
starter
Beiträge: 31
Registriert: 30.11.2017, 12:24

Re: [Aufruf] Philips-TV v0.1.0 testen

Beitrag von Jan201 » 15.07.2018, 14:08

AlCalzone hat geschrieben:
18.06.2018, 08:37
Du hast einen Fernseher mit v6-API, welcher ein initiales Pairing mit dem ioBroker-Gerät benötigt. Bin leider noch nicht dazu gekommen, das ins Admin-Interface einzubauen.
Es gibt einen Workaround, den andere Poster in diesem Thread beschrieben haben:
- Pairing über ein Python-Skript
- "manuelles" Eintragen von Username/Passwort mittels Skript (siehe vorvorletzer Beitrag).

Wichtig ist außerdem, dass du nach Github-Installationen immer noch einen Upload des Adapters durchführst (Adapter-Liste/Expertenmodus).
Moin,

Also ich hänge derzeit dabei einen Username und password zu generieren. und wo muss der eingetragen werden? und das mit dem pairing über Python verstehe ich ach nicht bzw habe da nix zu gefunden

Benutzeravatar
AlCalzone
guru
Beiträge: 2572
Registriert: 01.03.2016, 15:16

Re: [Aufruf] Philips-TV v0.1.0 testen

Beitrag von AlCalzone » 15.07.2018, 16:52

Ulfhednir hat geschrieben:
13.07.2018, 18:36
Beim Klick über VIS passiert noch nicht viel. Der Ereignisse-Log ist allerdings interessant, da Zustandsänderungen (Lautstärke mit Fernseh-Fernbedienung geändert) am TV erkannt werden.
Auch wenn nichts viel passiert, sollte doch zumindest was im Debug-Log auftauchen, oder? Diese Infos sind für mich interessant.
Auf meiner Fritte ist einiges an Traffic, auch einige unverschlüsselte Dienste. Die eth-Datei müsste ich erst entsprechend aufbereiten.
Kannst du den Traffic limitieren auf bestimmte IPs? So kann man bspw. in Wireshark nur das nötigste aufnehmen.
Meine Adapter:
IKEA Trådfri: GitHub | Test & Hilfe
G-Homa: GitHub | Test & Hilfe

akr1983
Beiträge: 6
Registriert: 19.07.2018, 21:28

Re: [Aufruf] Philips-TV v0.1.0 testen

Beitrag von akr1983 » 19.07.2018, 21:33

Hiho,

also erstmal Respekt vor der Arbeit die du dir da gemacht hast und dass du jetzt auch den Ehrgeiz hast es weiter zu machen. Ich bin einer der Api V6 Kandidaten ;-)

Leider war ich auf dem Pi zu doof das Python Script ans laufen zu bekommen, allerdings kann ich beim mitschneiden mit der Fritzbox helfen. Sofern vorhanden auf der Kommandozeile folgendes eingeben:

Code: Alles auswählen

tcpdump host "<IP vom Fernseher>" -w output.dat
Dann wird nur der Verkehr vom Fernseher und dem Host mitgeschnitten (wenn er denn über die FB läuft). Die Output.dat musst du dann nur runterladen und alcazone zur Verfügung stellen.

Liebe Grüße
Arne

Benutzeravatar
AlCalzone
guru
Beiträge: 2572
Registriert: 01.03.2016, 15:16

Re: [Aufruf] Philips-TV v0.1.0 testen

Beitrag von AlCalzone » 24.07.2018, 12:50

Hallo zusammen,

auf Github wurde mir bestätigt, dass der experimentelle Branch die ESOCKETTIMEDOUT-Fehler behebt. Ich habe diesen jetzt in den api-v5+v6 Branch gemerged. Wäre super, wenn jemand mit einem v6-Fernseher hier nochmal updaten und testen könnte.
Meine Adapter:
IKEA Trådfri: GitHub | Test & Hilfe
G-Homa: GitHub | Test & Hilfe

Ulfhednir
starter
Beiträge: 17
Registriert: 07.12.2016, 18:45

Re: [Aufruf] Philips-TV v0.1.0 testen

Beitrag von Ulfhednir » 25.07.2018, 22:17

Sorry, ich konnte in letzter Zeit kein Feedback geben, da mein Rechner geschrottet war. Mein letzter Stand war der, dass in Version 0.3.0-alpha7 der ESOCKETTIMEDOUT-Fehler bestand. Dieser ist nun im api-v5+v6 Branch gefixed? Mit welcher URL kann diese Version installiert und getestet werden?

akr1983
Beiträge: 6
Registriert: 19.07.2018, 21:28

Re: [Aufruf] Philips-TV v0.1.0 testen

Beitrag von akr1983 » 25.07.2018, 23:08

AlCalzone hat geschrieben:
13.07.2018, 09:59
https://github.com/AlCalzone/ioBroker.p ... stom-agent bitte nochmal testen, ich hatte da was vergessen.

Der ursprüngliche Branch erfordert noch etwas mehr Arbeit meinerseits, da der Fehler nicht richtig erkannt wird.

@Ulfhednir: Magst du mir den Trafficlog mal zukommen lassen?
Ich wollte jetzt Testen, aber leider ohne Erfolg. Bei dem Link kommt nur ein 404.
Und wenn ich die Version mit V5+V6 am Ende der URL installiere, mault er mich an, dass ich das der Fernseher gepaired werden muss. Benutzername und Kennwort hab ich bereits über das Script gesetzt.

Lg
Arne

Antworten