manche Widgets plötzlich nicht mehr sichtbar

Fragen zu Konfiguration und Bedienung des ioBroker.vis Adapter
Antworten
ManuelW
starter
Beiträge: 28
Registriert: 26.02.2018, 13:24

manche Widgets plötzlich nicht mehr sichtbar

Beitrag von ManuelW » 20.04.2018, 13:29

Hallo zusammen,

ich habe seit kurzem ein merkwürdiges Problem.
Einige Widgets, darunter zB "Slider Tabs" und "Fullscreen", sehe ich weder im Editor wenn ich sie in die View ziehe,
noch in der Ansicht.

Die Widgets tauchen aber im Editor in der Widgetsliste auf, ich kann es dort auch auswählen und editieren,
aber In der View wird es nicht sichtbar. Die Widgets haben aber def. schon funktioniert.

Hat jemand einen Tipp woran das liegen könnte?

PS: upload all habe ich schon probiert.

Benutzeravatar
arteck
guru
Beiträge: 1924
Registriert: 02.10.2016, 13:52
Wohnort: NRW

Re: manche Widgets plötzlich nicht mehr sichtbar

Beitrag von arteck » 24.04.2018, 08:32

schaumal was du als Anzeigewerte /Positionierung angegeben hast

darauf bin ich auch schon mal reingefallen.. ich habe manche View mit % und nicht mit px angegeben ..

ManuelW
starter
Beiträge: 28
Registriert: 26.02.2018, 13:24

Re: manche Widgets plötzlich nicht mehr sichtbar

Beitrag von ManuelW » 24.04.2018, 08:39

Alles schon versucht, feste Positionierung angegeben, neue View erstellt und es dort versucht, nix.
Es wird einfach nicht angezeigt.

Benutzeravatar
Dutchman
guru
Beiträge: 3947
Registriert: 07.01.2016, 23:42

Re: manche Widgets plötzlich nicht mehr sichtbar

Beitrag von Dutchman » 24.04.2018, 11:43

Hast du Mal deinem Browser Cache gelöscht ?
Irgendwas am System geändert (Update zB)


-------------------------
Send from mobile device
Das schöne ios hat Auto Korrektur zum k****

Wer Schreibfehler findet darf sie behalten oder auf eBay verkaufen, mindest Umsatz 10% für die community

ManuelW
starter
Beiträge: 28
Registriert: 26.02.2018, 13:24

Re: manche Widgets plötzlich nicht mehr sichtbar

Beitrag von ManuelW » 24.04.2018, 11:46

Das Problem besteht an mehreren (allen) Rechnern und verschiedenen Browsern. Cache geleert, komplette Inhalte gelöscht usw., ohne Erfolg.

Ich mache nur die regelmäßigen Updates die reinflattern.

Benutzeravatar
Dutchman
guru
Beiträge: 3947
Registriert: 07.01.2016, 23:42

Re: manche Widgets plötzlich nicht mehr sichtbar

Beitrag von Dutchman » 24.04.2018, 11:47

Und ist das Problem nach einem Update entstanden ?


-------------------------
Send from mobile device
Das schöne ios hat Auto Korrektur zum k****

Wer Schreibfehler findet darf sie behalten oder auf eBay verkaufen, mindest Umsatz 10% für die community

ManuelW
starter
Beiträge: 28
Registriert: 26.02.2018, 13:24

Re: manche Widgets plötzlich nicht mehr sichtbar

Beitrag von ManuelW » 24.04.2018, 11:48

Naja, ich kann nicht genau sagen wann es entstanden ist, da ich ja nicht nach jedem Update in der VIS etwas editiere.
Aufgefallen ist es mir halt erst jetzt, als ich was neues erstellen wollte.

Benutzeravatar
Dutchman
guru
Beiträge: 3947
Registriert: 07.01.2016, 23:42

Re: manche Widgets plötzlich nicht mehr sichtbar

Beitrag von Dutchman » 24.04.2018, 11:54

ManuelW hat geschrieben:Naja, ich kann nicht genau sagen wann es entstanden ist, da ich ja nicht nach jedem Update in der VIS etwas editiere.
Aufgefallen ist es mir halt erst jetzt, als ich was neues erstellen wollte.
Hmm ok...
Einzige was mir noch einfällt jetzt währe ein Upload Kommando für die fehlende Widget setzten aus zu führen.
Gehlen Dan alle bei dir oder nur ein par ?
Und wo sie fehlen sind die alle vom selben Widget Satz ?


-------------------------
Send from mobile device
Das schöne ios hat Auto Korrektur zum k****

Wer Schreibfehler findet darf sie behalten oder auf eBay verkaufen, mindest Umsatz 10% für die community

Mento
starter
Beiträge: 69
Registriert: 12.12.2017, 09:59

Re: manche Widgets plötzlich nicht mehr sichtbar

Beitrag von Mento » 25.04.2018, 19:02

Hi,
bei mir wurden die Eigenschaften der Widgets nicht mehr Angezeigt.

Ich habe den vis Adapter dann ein mal Aktualisiert und folgendes durchgeführt:

cd /opt/iobroker
sudo iobroker stop
sudo iobroker upload vis
sudo iobroker start

Vielleicht hilft es dir ja auch.

Gruß
Mento

ManuelW
starter
Beiträge: 28
Registriert: 26.02.2018, 13:24

Re: manche Widgets plötzlich nicht mehr sichtbar

Beitrag von ManuelW » 25.04.2018, 22:07

Den upload habe ich schon 2x gemacht, hat aber nix geholfen.

Ich werde wohl vis mal komplett löschen und neu installieren müssen :(

Benutzeravatar
smartboart
professional
Beiträge: 292
Registriert: 23.03.2018, 03:08
Wohnort: Deutschland

Re: manche Widgets plötzlich nicht mehr sichtbar

Beitrag von smartboart » 26.04.2018, 15:41

Hallo, was kam bei dem Problem raus? Habe nämlich das Selbe Problem... siehe Foto...Auch alle Browser und 2 Endgeräte mit Vis-App...
Auch alles versucht, sogar buttons neu erstellt, und hatte sogar ein Backup vom Widget als es noch ging und habe dies wieder importiert und alles in einer neuen view erstellt und sämtliche Einstellungen durchprobiert...
Browser_Visualisierung_fehlenede_Buttens.PNG
Edit_Vis.PNG
Dateianhänge
Browser_Visualisierung_fehlenede_Buttens.PNG
Edit_Vis.PNG

Benutzeravatar
smartboart
professional
Beiträge: 292
Registriert: 23.03.2018, 03:08
Wohnort: Deutschland

Re: manche Widgets plötzlich nicht mehr sichtbar

Beitrag von smartboart » 30.04.2018, 23:15

Hallo habe herausgefunden, dass es sich um kopierte widgets handelt welch innerhalb der view kopiert wurden...sobald ich diese neu anlege also neu aus der auswahl links hole, werden sue wieder angezeit vlt.hilft das ja dem einen oder anderem weiter.

ManuelW
starter
Beiträge: 28
Registriert: 26.02.2018, 13:24

Re: manche Widgets plötzlich nicht mehr sichtbar

Beitrag von ManuelW » 01.05.2018, 06:56

Bei mir geht’s seit dem letzten Update vor 3 Tagen wieder.

Antworten