Probleme mit vis / jqui-ctrl-icon

Fragen zu Konfiguration und Bedienung des ioBroker.vis Adapter
Antworten
xelarep
starter
Beiträge: 34
Registriert: 26.02.2017, 21:46

Probleme mit vis / jqui-ctrl-icon

Beitrag von xelarep » 20.01.2018, 21:44

Hallo zusammen,

hab nach nem knappen Jahr Betrieb die letzten Wochen mal wieder an Erweiterungen meines ioBrokers gearbeitet, und bin dabei über ein früheres Problem gestossen:

Ich verwende für diverse Tätigkeiten zwei übereinander gestapelte jqui-ctrl-icons die ich über die Sichtbarkeit anzeigen lasse. Damit lassen sich je nach Schaltzustand bzw. Inhalte eines Datenpunkts verschiedene icons anzeigen. Bei Betätigung dieses sichtbaren Schalters kann auf einem anderen Datenpunkt eine Aktion ausgelöst werden. Dazu gibt es hier auch Beispiele hier im Forum.

Ich verwende dies unter anderem zum Steuern von Variablen in meiner HomeMatic, GästeWLAN Fritzbox ein/aus und neuerdings Sonoff S20 per MQTT. Das Problem besteht auf jeden Fall bei FritzBox und Sonoff.

Beispiel/mein Problem: ich mache abhängig von aktuellen Schaltzustand (AN/AUS) der S20 (.../stat/POWER) eine Lampenicon (AN/AUS ) sichtbar, das bei Aktivierung in den jeweils anderen Zustand schaltet (AUS/AN - .../cmnd/POWER)
Das funktioniert prinzipiell, sobald ich nicht an der Sonoff oder an der Weberfläche rumschalte. Hier kommt das ganze gelegentlich aus dem Tritt, obwohl die Stati zeitnah per MQTT aktualisiert werden (kann ich in der Objektanzeige der Adminoberfäche des ioBrokers prima mitverfolgen). Letztlich wird das ganze unbedienbar, und ich muss einmal "aussenrum" schalten.

Ich verstehe dieses aus dem Tritt kommen nicht: genau dafür hab ich ja die Abfrage auf den Status?

Ebenso kurios ist das verhalten bei der Anzeige: die icons bleiben i.d.R. grau hinterlegt, beim aus dem Tritt kommen werden diese aber orange wie bei z.B. bei meinen Standard Lichtschaltern (jqui-mfd ctrl Light)
Diese verwenden dieselben icons (aus icons-mfd-png).

Was kann ich tun? Ich möchte das Problem möglichst grundsätzlich lösen und nicht noch nen weiteren Adapter (Sonoff...) an den Start bringen.

2 Nebenkriegsschauplätze:
- heute ist nach einer längeren Testphase ioBroker-vis übers WLAN auf zwei verschiedenen Geräten nicht mehr erreichbar gewesen. Einzigste Abhilfe: FritzBox kurz stromlos machen. Alles andere in meinem Netz lief noch? Hatte ich vor nem halben Jahr in diesem Szenario schon mal :-(
- ich lass ioBroker-vis auf einem alten iPad1 als Wandpanel anzeigen. Dieses hängt sich mehr oder regelmässig alle 1-2 Wochen weg und schliesst das Panel.

Jemand eine Idee oder link in anderes Thema? Hab auf die Schnelle nix passendes gefunden :-(

Nachtrag - Versionen:
vis: 1.0.4
jqui: 1.0.9

Antworten