Разные ошибки

Сообщите об ошибках в ioBroker
koh
Beiträge: 4
Registriert: 29.11.2017, 10:18

Re: Разные ошибки

Beitrag von koh » 04.12.2017, 15:21

1.0.4 (2017.11.30)

(bluefox) Fix read of DB (range error)
Спасибо :D

IOBroker супер. Спасибо разработчикам. Снимаю шляпу. Давно искал решение для себя, перепробовал кучу разного софта, включая промышленные скады.
js-controller: 1.2.3 / node.js: v6.12.0 / npm: 3.10.10
admin: 2.0.9
web: 2.1.9 vis: 1.0.4

Server: Intel i5 / linux: Debian 9-amd64
Adapter: Siemens LOGO!8.FS4 , Modbus TCP

nnprject
Beiträge: 5
Registriert: 25.11.2016, 07:06

Re: Разные ошибки

Beitrag von nnprject » 17.01.2018, 10:09

Не вижу список драйверов, "Обработка.." висит бесконечно. Admin обновил, JS-controller тоже, не помогает. Что еще проверить ?
Dateianhänge
iobr.JPG

Benutzeravatar
instalator
guru
Beiträge: 1258
Registriert: 09.11.2014, 16:50
Wohnort: Барнаул
Kontaktdaten:

Re: Разные ошибки

Beitrag von instalator » 17.01.2018, 15:57

nnprject hat geschrieben:Не вижу список драйверов, "Обработка.." висит бесконечно. Admin обновил, JS-controller тоже, не помогает. Что еще проверить ?
попробуй репозиторий сменить на latest
Высокий уровень Децибел вреден для здоровья!
Мой блог

nnprject
Beiträge: 5
Registriert: 25.11.2016, 07:06

Re: Разные ошибки

Beitrag von nnprject » 18.01.2018, 04:17

смена репозитория ничего не меняет (

Benutzeravatar
instalator
guru
Beiträge: 1258
Registriert: 09.11.2014, 16:50
Wohnort: Барнаул
Kontaktdaten:

Re: Разные ошибки

Beitrag von instalator » 19.01.2018, 13:03

nnprject hat geschrieben:смена репозитория ничего не меняет (
сменил в настройках админа? справа значек шестеренки.
сервер обновил?
Высокий уровень Децибел вреден для здоровья!
Мой блог

nnprject
Beiträge: 5
Registriert: 25.11.2016, 07:06

Re: Разные ошибки

Beitrag von nnprject » 22.01.2018, 09:12

Все это делал, ничего не помогает.

fred17
Beiträge: 6
Registriert: 29.12.2016, 21:14

Re: Разные ошибки

Beitrag von fred17 » 07.02.2018, 16:33

Возникли проблемы с установкой и обновлением модулей. При установке или обновление вылетает такая ошибка.

Пример при установки телеграм
Spoiler: Show hidden text
$ ./iobroker add telegram
npm install iobroker.telegram --production --prefix "/opt/iobroker" (System call)
../src/node_contextify.cc:254: static void node::ContextifyContext::RunInDebugContext(const v8::FunctionCallbackInfo<v8::Value>&): Assertion `!debug_context.IsEmpty()' failed.
Aborted
ERROR: host.smarthome Cannot install iobroker.telegram: 134
ERROR: process exited with code 25
До этого все обновлялось и устанавливалось без проблем из Админки или из консоли.
Если модуль уже установлен, то без проблемам устанавливается второй, если установленный модуль удалить полностью и попробовать его установить, вылетает ошибка.

Куда копать?

Benutzeravatar
instalator
guru
Beiträge: 1258
Registriert: 09.11.2014, 16:50
Wohnort: Барнаул
Kontaktdaten:

Re: Разные ошибки

Beitrag von instalator » 11.02.2018, 10:46

fred17 hat geschrieben:Возникли проблемы с установкой и обновлением модулей. При установке или обновление вылетает такая ошибка.

Пример при установки телеграм
Spoiler: Show hidden text
$ ./iobroker add telegram
npm install iobroker.telegram --production --prefix "/opt/iobroker" (System call)
../src/node_contextify.cc:254: static void node::ContextifyContext::RunInDebugContext(const v8::FunctionCallbackInfo<v8::Value>&): Assertion `!debug_context.IsEmpty()' failed.
Aborted
ERROR: host.smarthome Cannot install iobroker.telegram: 134
ERROR: process exited with code 25
До этого все обновлялось и устанавливалось без проблем из Админки или из консоли.
Если модуль уже установлен, то без проблемам устанавливается второй, если установленный модуль удалить полностью и попробовать его установить, вылетает ошибка.

Куда копать?
nodejs какой версии? из админки тоже не обновляет?
Высокий уровень Децибел вреден для здоровья!
Мой блог

fred17
Beiträge: 6
Registriert: 29.12.2016, 21:14

Re: Разные ошибки

Beitrag von fred17 » 11.02.2018, 13:14

instalator hat geschrieben:
fred17 hat geschrieben:Возникли проблемы с установкой и обновлением модулей. При установке или обновление вылетает такая ошибка.

Пример при установки телеграм
Spoiler: Show hidden text
$ ./iobroker add telegram
npm install iobroker.telegram --production --prefix "/opt/iobroker" (System call)
../src/node_contextify.cc:254: static void node::ContextifyContext::RunInDebugContext(const v8::FunctionCallbackInfo<v8::Value>&): Assertion `!debug_context.IsEmpty()' failed.
Aborted
ERROR: host.smarthome Cannot install iobroker.telegram: 134
ERROR: process exited with code 25
До этого все обновлялось и устанавливалось без проблем из Админки или из консоли.
Если модуль уже установлен, то без проблемам устанавливается второй, если установленный модуль удалить полностью и попробовать его установить, вылетает ошибка.

Куда копать?
nodejs какой версии? из админки тоже не обновляет?

Версия node 4.7.0 из админки не обновляются. Заметил, что все это перестало работать после того как я обновил сервер с версии 1.2.1 или 1.2.2 (точно не помню какая перед этим стояла) на 1.2.3. До этого случая система работала год без сбоев.

Benutzeravatar
instalator
guru
Beiträge: 1258
Registriert: 09.11.2014, 16:50
Wohnort: Барнаул
Kontaktdaten:

Re: Разные ошибки

Beitrag von instalator » 17.02.2018, 08:08

fred17 hat geschrieben:
instalator hat geschrieben:
fred17 hat geschrieben:Возникли проблемы с установкой и обновлением модулей. При установке или обновление вылетает такая ошибка.

Пример при установки телеграм
Spoiler: Show hidden text
$ ./iobroker add telegram
npm install iobroker.telegram --production --prefix "/opt/iobroker" (System call)
../src/node_contextify.cc:254: static void node::ContextifyContext::RunInDebugContext(const v8::FunctionCallbackInfo<v8::Value>&): Assertion `!debug_context.IsEmpty()' failed.
Aborted
ERROR: host.smarthome Cannot install iobroker.telegram: 134
ERROR: process exited with code 25
До этого все обновлялось и устанавливалось без проблем из Админки или из консоли.
Если модуль уже установлен, то без проблемам устанавливается второй, если установленный модуль удалить полностью и попробовать его установить, вылетает ошибка.

Куда копать?
nodejs какой версии? из админки тоже не обновляет?

Версия node 4.7.0 из админки не обновляются. Заметил, что все это перестало работать после того как я обновил сервер с версии 1.2.1 или 1.2.2 (точно не помню какая перед этим стояла) на 1.2.3. До этого случая система работала год без сбоев.
Обнови ее до 6й хотябы
Высокий уровень Децибел вреден для здоровья!
Мой блог

Benutzeravatar
aurodionov
professional
Beiträge: 384
Registriert: 14.07.2014, 16:39
Wohnort: Россия, Тюмень
Kontaktdaten:

Re: Разные ошибки

Beitrag von aurodionov » 23.02.2018, 07:17

при обновлении через админку, а именно кнопочкой обновить всё (Выполнение команды: $ ./iobroker upgrade) остоянно вылазит ошибка
  • Выполнено с ошибкой: module.js:427 throw err; ^ SyntaxError: /opt/iobroker/node_modules/iobroker.vis-plumb/io-package.json: Unexpected string at Object.parse (native) at Object.Module._extensions..json (module.js:424:27) at Module.load (module.js:343:32) at Function.Module._load (module.js:300:12) at Module.require (module.js:353:17) at require (internal/module.js:12:17) at Upgrade.upgradeAdapter (/opt/iobroker/node_modules/iobroker.js-controller/lib/setup/setupUpgrade.js:167:27) at Upgrade.upgradeAdapterHelper (/opt/iobroker/node_modules/iobroker.js-controller/lib/setup/setupUpgrade.js:30:14) at Immediate._onImmediate (/opt/iobroker/node_modules/iobroker.js-controller/lib/setup/setupUpgrade.js:38:26) at processImmediate [as _immediateCallback] (timers.js:396:17)
Как исправить ? Забить не предлагать ,из-за этой ошибки не работает скрипт обновления
Пишу с пульта....

Bosya
starter
Beiträge: 32
Registriert: 14.08.2015, 14:02

Re: Разные ошибки

Beitrag von Bosya » 10.04.2018, 16:37

Добрый день.
После очередного сиситемного обновления iobroker перестал работать нормально.
Драйвер javascript в постоянном ребуте.
Похоже одновился nodejs. Переустановка nodejs и npm ничего не дала. Смена с 4 nodejs на 6 и назад тоже не помогла. Переустановка (скриптом reinstall) не помогла. Вывод iobroker update ниже.

Code: Alles auswählen

root@cubietruck:/opt/iobroker# iobroker update
Used repository: online
[Tue Apr 10 2018 18:25:56 GMT+0300 (EEST)] Timeout by read all package.json (190) seconds
update done
Adapter    "admin"         : npm error, installed 3.3.7
Adapter    "amazon-dash"   : npm error
Adapter    "artnet"        : npm error
Adapter    "b-control-em"  : npm error
Adapter    "benq"          : npm error
Adapter    "ble"           : npm error
Adapter    "bmw"           : npm error
Adapter    "boblight"      : npm error
Adapter    "bosesoundtouch": npm error
Adapter    "botvac"        : npm error
Adapter    "broadlink2"    : npm error
Adapter    "chromecast"    : npm error
Adapter    "cloud"         : npm error
Adapter    "cul"           : npm error
Adapter    "daikin"        : npm error
Adapter    "daswetter"     : npm error
Adapter    "deconz"        : npm error
Adapter    "discovery"     : npm error, installed 1.1.0
Adapter    "dwd"           : npm error
Adapter    "ebus"          : npm error
Adapter    "egigeozone"    : npm error
Adapter    "email"         : npm error
Adapter    "epson_stylus_px830": npm error
Adapter    "fakeroku"      : npm error
Adapter    "feiertage"     : npm error
Adapter    "fhem"          : npm error
Adapter    "find-my-iphone": npm error
Adapter    "firetv"        : npm error
Adapter    "flot"          : npm error, installed 1.7.7
Adapter    "foobar2000"    : npm error
Adapter    "fritzbox"      : npm error
Adapter    "fritzdect"     : npm error
Adapter    "fronius"       : npm error
Adapter    "fullcalendar"  : npm error
Adapter    "g-homa"        : npm error
Adapter    "geofency"      : npm error
Adapter    "habpanel"      : npm error
Adapter    "haier"         : npm error
Adapter    "harmony"       : npm error
Adapter    "hid"           : npm error
Adapter    "hilink"        : npm error
Adapter    "history"       : npm error
Adapter    "hm-rega"       : npm error
Adapter    "hm-rpc"        : npm error
Adapter    "hmm"           : npm error
Adapter    "homepilot"     : npm error
Adapter    "hs100"         : npm error
Adapter    "hue"           : npm error
Adapter    "hyperion"      : npm error
Adapter    "i2c"           : npm error
Adapter    "ical"          : npm error
Adapter    "icons-addictive-flavour-png": npm error
Adapter    "icons-fatcow-hosting": npm error
Adapter    "icons-icons8"  : npm error
Adapter    "icons-material-png": 0.1.1
Adapter    "icons-material-svg": 0.1.1
Adapter    "icons-mfd-png" : 1.0.2
Adapter    "icons-mfd-svg" : 1.0.2
Adapter    "icons-open-icon-library-png": 0.1.3
Adapter    "icons-ultimate-png": 1.0.1
Adapter    "influxdb"      : 1.5.2
Adapter    "info"          : 0.1.0
Adapter    "innogy-smarthome": 0.2.0
Adapter    "javascript"    : 3.6.4    , installed 3.6.4
Adapter    "jeelink"       : 0.0.4
Controller "js-controller" : 1.4.0    , installed 1.4.0
Adapter    "js2fs"         : 0.1.5
Adapter    "kecontact"     : 0.0.3
Adapter    "km200"         : 1.1.6
Adapter    "knx"           : 1.0.8
Adapter    "kodi"          : 1.0.0
Adapter    "landroid"      : 1.0.1
Adapter    "landroid-s"    : 2.0.1
Adapter    "lgtv"          : 1.0.4    , installed 1.0.3 [Updateable]
Adapter    "lgtv-rs"       : 0.0.4
Adapter    "lifx"          : 0.0.5
Adapter    "lightify"      : 0.2.16
Adapter    "loxone"        : 0.4.0
Adapter    "material"      : 0.5.7
Adapter    "maxcube"       : 0.1.2
Adapter    "maxcul"        : 0.5.3
Adapter    "mbus"          : 0.1.8
Adapter    "mclighting"    : 0.0.10
Adapter    "megad"         : 1.3.0    , installed 1.2.1 [Updateable]
Adapter    "megadd"        : 0.3.8
Adapter    "megaesp"       : 0.1.0    , installed 0.1.0
Adapter    "miele"         : 0.1.6
Adapter    "mihome"        : 1.0.5
Adapter    "mihome-lamp"   : 1.0.0
Adapter    "mihome-plug"   : 0.1.1
Adapter    "mihome-vacuum" : 1.0.1
Adapter    "mikrotik"      : 1.0.0
Adapter    "milight"       : 0.3.5
Adapter    "milight-smart-light": 0.1.9
Adapter    "mobile"        : 0.4.11   , installed 0.4.11
Adapter    "modbus"        : 1.1.0
Adapter    "mpd"           : 1.0.2
Adapter    "mqtt"          : 1.5.0    , installed 1.5.0
Adapter    "mqtt-client"   : 1.1.1
Adapter    "musiccast"     : 0.0.7
Adapter    "mysensors"     : 1.2.1
Adapter    "netatmo"       : 1.3.0
Adapter    "node-red"      : 1.5.1
Adapter    "noolite"       : 0.2.0
Adapter    "nut"           : 1.1.2
Adapter    "onkyo"         : 0.2.1
Adapter    "openhab"       : 0.2.1
Adapter    "owfs"          : 0.5.0
Adapter    "owntracks"     : 0.2.0
Adapter    "panasonic-viera": 0.1.0
Adapter    "parser"        : 1.0.1
Adapter    "paw"           : 0.1.7
Adapter    "phantomjs"     : 1.0.0
Adapter    "piface"        : 1.0.0
Adapter    "pimatic"       : 0.1.5
Adapter    "ping"          : 1.3.2    , installed 1.3.2
Adapter    "places"        : 0.6.0
Adapter    "plexconnect"   : 0.0.6
Adapter    "proxy"         : 1.0.1
Adapter    "pushbullet"    : 0.0.11
Adapter    "pushover"      : 1.0.4
Adapter    "pushsafer"     : 0.1.8
Adapter    "radar"         : 1.1.3
Adapter    "rflink"        : 1.2.0
Adapter    "rickshaw"      : 0.4.5
Adapter    "rpi2"          : 0.3.2
Adapter    "rwe-smarthome" : 0.1.11
Adapter    "s7"            : 1.1.3
Adapter    "samsung"       : 0.2.9
Adapter    "sayit"         : 1.6.7    , installed 1.6.7
Adapter    "sbfspot"       : 2.2.1
Adapter    "scenes"        : 1.0.2
Adapter    "simple-api"    : 1.6.3    , installed 1.6.2 [Updateable]
Adapter    "sma-em"        : 0.5.3
Adapter    "smartmeter"    : 1.1.2
Adapter    "snmp"          : 0.5.0
Adapter    "socketio"      : 2.0.0
Adapter    "solarwetter"   : 1.0.0
Adapter    "sonoff"        : 2.1.0
Adapter    "sonos"         : 1.6.2
Adapter    "sony-bravia"   : 0.1.0
Adapter    "sql"           : 1.7.4    , installed 1.7.3 [Updateable]
Adapter    "squeezebox"    : 0.2.1
Adapter    "starline"      : 1.0.0
Adapter    "synology"      : 0.0.3
Adapter    "systeminfo"    : 0.3.0
Adapter    "tankerkoenig"  : 1.0.5
Adapter    "telegram"      : 1.2.0    , installed 1.2.0
Adapter    "terminal"      : 0.1.2
Adapter    "text2command"  : 1.1.7
Adapter    "tr-064"        : 0.4.18
Adapter    "tradfri"       : 1.1.10
Adapter    "tvspielfilm"   : 1.0.4
Adapter    "unifi"         : 0.3.1
Adapter    "upnp"          : 0.3.7
Adapter    "vcard"         : 0.0.8
Adapter    "viessmann"     : 0.4.0
Adapter    "vis"           : 1.1.2    , installed 1.1.2
Adapter    "vis-bars"      : 0.1.4
Adapter    "vis-canvas-gauges": 0.1.5
Adapter    "vis-colorpicker": 1.1.1   , installed 1.1.1
Adapter    "vis-fancyswitch": 1.1.0
Adapter    "vis-google-fonts": 1.0.0
Adapter    "vis-history"   : 0.2.7
Adapter    "vis-hqwidgets" : 1.1.1
Adapter    "vis-jqui-mfd"  : 1.0.11
Adapter    "vis-justgage"  : 1.0.0
Adapter    "vis-keyboard"  : 0.0.2
Adapter    "vis-lcars"     : 1.0.4
Adapter    "vis-map"       : 1.0.1
Adapter    "vis-material"  : 0.1.3
Adapter    "vis-metro"     : 1.1.2
Adapter    "vis-players"   : 0.1.5
Adapter    "vis-plumb"     : 1.0.1
Adapter    "vis-rgraph"    : 0.0.2
Adapter    "vis-timeandweather": 1.1.7
Adapter    "vis-weather"   : 1.2.0
Adapter    "vr200"         : 0.2.0
Adapter    "weatherunderground": 1.1.2
Adapter    "web"           : 2.3.0    , installed 2.1.9 [Updateable]
Adapter    "wetty"         : 0.1.1
Adapter    "wifilight"     : 0.2.1
Adapter    "wm-bus"        : 0.3.1
Adapter    "wolf"          : 1.0.0
Adapter    "xs1"           : 1.0.2
Adapter    "yahka"         : 0.7.1
Adapter    "yamaha"        : 0.3.19
Adapter    "yr"            : 1.0.6
Adapter    "zont"          : 0.5.2
Adapter    "zwave"         : 1.0.0

root@cubietruck:/opt/iobroker# node -v
v6.14.1
root@cubietruck:/opt/iobroker# nodejs -v
v6.14.1
root@cubietruck:/opt/iobroker# npm -v
5.8.0


Antworten