Не обновляется javascript до версии 3.0.8

Сообщите об ошибках в ioBroker
Antworten
Benutzeravatar
instalator
guru
Beiträge: 1258
Registriert: 09.11.2014, 16:50
Wohnort: Барнаул
Kontaktdaten:

Не обновляется javascript до версии 3.0.8

Beitrag von instalator » 25.09.2016, 13:00

Spoiler: Show hidden text

Code: Alles auswählen

$ ./iobroker upgrade javascript
npm install iobroker.javascript --production --prefix "C:/ioBroker" (System call)
npm
 
ERR!
 Windows_NT 6.1.7601
npm
 
ERR!
 
argv
 "C:\\Program Files\\nodejs\\\\node.exe" "C:\\Program Files\\nodejs\\node_modules\\npm\\bin\\npm-cli.js" "install" "iobroker.javascript" "--production" "--prefix" "C:/ioBroker"
npm
 
ERR!
 
node
 v0.12.2
npm
 
ERR!
 
npm 
 v2.7.4
npm
 
ERR!
 
path
 C:\ioBroker\node_modules\iobroker.javascript
npm
 
ERR!
 
code
 EBUSY
npm
 
ERR!
 
errno
 -4082

npm
 
ERR!
 EBUSY, rmdir 'C:\ioBroker\node_modules\iobroker.javascript'
npm
 
ERR!
 
npm
 
ERR!
 If you need help, you may report this error at:
npm
 
ERR!
     <https://github.com/npm/npm/issues>
npm
 
ERR!
 
error rolling back
 Error: EBUSY, rmdir 'C:\ioBroker\node_modules\iobroker.javascript'
npm
 
ERR!
 
error rolling back
     at Error (native)
npm
 
ERR!
 
error rolling back
  { [Error: EBUSY, rmdir 'C:\ioBroker\node_modules\iobroker.javascript']
npm
 
ERR!
 
error rolling back
   errno: -4082,
npm
 
ERR!
 
error rolling back
   code: 'EBUSY',
npm
 
ERR!
 
error rolling back
   path: 'C:\\ioBroker\\node_modules\\iobroker.javascript' }

npm
 
ERR!
 Please include the following file with any support request:
npm
 
ERR!
     C:\ioBroker\node_modules\iobroker\npm-debug.log
ERROR: host.Server-PC Cannot install iobroker.javascript: 4294963214
ERROR: process exited with code 25
Высокий уровень Децибел вреден для здоровья!
Мой блог

Benutzeravatar
Bluefox
Site Admin
Beiträge: 7909
Registriert: 13.07.2014, 14:42
Kontaktdaten:

Re: Не обновляется javascript до версии 3.0.8

Beitrag von Bluefox » 25.09.2016, 14:00

instalator hat geschrieben:
Spoiler: Show hidden text

Code: Alles auswählen

$ ./iobroker upgrade javascript
npm install iobroker.javascript --production --prefix "C:/ioBroker" (System call)
npm
 
ERR!
 Windows_NT 6.1.7601
npm
 
ERR!
 
argv
 "C:\\Program Files\\nodejs\\\\node.exe" "C:\\Program Files\\nodejs\\node_modules\\npm\\bin\\npm-cli.js" "install" "iobroker.javascript" "--production" "--prefix" "C:/ioBroker"
npm
 
ERR!
 
node
 v0.12.2
npm
 
ERR!
 
npm 
 v2.7.4
npm
 
ERR!
 
path
 C:\ioBroker\node_modules\iobroker.javascript
npm
 
ERR!
 
code
 EBUSY
npm
 
ERR!
 
errno
 -4082

npm
 
ERR!
 EBUSY, rmdir 'C:\ioBroker\node_modules\iobroker.javascript'
npm
 
ERR!
 
npm
 
ERR!
 If you need help, you may report this error at:
npm
 
ERR!
     <https://github.com/npm/npm/issues>
npm
 
ERR!
 
error rolling back
 Error: EBUSY, rmdir 'C:\ioBroker\node_modules\iobroker.javascript'
npm
 
ERR!
 
error rolling back
     at Error (native)
npm
 
ERR!
 
error rolling back
  { [Error: EBUSY, rmdir 'C:\ioBroker\node_modules\iobroker.javascript']
npm
 
ERR!
 
error rolling back
   errno: -4082,
npm
 
ERR!
 
error rolling back
   code: 'EBUSY',
npm
 
ERR!
 
error rolling back
   path: 'C:\\ioBroker\\node_modules\\iobroker.javascript' }

npm
 
ERR!
 Please include the following file with any support request:
npm
 
ERR!
     C:\ioBroker\node_modules\iobroker\npm-debug.log
ERROR: host.Server-PC Cannot install iobroker.javascript: 4294963214
ERROR: process exited with code 25

Code: Alles auswählen

cd C:\ioBroker
iobroker stop
del C:\ioBroker\node_modules\iobroker.javascript\* /S
npm install iobroker.javascript --production
iobroker start

Antworten