Yet another HomeKit adapter

Forum für Ideen, wie ioBroker verbessert werden kann
Benutzeravatar
rom.wagner80
starter
Beiträge: 76
Registriert: 30.03.2017, 20:41

Re: Yet another HomeKit adapter

Beitrag von rom.wagner80 » 13.03.2018, 22:21

Hier mal der Datenpunkt, der das Problem im Post verursacht. Allerdings machen das Alle Rollläden. Die Einstellungen sind aber auch für alle Datenpunkte gleich.
Dateianhänge
700351CA-BB56-4614-A5B6-C91E5E7833F5.jpeg
700351CA-BB56-4614-A5B6-C91E5E7833F5.jpeg (305.54 KiB) 431 mal betrachtet

Benutzeravatar
rom.wagner80
starter
Beiträge: 76
Registriert: 30.03.2017, 20:41

Re: Yet another HomeKit adapter

Beitrag von rom.wagner80 » 13.03.2018, 22:26

eumats hat geschrieben:
rom.wagner80 hat geschrieben:
rom.wagner80 hat geschrieben:
Dank dir nochmal für deine Hilfe. Werd morgen berichten, wie es läuft .

Gute Nacht

Also, die Grundfunktion ist Super. Klappt alles wie es soll, im HomeKit wird alles richtig angezeigt....ABER :) nach den eingestellten 5 Sekunden kommt es hin und wieder vor, dass die Rolllade noch ein zehntel Sekündchen fährt. ich denke das liegt daran, dass der Jalousieaktor irgendwo stehen bleibt und dann durch den Sollwert auf genau die Prozentzahl fährt. Beispiel : Istwert tatsächlich: 25,4 % Istwert angezeigt : 25 % Sollwert nach 5 Sekunden 25 %. somit fährt der Rollladen noch um 0,4 Prozent nach oben...dafür vielleicht noch ne Idee ? :) brauch ich den Timeout von 5 Sekunden überhaupt ? Weil bei erneuter Bewegung der Rolllade und der damit einhergehenden Veränderung des Istwertes wird der Trigger erneut ausgeführt und somit die Sollposition wieder berrechnet
Lass dir mal in deinem Skript per Debug die Werte für IST und SOLL ausgeben

Das werd ich aber erst morgen schaffen... werde weiter berichten :)

eumats
professional
Beiträge: 276
Registriert: 24.09.2017, 09:04

Re: Yet another HomeKit adapter

Beitrag von eumats » 14.03.2018, 05:55

rom.wagner80 hat geschrieben:Hier mal der Datenpunkt, der das Problem im Post verursacht. Allerdings machen das Alle Rollläden. Die Einstellungen sind aber auch für alle Datenpunkte gleich.
Ändere mal den Typ der Darenpunkte in Zahl (number)...

Benutzeravatar
rom.wagner80
starter
Beiträge: 76
Registriert: 30.03.2017, 20:41

Re: Yet another HomeKit adapter

Beitrag von rom.wagner80 » 14.03.2018, 16:33

eumats hat geschrieben: Ändere mal den Typ der Darenpunkte in Zahl (number)...
Da hat schonmal funktioniert :)
Danke

Benutzeravatar
rom.wagner80
starter
Beiträge: 76
Registriert: 30.03.2017, 20:41

Re: Yet another HomeKit adapter

Beitrag von rom.wagner80 » 14.03.2018, 16:43

eumats hat geschrieben: Lass dir mal in deinem Skript per Debug die Werte für IST und SOLL ausgeben
Also folgendes ist zu beobachten !? :
Dateianhänge
Log.jpeg
Log.jpeg (32.68 KiB) 398 mal betrachtet
ScriptLog.jpeg
ScriptLog.jpeg (187.83 KiB) 398 mal betrachtet

eumats
professional
Beiträge: 276
Registriert: 24.09.2017, 09:04

Re: Yet another HomeKit adapter

Beitrag von eumats » 14.03.2018, 19:56

Hast du bei diesem Log den Rolladen manuell bedient und hat er da wieder „gestottert“?

Benutzeravatar
rom.wagner80
starter
Beiträge: 76
Registriert: 30.03.2017, 20:41

Re: Yet another HomeKit adapter

Beitrag von rom.wagner80 » 14.03.2018, 20:12

Ja, genau.

eumats
professional
Beiträge: 276
Registriert: 24.09.2017, 09:04

Re: Yet another HomeKit adapter

Beitrag von eumats » 14.03.2018, 20:26

Hast du ihn nur ganz kurz (also 3%) fahren lassen? Lass ihn mal bitte länger fahre. Natürlich manuell und dann das Log posten.

Benutzeravatar
rom.wagner80
starter
Beiträge: 76
Registriert: 30.03.2017, 20:41

Re: Yet another HomeKit adapter

Beitrag von rom.wagner80 » 14.03.2018, 20:32

eumats hat geschrieben:Hast du ihn nur ganz kurz (also 3%) fahren lassen? Lass ihn mal bitte länger fahre. Natürlich manuell und dann das Log posten.
Werd ich morgen mal machen... weiß nicht mehr ob’s 3% waren... könnte aber sein.
Schönen Abend noch

rh1212
starter
Beiträge: 81
Registriert: 17.02.2018, 14:44

Re: Yet another HomeKit adapter

Beitrag von rh1212 » 15.03.2018, 16:48

Hallo!

kann leider der Adapter nicht installieren, versuche ich seit 3 Tagen, direkt über Adapter seite, mit link, oder von der Liste, leider geht nicht. Hat jemand eine Idee?

Log:
Spoiler: Show hidden text

Code: Alles auswählen

iobroker	2018-03-15 16:42:51.117	info	exit 0
iobroker	2018-03-15 16:42:51.022	info	npm ERR! code 1
iobroker	2018-03-15 16:42:51.022	info	npm ERR! Please include the following file with any support request:npm ERR! /opt/npm-debug.log
iobroker	2018-03-15 16:42:51.019	info	
iobroker	2018-03-15 16:42:50.944	info	npm ERR! There is likely additional logging output above.
iobroker	2018-03-15 16:42:50.944	info	npm ERR! npm owner ls mdns
iobroker	2018-03-15 16:42:50.944	info	npm ERR! Or if that isn't available, you can get their info via:
iobroker	2018-03-15 16:42:50.944	info	npm ERR! npm bugs mdns
iobroker	2018-03-15 16:42:50.944	info	node-gyp rebuildnpm ERR! You can get information on how to open an issue for this project with:
iobroker	2018-03-15 16:42:50.942	info	Tell the author that this fails on your system:npm ERR!
iobroker	2018-03-15 16:42:50.938	info	npm ERR!
iobroker	2018-03-15 16:42:50.938	info	npm ERR! not with npm itself.
iobroker	2018-03-15 16:42:50.938	info	npm ERR! If you do, this is most likely a problem with the mdns package,
iobroker	2018-03-15 16:42:50.938	info	npm ERR! Make sure you have the latest version of node.js and npm installed.
iobroker	2018-03-15 16:42:50.938	info	npm ERR! Failed at the mdns@2.3.4 install script 'node-gyp rebuild'.
iobroker	2018-03-15 16:42:50.938	info	npm ERR!
iobroker	2018-03-15 16:42:50.938	info	ERR! mdns@2.3.4 install: `node-gyp rebuild`npm ERR! Exit status 1
iobroker	2018-03-15 16:42:50.937	info	npm
iobroker	2018-03-15 16:42:50.931	info	ERR! npm v3.10.10npm ERR! code ELIFECYCLE
iobroker	2018-03-15 16:42:50.929	info	npm
iobroker	2018-03-15 16:42:50.929	info	npm ERR! node v6.13.0
iobroker	2018-03-15 16:42:50.929	info	ERR! Linux 4.9.59-v7+npm ERR! argv "/usr/bin/node" "/usr/bin/npm" "install" "https://github.com/jensweigele/ioBroker.yahka/tarball/master" "--production" "--prefix" "/opt/iobroker"
iobroker	2018-03-15 16:42:50.927	info	npm
iobroker	2018-03-15 16:42:50.910	info	iobroker.inst@1.0.8 /opt/iobroker└── (empty)
iobroker	2018-03-15 16:42:45.364	info	gyp ERR! node-gyp -v v3.4.0gyp ERR! not ok
iobroker	2018-03-15 16:42:45.362	info	gyp ERR! node -v v6.13.0
iobroker	2018-03-15 16:42:45.362	info	gyp ERR! cwd /opt/iobroker/node_modules/mdns
iobroker	2018-03-15 16:42:45.362	info	gyp ERR! System Linux 4.9.59-v7+gyp ERR! command "/usr/bin/node" "/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
iobroker	2018-03-15 16:42:45.361	info	gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:219:12)
iobroker	2018-03-15 16:42:45.361	info	gyp ERR! stack at ChildProcess.emit (events.js:191:7)
iobroker	2018-03-15 16:42:45.361	info	gyp ERR! stack at emitTwo (events.js:106:13)
iobroker	2018-03-15 16:42:45.361	info	ERR! stack Error: `make` failed with exit code: 2gyp ERR! stack at ChildProcess.onExit (/usr/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:276:23)
iobroker	2018-03-15 16:42:45.359	info	gyp
iobroker	2018-03-15 16:42:45.350	info	
iobroker	2018-03-15 16:42:45.348	info	ERR! build error
iobroker	2018-03-15 16:42:45.345	info	gyp
iobroker	2018-03-15 16:42:45.334	info	make: Leaving directory '/opt/iobroker/node_modules/mdns/build'
iobroker	2018-03-15 16:42:45.334	info	dns_sd_bindings.target.mk:149: recipe for target 'Release/obj.target/dns_sd_bindings/src/dns_sd.o' failedmake: *** [Release/obj.target/dns_sd_bindings/src/dns_sd.o] Error 1
iobroker	2018-03-15 16:42:45.324	info	compilation terminated.
iobroker	2018-03-15 16:42:45.324	info	^
iobroker	2018-03-15 16:42:45.324	info	#include
iobroker	2018-03-15 16:42:45.324	info	In file included from ../src/dns_sd.cpp:1:0:../src/mdns.hpp:32:20: fatal error: dns_sd.h: No such file or directory
iobroker	2018-03-15 16:42:44.927	info	CXX(target) Release/obj.target/dns_sd_bindings/src/dns_sd.o
iobroker	2018-03-15 16:42:44.920	info	make: Entering directory '/opt/iobroker/node_modules/mdns/build'
iobroker	2018-03-15 16:42:42.261	info	> node-gyp rebuild
iobroker	2018-03-15 16:42:42.261	info	> mdns@2.3.4 install /opt/iobroker/node_modules/mdns
iobroker	2018-03-15 16:42:11.723	info	npm install https://github.com/jensweigele/ioBroker.yahka/tarball/master --production --prefix "/opt/iobroker" (System call)
iobroker	2018-03-15 16:42:11.321	info	install https://github.com/jensweigele/ioBroker.yahka/tarball/master
iobroker	2018-03-15 16:42:10.081	info	url "https://github.com/jensweigele/ioBroker.yahka" --debug
Spoiler: Show hidden text

Code: Alles auswählen

iobroker	2018-03-15 16:54:36.238	info	exit 13
iobroker	2018-03-15 16:54:36.205	error	host.raspberrypi Cannot install yahka
iobroker	2018-03-15 16:54:36.203	info	host.raspberrypi install adapter yahka
iobroker	2018-03-15 16:54:36.176	info	npm ERR! code 1
iobroker	2018-03-15 16:54:36.176	info	Please include the following file with any support request:npm ERR! /opt/npm-debug.log
iobroker	2018-03-15 16:54:36.174	info	npm ERR!
iobroker	2018-03-15 16:54:36.172	info	
iobroker	2018-03-15 16:54:36.091	info	npm ERR! There is likely additional logging output above.
iobroker	2018-03-15 16:54:36.091	info	npm ERR! npm owner ls mdns
iobroker	2018-03-15 16:54:36.091	info	npm ERR! Or if that isn't available, you can get their info via:
iobroker	2018-03-15 16:54:36.091	info	npm ERR! npm bugs mdns
iobroker	2018-03-15 16:54:36.091	info	npm ERR! You can get information on how to open an issue for this project with:
iobroker	2018-03-15 16:54:36.091	info	ERR! Tell the author that this fails on your system:npm ERR! node-gyp rebuild
iobroker	2018-03-15 16:54:36.086	info	npm
iobroker	2018-03-15 16:54:36.086	info	npm ERR! not with npm itself.
iobroker	2018-03-15 16:54:36.086	info	npm ERR! If you do, this is most likely a problem with the mdns package,
iobroker	2018-03-15 16:54:36.086	info	npm ERR! Make sure you have the latest version of node.js and npm installed.
iobroker	2018-03-15 16:54:36.086	info	npm ERR! Failed at the mdns@2.3.4 install script 'node-gyp rebuild'.
iobroker	2018-03-15 16:54:36.086	info	npm ERR!
iobroker	2018-03-15 16:54:36.086	info	mdns@2.3.4 install: `node-gyp rebuild`npm ERR! Exit status 1
iobroker	2018-03-15 16:54:36.084	info	npm ERR!
iobroker	2018-03-15 16:54:36.081	info	
iobroker	2018-03-15 16:54:36.079	info	npm ERR! code ELIFECYCLE
iobroker	2018-03-15 16:54:36.077	info	npm ERR! npm v3.10.10
iobroker	2018-03-15 16:54:36.077	info	npm ERR! node v6.13.0
iobroker	2018-03-15 16:54:36.077	info	ERR! Linux 4.9.59-v7+npm ERR! argv "/usr/bin/node" "/usr/bin/npm" "install" "iobroker.yahka" "--production" "--prefix" "/opt/iobroker"
iobroker	2018-03-15 16:54:36.074	info	npm
iobroker	2018-03-15 16:54:30.534	info	gyp ERR! not ok
iobroker	2018-03-15 16:54:30.534	info	gyp ERR! node-gyp -v v3.4.0
iobroker	2018-03-15 16:54:30.534	info	gyp ERR! node -v v6.13.0
iobroker	2018-03-15 16:54:30.534	info	gyp ERR! cwd /opt/iobroker/node_modules/mdns
iobroker	2018-03-15 16:54:30.534	info	gyp ERR! command "/usr/bin/node" "/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
iobroker	2018-03-15 16:54:30.534	info	gyp ERR! System Linux 4.9.59-v7+
iobroker	2018-03-15 16:54:30.534	info	stack at ChildProcess.emit (events.js:191:7)gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:219:12)
iobroker	2018-03-15 16:54:30.528	info	gyp ERR!
iobroker	2018-03-15 16:54:30.528	info	gyp ERR! stack at emitTwo (events.js:106:13)
iobroker	2018-03-15 16:54:30.528	info	ERR! stack Error: `make` failed with exit code: 2gyp ERR! stack at ChildProcess.onExit (/usr/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:276:23)
iobroker	2018-03-15 16:54:30.515	info	gyp
iobroker	2018-03-15 16:54:30.506	info	ERR! build error
iobroker	2018-03-15 16:54:30.505	info	
iobroker	2018-03-15 16:54:30.502	info	gyp
iobroker	2018-03-15 16:54:30.497	info	make: *** [Release/obj.target/dns_sd_bindings/src/dns_sd.o] Error 1
iobroker	2018-03-15 16:54:30.473	info	compilation terminated.
iobroker	2018-03-15 16:54:30.473	info	^
iobroker	2018-03-15 16:54:30.473	info	#include
iobroker	2018-03-15 16:54:30.473	info	In file included from ../src/dns_sd.cpp:1:0:../src/mdns.hpp:32:20: fatal error: dns_sd.h: No such file or directory
iobroker	2018-03-15 16:53:59.192	info	npm install iobroker.yahka --production --prefix "/opt/iobroker" (System call)
iobroker	2018-03-15 16:53:58.863	info	host.raspberrypi install adapter yahka
iobroker	2018-03-15 16:53:58.832	info	npm ERR! code 1
iobroker	2018-03-15 16:53:58.832	info	npm ERR! Please include the following file with any support request:npm ERR! /opt/npm-debug.log
iobroker	2018-03-15 16:53:58.830	info	
iobroker	2018-03-15 16:53:58.749	info	npm ERR! There is likely additional logging output above.
iobroker	2018-03-15 16:53:58.749	info	npm ERR! npm owner ls mdns
iobroker	2018-03-15 16:53:58.749	info	npm ERR! Or if that isn't available, you can get their info via:
iobroker	2018-03-15 16:53:58.749	info	ERR! You can get information on how to open an issue for this project with:npm ERR! npm bugs mdns
iobroker	2018-03-15 16:53:58.747	info	npm
iobroker	2018-03-15 16:53:58.747	info	npm ERR! node-gyp rebuild
iobroker	2018-03-15 16:53:58.747	info	npm ERR! Tell the author that this fails on your system:
iobroker	2018-03-15 16:53:58.747	info	npm ERR! not with npm itself.
iobroker	2018-03-15 16:53:58.747	info	npm ERR! If you do, this is most likely a problem with the mdns package,
iobroker	2018-03-15 16:53:58.747	info	npm ERR! Make sure you have the latest version of node.js and npm installed.
iobroker	2018-03-15 16:53:58.747	info	npm ERR! Failed at the mdns@2.3.4 install script 'node-gyp rebuild'.
iobroker	2018-03-15 16:53:58.747	info	npm ERR!
iobroker	2018-03-15 16:53:58.747	info	ERR! mdns@2.3.4 install: `node-gyp rebuild`npm ERR! Exit status 1
iobroker	2018-03-15 16:53:58.746	info	npm
iobroker	2018-03-15 16:53:58.740	info	npm ERR! code ELIFECYCLE
iobroker	2018-03-15 16:53:58.740	info	npm ERR! npm v3.10.10
iobroker	2018-03-15 16:53:58.740	info	npm ERR! node v6.13.0
iobroker	2018-03-15 16:53:58.740	info	ERR! Linux 4.9.59-v7+npm ERR! argv "/usr/bin/node" "/usr/bin/npm" "install" "iobroker.yahka" "--production" "--prefix" "/opt/iobroker"
iobroker	2018-03-15 16:53:58.736	info	npm
iobroker	2018-03-15 16:53:53.021	info	gyp ERR! node-gyp -v v3.4.0gyp ERR! not ok
iobroker	2018-03-15 16:53:53.019	info	gyp ERR! node -v v6.13.0
iobroker	2018-03-15 16:53:53.019	info	gyp ERR! cwd /opt/iobroker/node_modules/mdns
iobroker	2018-03-15 16:53:53.019	info	gyp ERR! command "/usr/bin/node" "/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
iobroker	2018-03-15 16:53:53.019	info	gyp ERR! System Linux 4.9.59-v7+
iobroker	2018-03-15 16:53:53.019	info	gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:219:12)
iobroker	2018-03-15 16:53:53.019	info	gyp ERR! stack at ChildProcess.emit (events.js:191:7)
iobroker	2018-03-15 16:53:53.019	info	gyp ERR! stack at emitTwo (events.js:106:13)
iobroker	2018-03-15 16:53:53.019	info	ERR! stack Error: `make` failed with exit code: 2gyp ERR! stack at ChildProcess.onExit (/usr/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:276:23)
iobroker	2018-03-15 16:53:53.015	info	gyp
iobroker	2018-03-15 16:53:53.006	info	
iobroker	2018-03-15 16:53:53.005	info	ERR! build error
iobroker	2018-03-15 16:53:53.002	info	gyp
iobroker	2018-03-15 16:53:52.989	info	make: *** [Release/obj.target/dns_sd_bindings/src/dns_sd.o] Error 1
iobroker	2018-03-15 16:53:52.980	info	compilation terminated.
iobroker	2018-03-15 16:53:52.972	info	^
iobroker	2018-03-15 16:53:52.972	info	#include
iobroker	2018-03-15 16:53:52.972	info	In file included from ../src/dns_sd.cpp:1:0:../src/mdns.hpp:32:20: fatal error: dns_sd.h: No such file or directory
iobroker	2018-03-15 16:53:21.901	info	npm install iobroker.yahka --production --prefix "/opt/iobroker" (System call)
iobroker	2018-03-15 16:53:21.532	info	host.raspberrypi install adapter yahka
iobroker	2018-03-15 16:53:21.466	info	npm ERR! code 1
iobroker	2018-03-15 16:53:21.466	info	npm ERR! Please include the following file with any support request:npm ERR! /opt/npm-debug.log
iobroker	2018-03-15 16:53:21.464	info	
iobroker	2018-03-15 16:53:21.430	info	npm ERR! There is likely additional logging output above.
iobroker	2018-03-15 16:53:21.430	info	npm ERR! npm owner ls mdns
iobroker	2018-03-15 16:53:21.430	info	npm ERR! Or if that isn't available, you can get their info via:
iobroker	2018-03-15 16:53:21.430	info	npm ERR! npm bugs mdns
iobroker	2018-03-15 16:53:21.430	info	npm ERR! You can get information on how to open an issue for this project with:
iobroker	2018-03-15 16:53:21.430	info	npm ERR! node-gyp rebuild
iobroker	2018-03-15 16:53:21.430	info	npm ERR! Tell the author that this fails on your system:
iobroker	2018-03-15 16:53:21.430	info	npm ERR! not with npm itself.
iobroker	2018-03-15 16:53:21.430	info	npm ERR! If you do, this is most likely a problem with the mdns package,
iobroker	2018-03-15 16:53:21.430	info	npm ERR! Make sure you have the latest version of node.js and npm installed.
iobroker	2018-03-15 16:53:21.430	info	npm ERR! Failed at the mdns@2.3.4 install script 'node-gyp rebuild'.
iobroker	2018-03-15 16:53:21.430	info	npm ERR!
iobroker	2018-03-15 16:53:21.430	info	npm ERR! Exit status 1
iobroker	2018-03-15 16:53:21.430	info	npm ERR! mdns@2.3.4 install: `node-gyp rebuild`
iobroker	2018-03-15 16:53:21.430	info	npm ERR! code ELIFECYCLE
iobroker	2018-03-15 16:53:21.430	info	npm ERR! npm v3.10.10
iobroker	2018-03-15 16:53:21.430	info	npm ERR! node v6.13.0
iobroker	2018-03-15 16:53:21.430	info	ERR! Linux 4.9.59-v7+npm ERR! argv "/usr/bin/node" "/usr/bin/npm" "install" "iobroker.yahka" "--production" "--prefix" "/opt/iobroker"
iobroker	2018-03-15 16:53:21.377	info	npm
iobroker	2018-03-15 16:53:15.749	info	gyp ERR! not ok
iobroker	2018-03-15 16:53:15.747	info	gyp ERR! node-gyp -v v3.4.0
iobroker	2018-03-15 16:53:15.747	info	gyp ERR! node -v v6.13.0
iobroker	2018-03-15 16:53:15.747	info	gyp ERR! cwd /opt/iobroker/node_modules/mdns
iobroker	2018-03-15 16:53:15.747	info	gyp ERR! System Linux 4.9.59-v7+gyp ERR! command "/usr/bin/node" "/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
iobroker	2018-03-15 16:53:15.744	info	gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:219:12)
iobroker	2018-03-15 16:53:15.744	info	gyp ERR! stack at ChildProcess.emit (events.js:191:7)
iobroker	2018-03-15 16:53:15.744	info	gyp ERR! stack at emitTwo (events.js:106:13)
iobroker	2018-03-15 16:53:15.744	info	ERR! stack Error: `make` failed with exit code: 2gyp ERR! stack at ChildProcess.onExit (/usr/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:276:23)
iobroker	2018-03-15 16:53:15.742	info	gyp
iobroker	2018-03-15 16:53:15.733	info	ERR! build error
iobroker	2018-03-15 16:53:15.732	info	
iobroker	2018-03-15 16:53:15.729	info	gyp
iobroker	2018-03-15 16:53:15.716	info	make: *** [Release/obj.target/dns_sd_bindings/src/dns_sd.o] Error 1
iobroker	2018-03-15 16:53:15.708	info	compilation terminated.
iobroker	2018-03-15 16:53:15.708	info	^
iobroker	2018-03-15 16:53:15.708	info	#include
iobroker	2018-03-15 16:53:15.708	info	In file included from ../src/dns_sd.cpp:1:0:../src/mdns.hpp:32:20: fatal error: dns_sd.h: No such file or directory
iobroker	2018-03-15 16:52:44.258	info	npm install iobroker.yahka --production --prefix "/opt/iobroker" (System call)
iobroker	2018-03-15 16:52:42.226	info	add yahka

worfinator
starter
Beiträge: 74
Registriert: 11.02.2018, 12:57

Re: Yet another HomeKit adapter

Beitrag von worfinator » 15.03.2018, 17:13

Wichtig vor der Installation müssen einige Pakete installiert werden: sudo apt-get install libavahi-compat-libdnssd-dev
Hast du das vorab gemacht?

rh1212
starter
Beiträge: 81
Registriert: 17.02.2018, 14:44

Re: Yet another HomeKit adapter

Beitrag von rh1212 » 15.03.2018, 17:43

worfinator hat geschrieben:
Wichtig vor der Installation müssen einige Pakete installiert werden: sudo apt-get install libavahi-compat-libdnssd-dev
Hast du das vorab gemacht?
Ja, ich habe der Adapter auch vorher benutzt, gelöscht und nun wollte ich das nochmal installieren

eumats
professional
Beiträge: 276
Registriert: 24.09.2017, 09:04

Re: Yet another HomeKit adapter

Beitrag von eumats » 15.03.2018, 19:48

Versuch mal in der Konsole:
Spoiler: Show hidden text

Code: Alles auswählen

cd /opt/iobroker 
sudo npm cache clean
sudo iobroker stop
sudo npm install iobroker.yahka
sudo iobroker add yahka
sudo iobroker start

roqstailor
starter
Beiträge: 11
Registriert: 15.03.2018, 20:17

Re: Yet another HomeKit adapter

Beitrag von roqstailor » 15.03.2018, 20:31

hallo klasse forum

habe folgendes problem,

Code: Alles auswählen

host.raspberrypi	2018-03-15 20:30:21.781	info	Restart adapter system.adapter.yahka.1 because enabled
host.raspberrypi	2018-03-15 20:30:21.781	error	instance system.adapter.yahka.1 terminated with code 1 ()
host.raspberrypi	2018-03-15 20:30:21.781	error	Caught by controller[0]: at Function.Module._load (module.js:445:3)
host.raspberrypi	2018-03-15 20:30:21.781	error	Caught by controller[0]: at tryModuleLoad (module.js:453:12)
host.raspberrypi	2018-03-15 20:30:21.780	error	Caught by controller[0]: at Module.load (module.js:494:32)
host.raspberrypi	2018-03-15 20:30:21.780	error	Caught by controller[0]: at Object.Module._extensions..js (module.js:586:10)
host.raspberrypi	2018-03-15 20:30:21.780	error	Caught by controller[0]: at Module._compile (module.js:577:32)
host.raspberrypi	2018-03-15 20:30:21.779	error	Caught by controller[0]: at Object. (/opt/iobroker/node_modules/mdns/lib/dns_sd.js:32:22)
host.raspberrypi	2018-03-15 20:30:21.779	error	Caught by controller[0]: at require (internal/module.js:20:19)
host.raspberrypi	2018-03-15 20:30:21.778	error	Caught by controller[0]: at Module.require (module.js:504:17)
host.raspberrypi	2018-03-15 20:30:21.778	error	Caught by controller[0]: at Function.Module._load (module.js:424:25)
host.raspberrypi	2018-03-15 20:30:21.778	error	Caught by controller[0]: at Function.Module._resolveFilename (module.js:476:15)
host.raspberrypi	2018-03-15 20:30:21.778	error	Caught by controller[0]: Error: Cannot find module '../build/Release/dns_sd_bindings'
host.raspberrypi	2018-03-15 20:30:21.777	error	Caught by controller[0]: ^
host.raspberrypi	2018-03-15 20:30:21.777	error	Caught by controller[0]: throw err;
host.raspberrypi	2018-03-15 20:30:21.775	error	Caught by controller[0]: module.js:478
installation ging ohne probleme nur will der einfach nicht starten und ich verstehe nicht wieso

rh1212
starter
Beiträge: 81
Registriert: 17.02.2018, 14:44

Re: Yet another HomeKit adapter

Beitrag von rh1212 » 15.03.2018, 20:42

eumats hat geschrieben:Versuch mal in der Konsole:
Spoiler: Show hidden text

Code: Alles auswählen

cd /opt/iobroker 
sudo npm cache clean
sudo iobroker stop
sudo npm install iobroker.yahka
sudo iobroker add yahka
sudo iobroker start
Danke für die Antwort eumats,

leider hat das auch nicht funktioniert.
Spoiler: Show hidden text

Code: Alles auswählen

root@raspberrypi:/opt/iobroker# sudo npm install iobroker.yahka

> mdns@2.3.4 install /opt/iobroker/node_modules/mdns
> node-gyp rebuild

make: Entering directory '/opt/iobroker/node_modules/mdns/build'
  CXX(target) Release/obj.target/dns_sd_bindings/src/dns_sd.o
In file included from ../src/dns_sd.cpp:1:0:
../src/mdns.hpp:32:20: fatal error: dns_sd.h: No such file or directory
 #include <dns_sd.h>
                    ^
compilation terminated.
dns_sd_bindings.target.mk:149: recipe for target 'Release/obj.target/dns_sd_bindings/src/dns_sd.o' failed
make: *** [Release/obj.target/dns_sd_bindings/src/dns_sd.o] Error 1
make: Leaving directory '/opt/iobroker/node_modules/mdns/build'
gyp ERR! build error
gyp ERR! stack Error: `make` failed with exit code: 2
gyp ERR! stack     at ChildProcess.onExit (/usr/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:276:23)
gyp ERR! stack     at emitTwo (events.js:106:13)
gyp ERR! stack     at ChildProcess.emit (events.js:191:7)
gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:219:12)
gyp ERR! System Linux 4.9.59-v7+
gyp ERR! command "/usr/bin/node" "/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
gyp ERR! cwd /opt/iobroker/node_modules/mdns
gyp ERR! node -v v6.13.0
gyp ERR! node-gyp -v v3.4.0
gyp ERR! not ok
iobroker.inst@1.0.8 /opt/iobroker
└── (empty)

npm ERR! Linux 4.9.59-v7+
npm ERR! argv "/usr/bin/node" "/usr/bin/npm" "install" "iobroker.yahka"
npm ERR! node v6.13.0
npm ERR! npm  v3.10.10
npm ERR! code ELIFECYCLE

npm ERR! mdns@2.3.4 install: `node-gyp rebuild`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the mdns@2.3.4 install script 'node-gyp rebuild'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the mdns package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node-gyp rebuild
npm ERR! You can get information on how to open an issue for this project with:
npm ERR!     npm bugs mdns
npm ERR! Or if that isn't available, you can get their info via:
npm ERR!     npm owner ls mdns
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR!     /opt/iobroker/npm-debug.log
npm ERR! code 1

eumats
professional
Beiträge: 276
Registriert: 24.09.2017, 09:04

Re: Yet another HomeKit adapter

Beitrag von eumats » 15.03.2018, 20:47

roqstailor hat geschrieben:hallo klasse forum

habe folgendes problem,

installation ging ohne probleme nur will der einfach nicht starten und ich verstehe nicht wieso
Hast du gemacht was hier steht: https://github.com/jensweigele/ioBroker ... leshooting

rh1212
starter
Beiträge: 81
Registriert: 17.02.2018, 14:44

Re: Yet another HomeKit adapter

Beitrag von rh1212 » 15.03.2018, 20:54

Ah Problem gelöst mit apt-get update, keine Ahnung was da los war. Also ich habe das jetzt installiert, danke für Eure Hilfe!

roqstailor
starter
Beiträge: 11
Registriert: 15.03.2018, 20:17

Re: Yet another HomeKit adapter

Beitrag von roqstailor » 15.03.2018, 21:00

eumats hat geschrieben:
roqstailor hat geschrieben:hallo klasse forum

habe folgendes problem,

installation ging ohne probleme nur will der einfach nicht starten und ich verstehe nicht wieso
Hast du gemacht was hier steht: https://github.com/jensweigele/ioBroker ... leshooting

ja das habe ich alles schon gemacht

worfinator
starter
Beiträge: 74
Registriert: 11.02.2018, 12:57

Re: Yet another HomeKit adapter

Beitrag von worfinator » 15.03.2018, 22:37

Hm ja, mit diesem mdns hatte ich früher auch schon öfters Probleme. Aber einen konkreten Einfall hab ich jetzt auch nicht.

eumats
professional
Beiträge: 276
Registriert: 24.09.2017, 09:04

Re: Yet another HomeKit adapter

Beitrag von eumats » 16.03.2018, 09:40

roqstailor hat geschrieben: ja das habe ich alles schon gemacht
Hmm. Andere Adapter lassen sich installieren?

Vielleicht hilft ja wie bei rh1212 ein:

Code: Alles auswählen

sudo apt-get update && sudo apt-get upgrade

Antworten