tr-064 Adapter Fehler

Forum zum Mitteilen von Fehlern
AndyUM61
professional
Beiträge: 276
Registriert: 23.06.2015, 08:41

tr-064 Adapter Fehler

Beitrag von AndyUM61 » 02.01.2017, 17:28

Hallo, mein Log schreibt sich leider nach dem Update des tr-064-Adapters mit folgendem Fehler voll:

Code: Alles auswählen

tr-064.0	2017-01-02 17:23:35.060	error	at Timer.listOnTimeout (timers.js:92:15)
tr-064.0	2017-01-02 17:23:35.060	error	at doIt [as _onTimeout] (C:\Program Files\ioBroker\node_modules\iobroker.tr-064\tr-064.js:491:32)
tr-064.0	2017-01-02 17:23:35.060	error	at TR064.getWLAN (C:\Program Files\ioBroker\node_modules\iobroker.tr-064\tr-064.js:351:5)
tr-064.0	2017-01-02 17:23:30.154	info	starting. Version 0.1.16 in C:/Program Files/ioBroker/node_modules/iobroker.tr-064, node: v4.5.0
Er versucht auch jede Minute den Adapter neu zu starten:(!
Internette Grüße
Andy

RaspberryMatic (Raspberry Pi3), CUxD, ioBroker (Win 8.1/64)

bku
professional
Beiträge: 183
Registriert: 31.01.2015, 13:04

Re: tr-064 Adapter Fehler

Beitrag von bku » 02.01.2017, 20:37

Hab das gleiche ...

Gruß Bernd

Benutzeravatar
ruhr70
guru
Beiträge: 2274
Registriert: 24.02.2015, 19:40

Re: tr-064 Adapter Fehler

Beitrag von ruhr70 » 02.01.2017, 20:38

dito

Code: Alles auswählen

host.ubuntu1604server	2017-01-02 20:34:48.315	error	instance system.adapter.tr-064.0 terminated with code 0 (OK)
tr-064.0	2017-01-02 20:34:48.311	info	terminating
tr-064.0	2017-01-02 20:34:48.309	error	at Timer.listOnTimeout (timers.js:92:15)
tr-064.0	2017-01-02 20:34:48.309	error	at doIt [as _onTimeout] (/opt/iobroker/node_modules/iobroker.tr-064/tr-064.js:491:32)
tr-064.0	2017-01-02 20:34:48.309	error	at TR064.getWLAN (/opt/iobroker/node_modules/iobroker.tr-064/tr-064.js:351:5)
tr-064.0	2017-01-02 20:34:48.309	error	at callGetInfo (/opt/iobroker/node_modules/iobroker.tr-064/tr-064.js:342:29)
tr-064.0	2017-01-02 20:34:48.309	error	TypeError: path.actions.getInfo is not a function
tr-064.0	2017-01-02 20:34:48.307	error	uncaught exception: path.actions.getInfo is not a function
tr-064.0	2017-01-02 20:34:44.793	info	starting. Version 0.1.16 in /opt/iobroker/node_modules/iobroker.tr-064, node: v4.7.0
Intel NUC (NUC6i5SYH) -> ESXi 6 > VM Ubuntu 16.04 ioBroker (redis) > VM Ubuntu 16.04 mySQL
Slave: Pi 3 ohne SD (Boot USB SLC)
CCU2, hue 2, DS 1512+, WeMos, Harmony Hub, Alexa
Adapter: Fritzbox / Skripte: dynamic hue, Bluetooth Scanner, WIFFI-wz

Sven2013
professional
Beiträge: 347
Registriert: 15.07.2015, 13:07

Re: tr-064 Adapter Fehler

Beitrag von Sven2013 » 03.01.2017, 00:03

Schließe mich genau damit an...
Gruß Sven

kirbsi
professional
Beiträge: 105
Registriert: 13.07.2016, 18:11

Re: tr-064 Adapter Fehler

Beitrag von kirbsi » 03.01.2017, 06:04

Ich auch. Der Adapter schaltet sich alle 30sek aus.

Benutzeravatar
apollon77
guru
Beiträge: 6556
Registriert: 10.04.2015, 12:27

Re: tr-064 Adapter Fehler

Beitrag von apollon77 » 03.01.2017, 10:48

LKeider hat soef die Versionsinfos in der io-package.json nicht eingetragen, sonst könnte man auf eine alte Version zurückrollen per Admin :-(
How-to:
* Debug-Log für einen Adapter/Instanz einschalten? -> Instanzen -> Expertenomodus -> Spalte Loglevel/Log-Stufe

AndyUM61
professional
Beiträge: 276
Registriert: 23.06.2015, 08:41

Re: tr-064 Adapter Fehler

Beitrag von AndyUM61 » 03.01.2017, 17:15

apollon77 hat geschrieben:LKeider hat soef die Versionsinfos in der io-package.json nicht eingetragen, sonst könnte man auf eine alte Version zurückrollen per Admin :-(
Na fein:(.

...hatte bis zum Update recht gut funktioniert..
Internette Grüße
Andy

RaspberryMatic (Raspberry Pi3), CUxD, ioBroker (Win 8.1/64)

Benutzeravatar
Jey Cee
guru
Beiträge: 1627
Registriert: 22.12.2014, 17:00

Re: tr-064 Adapter Fehler

Beitrag von Jey Cee » 03.01.2017, 17:24

Hat schon jemand ein issue auf github erstellt?
Denk nicht das soef hier mit liest.
Ich hab vorgestern einen issue gemeldet auf github und den hat soef dann gleich erledigt.

Gesendet von meinem m8 mit Tapatalk

vore
starter
Beiträge: 92
Registriert: 01.11.2015, 22:33

Re: tr-064 Adapter Fehler

Beitrag von vore » 04.01.2017, 10:44

Gleicher Fehler.. aber bei mir hat der Adapter bisher leider gar nicht funktioniert (Gast-Wlan Ein/Aus).

Gruß
Vore

pix
guru
Beiträge: 2693
Registriert: 04.11.2014, 17:49
Kontaktdaten:

Re: tr-064 Adapter Fehler

Beitrag von pix » 04.01.2017, 11:52

Hallo,

bei mir kommt dieser Fehler beim Setzen des GastWLAN Datenpunktes auf true:

Code: Alles auswählen

2017-01-04 11:47:14.338  - [31merror[39m: host. pmessage io.tr-064.0.states.wlanGuest {"val":true,"ack":false,"ts":1483526834333,"q":0,"from":"system.adapter.web.0","lc":1483526834333} Cannot read property 'services' of undefined
2017-01-04 11:47:14.344  - [31merror[39m: host. TypeError: Cannot read property 'services' of undefined
    at TR064.setWLANGuest (/Users/pix/Documents/iobroker/node_modules/iobroker.tr-064/tr-064.js:283:24)
    at Object.onStateChange (/Users/pix/Documents/iobroker/node_modules/iobroker.tr-064/tr-064.js:112:27)
    at Object.options.stateChange (/Users/pix/Documents/iobroker/node_modules/iobroker.tr-064/node_modules/soef/soef.js:1057:21)
    at that.states.States.change (/Users/pix/Documents/iobroker/node_modules/iobroker.js-controller/lib/adapter.js:2194:37)
    at RedisClient.<anonymous> (/Users/pix/Documents/iobroker/node_modules/iobroker.js-controller/lib/states/statesInRedis.js:88:25)
    at emitThree (events.js:97:13)
    at RedisClient.emit (events.js:175:7)
    at return_pub_sub (/Users/pix/Documents/iobroker/node_modules/iobroker.js-controller/node_modules/redis/index.js:782:18)
    at RedisClient.return_reply (/Users/pix/Documents/iobroker/node_modules/iobroker.js-controller/node_modules/redis/index.js:825:9)
    at JavascriptRedisParser.Parser.returnReply (/Users/pix/Documents/iobroker/node_modules/iobroker.js-controller/node_modules/redis/index.js:188:18)
Gruß
Pix
Mac mini (OS X 10.12.6, node v6.12.2, npm v4.6.1), Redis, InfluxDB, VIS via iOS; gesteuerte Systeme: Homematic CCU2, Homepilot, Roomba, Sonos, XEOMA auf Odroid XU4; Adapter: feiertage, tvspielfilm, rtv, solarwetter, tankerkoenig, homepilot, epson_stylus_px830

Benutzeravatar
andre
professional
Beiträge: 385
Registriert: 01.12.2015, 21:08
Wohnort: Winsen (Luhe)
Kontaktdaten:

Re: tr-064 Adapter Fehler

Beitrag von andre » 04.01.2017, 12:43

Jey Cee hat geschrieben:Hat schon jemand ein issue auf github erstellt?
Denk nicht das soef hier mit liest.
Ich hab vorgestern einen issue gemeldet auf github und den hat soef dann gleich erledigt.

Gesendet von meinem m8 mit Tapatalk
Habe gerade ein issue auf git erstellt.

https://github.com/soef/ioBroker.tr-064/issues/12

...und danach diesen Thread entdeckt ;)

Aber wie es aussschaut bin ich ja nicht der einzige. Bei mir hatte der Adapter bisher wunderbar funktioniert. Habe damit in Verbindung mit Amazon Echo und dem Cloud-Adapter immer mein Gast-WLAN ein und aus geschaltet... :D

MfG,
André
Meine langsam aber stetig wachsende Tutorialsammlung zu ioBroker, Docker, DS & Co findet ihr hier: https://buanet.de/tutorials/
Kein individueller Support per PN oder E-Mail.

Benutzeravatar
andre
professional
Beiträge: 385
Registriert: 01.12.2015, 21:08
Wohnort: Winsen (Luhe)
Kontaktdaten:

Re: tr-064 Adapter Fehler

Beitrag von andre » 05.01.2017, 09:31

Ich habe im Übrigen die neue Version wieder deinstalliert.
Da im Admin keine alte Version aufgeführt ist, hier einmal der Weg über die Konsole für alle die (noch) nicht so fit sind:

Code: Alles auswählen

cd /opt/iobroker
iobroker stop
npm install iobroker.tr-064@0.1.12 --production
iobroker upload tr-064
iobroker start
MfG,
André
Meine langsam aber stetig wachsende Tutorialsammlung zu ioBroker, Docker, DS & Co findet ihr hier: https://buanet.de/tutorials/
Kein individueller Support per PN oder E-Mail.

Blue14
starter
Beiträge: 49
Registriert: 20.10.2016, 16:48

Re: tr-064 Adapter Fehler

Beitrag von Blue14 » 08.01.2017, 13:57

andre hat geschrieben:Ich habe im Übrigen die neue Version wieder deinstalliert.
Da im Admin keine alte Version aufgeführt ist, hier einmal der Weg über die Konsole für alle die (noch) nicht so fit sind:
Hallo Andre leider bin ich noch nich so fir wie du es schreibst ;)
Habe jetzt laut deiner Anleitung die alte Version wieder installiert leider sehe ich diese jetzt nicht unter Instanzen, muss ich noch irgendwas machen?
Neustart des Pi hat leider nichts gebracht auch nich den Cache vom Browser zu löschen.

mfg

Benutzeravatar
ruhr70
guru
Beiträge: 2274
Registriert: 24.02.2015, 19:40

Re: tr-064 Adapter Fehler

Beitrag von ruhr70 » 08.01.2017, 15:13

Das + im Reiter Adapter in der Spate Installieren.

Du hast den Adapter nun unter Adapter in der Version hinzugefügt und musst ihn nun mit dem Plus der Instanz hinzufügen.
Intel NUC (NUC6i5SYH) -> ESXi 6 > VM Ubuntu 16.04 ioBroker (redis) > VM Ubuntu 16.04 mySQL
Slave: Pi 3 ohne SD (Boot USB SLC)
CCU2, hue 2, DS 1512+, WeMos, Harmony Hub, Alexa
Adapter: Fritzbox / Skripte: dynamic hue, Bluetooth Scanner, WIFFI-wz

Blue14
starter
Beiträge: 49
Registriert: 20.10.2016, 16:48

Re: tr-064 Adapter Fehler

Beitrag von Blue14 » 08.01.2017, 15:35

ok dank dir, hat mich etwas verwirrt das da jetzt schon die version bei adapter bei stand.
Da hab ich den schluss gezogen das es installiert ist ^^

Benutzeravatar
ruhr70
guru
Beiträge: 2274
Registriert: 24.02.2015, 19:40

Re: tr-064 Adapter Fehler

Beitrag von ruhr70 » 09.01.2017, 10:10

ist mir auch anfangs passiert


Gesendet von iPhone mit Tapatalk
Intel NUC (NUC6i5SYH) -> ESXi 6 > VM Ubuntu 16.04 ioBroker (redis) > VM Ubuntu 16.04 mySQL
Slave: Pi 3 ohne SD (Boot USB SLC)
CCU2, hue 2, DS 1512+, WeMos, Harmony Hub, Alexa
Adapter: Fritzbox / Skripte: dynamic hue, Bluetooth Scanner, WIFFI-wz

vore
starter
Beiträge: 92
Registriert: 01.11.2015, 22:33

Re: tr-064 Adapter Fehler

Beitrag von vore » 14.01.2017, 15:01

Hallo!
Mein Gast-WLan lässst ich leider immer noch nicht schalten (aktuelle Version 0.1.20).
Bekommen den folgenden Eintrag im Log:

Code: Alles auswählen

TypeError:	2017-01-14 14:55:35.804	error	at Object.options.stateChange (/opt/iobroker/node_modules/iobroker.tr-064/node_modules/soef/soef.js:1062:21)
TypeError:	2017-01-14 14:55:35.804	error	at Object.onStateChange (/opt/iobroker/node_modules/iobroker.tr-064/tr-064.js:112:27)
TypeError:	2017-01-14 14:55:35.804	error	at TR064.setWLANGuest (/opt/iobroker/node_modules/iobroker.tr-064/tr-064.js:283:81)
TypeError:	2017-01-14 14:55:35.804	error	Cannot read property 'actions' of undefined
Habe mal eine Issue bei GitHub aufgemacht.

Benutzeravatar
Bluefox
Site Admin
Beiträge: 8102
Registriert: 13.07.2014, 14:42
Kontaktdaten:

Re: tr-064 Adapter Fehler

Beitrag von Bluefox » 16.01.2017, 19:47

vore hat geschrieben:Hallo!
Mein Gast-WLan lässst ich leider immer noch nicht schalten (aktuelle Version 0.1.20).
Bekommen den folgenden Eintrag im Log:

Code: Alles auswählen

TypeError:	2017-01-14 14:55:35.804	error	at Object.options.stateChange (/opt/iobroker/node_modules/iobroker.tr-064/node_modules/soef/soef.js:1062:21)
TypeError:	2017-01-14 14:55:35.804	error	at Object.onStateChange (/opt/iobroker/node_modules/iobroker.tr-064/tr-064.js:112:27)
TypeError:	2017-01-14 14:55:35.804	error	at TR064.setWLANGuest (/opt/iobroker/node_modules/iobroker.tr-064/tr-064.js:283:81)
TypeError:	2017-01-14 14:55:35.804	error	Cannot read property 'actions' of undefined
Habe mal eine Issue bei GitHub aufgemacht.
Es bringt nichts, mit uralter Version ein issue zu machen. Es gibt nämlich schon 0.1.27.

Benutzeravatar
arteck
guru
Beiträge: 1886
Registriert: 02.10.2016, 13:52
Wohnort: NRW

Re: tr-064 Adapter Fehler

Beitrag von arteck » 16.01.2017, 20:20

na dann teste ich mal ;)

Benutzeravatar
arteck
guru
Beiträge: 1886
Registriert: 02.10.2016, 13:52
Wohnort: NRW

Re: tr-064 Adapter Fehler

Beitrag von arteck » 16.01.2017, 20:24

bäm gefindet

tr-064.0 2017-01-16 20:21:04.759 error main - init:Error: read ECONNRESET - {"code":"ECONNRESET","errno":"ECONNRESET","syscall":"read"}
tr-064.0 2017-01-16 20:19:16.670 info starting. Version 0.1.27 in /opt/iobroker/node_modules/iobroker.tr-064, node: v4.7.2

Antworten