Error while connecting to cloud: Error: websocket error

Forum zum Mitteilen von Fehlern
jf62
starter
Beiträge: 32
Registriert: 18.12.2017, 08:52

Error while connecting to cloud: Error: websocket error

Beitrag von jf62 » 11.07.2018, 09:38

Seit gestern kommt bei mir oben genannte Fehlermeldung vom cloud Adapter (free).
Natürlich ist dann der Adapter auch nicht verbunden. Wenn ich mich via Browser auf iobroker.net anmelde erhalte ich folgende Fehlermeldung:
IOBROKER IST NOCH NICHT VERBUNDEN, DRÜCKEN SIE HIER, UM DIE VERBINDUNG HERZUSTELLEN

Gibt es hier einen Zusammenhang mit der Wartung gestern oder muss ich an anderer Stelle suchen?

Der Adapter lief seit Monaten (12/17) ohne jede Änderung und Murren.

Benutzeravatar
Stabilostick
professional
Beiträge: 270
Registriert: 23.05.2018, 14:52

Re: Error while connecting to cloud: Error: websocket error

Beitrag von Stabilostick » 11.07.2018, 09:46

Wird bereits unter z.B. viewtopic.php?t=15372 und viewtopic.php?t=15373 diskutiert. Laut letzterem soll es bereits wieder gehen.
Zuletzt geändert von Stabilostick am 11.07.2018, 09:49, insgesamt 1-mal geändert.

jf62
starter
Beiträge: 32
Registriert: 18.12.2017, 08:52

Re: Error while connecting to cloud: Error: websocket error

Beitrag von jf62 » 11.07.2018, 09:48

Dort ist nirgends die Rede von Socket Fehlern..

Benutzeravatar
Stabilostick
professional
Beiträge: 270
Registriert: 23.05.2018, 14:52

Re: Error while connecting to cloud: Error: websocket error

Beitrag von Stabilostick » 11.07.2018, 09:51

Danke für den Hinweis.

Benutzeravatar
Stabilostick
professional
Beiträge: 270
Registriert: 23.05.2018, 14:52

Re: Error while connecting to cloud: Error: websocket error

Beitrag von Stabilostick » 11.07.2018, 09:55

Habe es gerade ausprobiert:

cloud.0 2018-07-11 10:53:30.540 info Connection changed: connect
cloud.0 2018-07-11 10:53:30.385 info Trying to connect as system.user.admin
cloud.0 2018-07-11 10:52:30.380 info Connection changed: io client disconnect
cloud.0 2018-07-11 10:52:30.379 info Adapter redirected temporally to "https://iobroker.net:10560" in one minute. Reason: command from server
cloud.0 2018-07-11 10:52:30.268 info Trying to connect as system.user.admin
cloud.0 2018-07-11 10:52:29.781 info Connecting with https://iobroker.net:10555 with "<insert text here>"
cloud.0 2018-07-11 10:52:29.742 info starting. Version 2.6.2 in C:/dev/iobroker/node_modules/iobroker.cloud, node: v8.11.1

Klappt bei mir.

jf62
starter
Beiträge: 32
Registriert: 18.12.2017, 08:52

Re: Error while connecting to cloud: Error: websocket error

Beitrag von jf62 » 11.07.2018, 11:32

Wasi mich sehr stutzig macht, ist doch die Fehlermeldung nach Login auf iobroker.net

IOBROKER IST NOCH NICHT VERBUNDEN, DRÜCKEN SIE HIER, UM DIE VERBINDUNG HERZUSTELLEN

Was ist hier denn das Problem? Ich habe keine Idee mehr.

Benutzeravatar
Stabilostick
professional
Beiträge: 270
Registriert: 23.05.2018, 14:52

Re: Error while connecting to cloud: Error: websocket error

Beitrag von Stabilostick » 11.07.2018, 11:41

Wenn bei mir die Meldung "info Connection changed: connect" im Log kommt, geht bei mir auch die Anmeldung im Web. Was sagt Dein Log zum cloud-Adapter?

jf62
starter
Beiträge: 32
Registriert: 18.12.2017, 08:52

Re: Error while connecting to cloud: Error: websocket error

Beitrag von jf62 » 11.07.2018, 11:55

cloud.0 2018-07-11 12:54:37.427 error Error while connecting to cloud: Error: websocket error
cloud.0 2018-07-11 12:54:37.421 info Trying to connect as system.user.admin
cloud.0 2018-07-11 12:53:37.757 info Trying to connect as system.user.admin
cloud.0 2018-07-11 12:53:37.672 error Error while connecting to cloud: Error: websocket error
cloud.0 2018-07-11 12:53:37.366 info Connecting with https://iobroker.net:10550 with "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx"
cloud.0 2018-07-11 12:53:37.287 info starting. Version 2.6.2 in /opt/iobroker/node_modules/iobroker.cloud, node: v8.11.3
cloud.0 2018-07-11 12:53:37.095 info States connected to redis: 127.0.0.1:6379

Benutzeravatar
Stabilostick
professional
Beiträge: 270
Registriert: 23.05.2018, 14:52

Error while connecting to cloud: Error: websocket error

Beitrag von Stabilostick » 11.07.2018, 12:14

Ich habe andere Ports. Vielleicht habe ich eine andere Version des cloud-Adapters? Nee, auch 2.6.2

khg
starter
Beiträge: 54
Registriert: 23.02.2015, 12:51

Re: Error while connecting to cloud: Error: websocket error

Beitrag von khg » 11.07.2018, 12:49

habe seit gestern das gleiche Problem

loud.0 2018-07-11 13:44:43.979 error Error while connecting to cloud: Error: websocket error
cloud.0 2018-07-11 13:44:43.875 info Trying to connect as system.user.admin
cloud.0 2018-07-11 13:43:43.966 error Error while connecting to cloud: Error: websocket error
cloud.0 2018-07-11 13:43:43.852 info Trying to connect as system.user.admin

jf62
starter
Beiträge: 32
Registriert: 18.12.2017, 08:52

Re: Error while connecting to cloud: Error: websocket error

Beitrag von jf62 » 11.07.2018, 12:57

Habe gerade mal mit einer anderen Adresse mich neu registriert und ALLES neu eingerichtet.

Dies scheitert nun am aktivieren des ALEXA Skills (den ich natürlich vorher deaktiviert hatte) mit der Fehlermeldung: 404 remote answer

Allerdings wird die cloud Instanz nun grün und scheint verbunden zu sein

Also hier ist irgendetwas sehr schräg

Benutzeravatar
Stabilostick
professional
Beiträge: 270
Registriert: 23.05.2018, 14:52

Re: Error while connecting to cloud: Error: websocket error

Beitrag von Stabilostick » 11.07.2018, 14:00

Also unter https://iobroker.net:10550 ist der Port nicht offen. Da passt auch Deine originale Fehlermeldung. Der Port unter https://iobroker.net:10555 ist zwar offen, da passt aber (immer noch?) das Let's Encrypt-Zerifikat nicht (Stand 11.07.2018 14:50):

2018-07-11 14_51_04-Zertifikat-Ansicht_ _iobroker.net_.png
2018-07-11 14_51_04-Zertifikat-Ansicht_ _iobroker.net_.png (22.54 KiB) 99 mal betrachtet

Auf dem umgeleiteten Port 10560 ist alles ok und das Zertifikat läuft aktuell bis zum 08.10.2018.

Welche Cloud-URL steht jetzt bei Dir in der cloud-Adapterkonfiguration unter den "Erweiterten EInstellungen"? Ändert die sich eigentlich, wenn man was mit Alexa aktiviert?

jf62
starter
Beiträge: 32
Registriert: 18.12.2017, 08:52

Re: Error while connecting to cloud: Error: websocket error

Beitrag von jf62 » 11.07.2018, 15:04

https://iobroker.net:10560 (hab das mal auf den Port 10560 geändert) verbindet sich sofort.
Nur das Problem mit dem Fehler 404 bei der Aktivierung des Skills besteht weiterhin und somit kann Alexa ja nichts machen.

Benutzeravatar
eric2905
guru
Beiträge: 3290
Registriert: 23.03.2015, 18:41
Wohnort: Wuppertal

Re: Error while connecting to cloud: Error: websocket error

Beitrag von eric2905 » 11.07.2018, 15:07

Hat eigentlich keine mal die entspr. Threads und Postings im Forum gelesen?

Hier wurde das abgelaufene Zertifikat der Free-Cloud behandelt : Link

Im Thread zum Zertifikatswechsel auf der Pro-Cloud stehen die Lösungsansätze für die hängende Alexa drin.

Gruß,
Eric


Von unterwegs getippert
-----------------------------------------------------------------------------------------------
Roses are red, violets are blue,
if I listen to heavy metal, my neighbours do too

jf62
starter
Beiträge: 32
Registriert: 18.12.2017, 08:52

Re: Error while connecting to cloud: Error: websocket error

Beitrag von jf62 » 11.07.2018, 15:12

Fehler gefunden: beim Verbinden des skills mit Alexa wird eien Aufruf gestartet, der einen Code parsed. bei diesem parsin inst ein Fehler drin: dort steht sinngemäß etwas mit ?ALOGIN=...... Das A ist hier nicht nur überflüssig sondern falsch. Habe alles gelassen und nur das 'A' gelöscht und schon konnte er sich verbinden.

Dies ist ein BUG im Skill und sollte von den Entwicklern mal unter die Lupe genommen werden.

Benutzeravatar
Stabilostick
professional
Beiträge: 270
Registriert: 23.05.2018, 14:52

Re: Error while connecting to cloud: Error: websocket error

Beitrag von Stabilostick » 11.07.2018, 16:06

eric2905 hat geschrieben:
11.07.2018, 15:07
Hat eigentlich keine mal die entspr. Threads und Postings im Forum gelesen?
Hier wurde das abgelaufene Zertifikat der Free-Cloud behandelt : Link
Hallo Eric,

deswegen ja der Hinweis/Frage an Dich: Der Fehler NET::ERR_CERT_DATE_INVALID kommt jetzt (11.07.2018 17:05) auf dem Port 10555 immer noch. Trotz tausch des Zertifikats. Muss das so?

Viele Grüße,
Thomas

Benutzeravatar
Stabilostick
professional
Beiträge: 270
Registriert: 23.05.2018, 14:52

Re: Error while connecting to cloud: Error: websocket error

Beitrag von Stabilostick » 12.07.2018, 00:08

Ah, jetzt geht der 10555-Port auch wieder. Danke!

haselchen
professional
Beiträge: 203
Registriert: 07.10.2017, 14:30

Re: Error while connecting to cloud: Error: websocket error

Beitrag von haselchen » 12.07.2018, 19:04

Ich habe den Fehler leider immer noch.
Wie behebt man den?
Unbenannt1.PNG

Benutzeravatar
Stabilostick
professional
Beiträge: 270
Registriert: 23.05.2018, 14:52

Re: Error while connecting to cloud: Error: websocket error

Beitrag von Stabilostick » 12.07.2018, 21:13

Hmm, bei mir läuft es immer noch so ab:

2018-07-12 22:04:03.990 - cloud.0 starting. Version 2.6.2 in C:/dev/iobroker/node_modules/iobroker.cloud, node: v8.11.1
2018-07-12 22:04:04.028 - cloud.0 Connecting with https://iobroker.net:10555 with "xxxxxxxxxxxx"
2018-07-12 22:04:04.522 - cloud.0 Trying to connect as system.user.admin
2018-07-12 22:04:04.667 - cloud.0 Adapter redirected temporally to "https://iobroker.net:10560" in one minute. Reason: command from server
2018-07-12 22:04:04.669 - cloud.0 Connection changed: io client disconnect
2018-07-12 22:05:04.677 - cloud.0 Trying to connect as system.user.admin
2018-07-12 22:05:04.938 -cloud.0 Connection changed: connect

Und es geht. Ich weiß, das hilft Dir nicht.
Warum kommt bei Dir kein reconnect? Hast Du auch Version 2.6.2? Internet da?

haselchen
professional
Beiträge: 203
Registriert: 07.10.2017, 14:30

Re: Error while connecting to cloud: Error: websocket error

Beitrag von haselchen » 13.07.2018, 08:17

Mittlerweile ist die Ampel vom Cloud Adapter auf grün gesprungen.
Ausfalldauer: 2 Tage.
Logischerweise hatte ich davor den Adapter mal neu gestartet und ebenfalls auch mal gelöscht und wieder neu installiert. Ohne Erfolg.
Bisschen blöd gelaufen die ganze Aktion muss ich sagen.
Ich weiss die Arbeit der Entwickler zu schätzen, aber nur eine "Wartungsarbeiten Info" und dann kein Support bei dem Fehler, der danach entsteht zu geben, finde ich als Laien-Anwender doch recht ärgerlich.

Zitat eric2905 "Hier wurde das abgelaufene Zertifikat der Free-Cloud behandelt : Link"

Tut mir leid, aber da wird nichts behandelt oder eine Lösung aufgezeigt bezüglich des websocket errors, genauso wenig wie in anderen Threads oder Postings.

Antworten