web Instanz mit SSL startet nach Update auf Version 1.5.1 nicht mehr

Fragen zu Konfiguration und Bedienung von Adaptern
Antworten
NightWatcher
professional
Beiträge: 241
Registriert: 09.10.2016, 12:44

web Instanz mit SSL startet nach Update auf Version 1.5.1 nicht mehr

Beitrag von NightWatcher » 14.09.2018, 13:46

Ein ähnlicher Fehler wurde offensichtlich hier bereits beschrieben: viewtopic.php?t=16596

Bei mir scheint es nur den web Adapter zu betreffen, der SSL aktiviert hat.

Code: Alles auswählen

host.SERVER	2018-09-14 14:44:41.935	error	instance system.adapter.web.0 terminated with code 0 (OK)
Caught	2018-09-14 14:44:41.935	error	by controller[7]: at Decoder.add (C:\ioBroker\node_modules\iobroker.js-controller\node_modules\socket.io-parser\index.js:246:12)
Caught	2018-09-14 14:44:41.935	error	by controller[7]: at Decoder.Emitter.emit (C:\ioBroker\node_modules\iobroker.js-controller\node_modules\component-emitter\index.js:134:20)
Caught	2018-09-14 14:44:41.935	error	by controller[7]: at Decoder.<anonymous> (C:\ioBroker\node_modules\iobroker.js-controller\node_modules\component-bind\index.js:21:15)
Caught	2018-09-14 14:44:41.935	error	by controller[7]: at Manager.ondecoded (C:\ioBroker\node_modules\iobroker.js-controller\node_modules\socket.io-client\lib\manager.js:332:8)
Caught	2018-09-14 14:44:41.935	error	by controller[7]: at Manager.Emitter.emit (C:\ioBroker\node_modules\iobroker.js-controller\node_modules\socket.io-client\node_modules\component-emitter\index.js:133:20)
Caught	2018-09-14 14:44:41.935	error	by controller[7]: at Manager.<anonymous> (C:\ioBroker\node_modules\iobroker.js-controller\node_modules\component-bind\index.js:21:15)
Caught	2018-09-14 14:44:41.935	error	by controller[7]: at Socket.onpacket (C:\ioBroker\node_modules\iobroker.js-controller\node_modules\socket.io-client\lib\socket.js:236:12)
Caught	2018-09-14 14:44:41.935	error	by controller[7]: at Socket.onack (C:\ioBroker\node_modules\iobroker.js-controller\node_modules\socket.io-client\lib\socket.js:312:9)
Caught	2018-09-14 14:44:41.935	error	by controller[7]: at Socket.that.getForeignObject (C:\ioBroker\node_modules\iobroker.js-controller\lib\adapter.js:724:21)
Caught	2018-09-14 14:44:41.935	error	by controller[7]: at adapter.getCertificates (C:\ioBroker\node_modules\iobroker.web\main.js:239:29)
Caught	2018-09-14 14:44:41.935	error	by controller[7]: at initWebServer (C:\ioBroker\node_modules\iobroker.web\main.js:847:28)
Caught	2018-09-14 14:44:41.919	error	by controller[7]: at Object.createServer (C:\ioBroker\node_modules\iobroker.js-controller\lib\letsencrypt.js:55:26)
Caught	2018-09-14 14:44:41.919	error	by controller[7]: at Object.Greenlock.create (C:\ioBroker\node_modules\iobroker.js-controller\node_modules\greenlock\index.js:258:13)
Caught	2018-09-14 14:44:41.919	error	by controller[7]: at promisifyAllSelf (C:\ioBroker\node_modules\iobroker.js-controller\node_modules\greenlock\index.js:15:20)
Caught	2018-09-14 14:44:41.919	error	by controller[7]: at Array.forEach (native)
Caught	2018-09-14 14:44:41.919	error	by controller[7]: at C:\ioBroker\node_modules\iobroker.js-controller\node_modules\greenlock\index.js:17:33
Caught	2018-09-14 14:44:41.919	error	by controller[7]: TypeError: util.promisify is not a function
Caught	2018-09-14 14:44:41.919	error	by controller[6]: Detected Let's Encrypt v02 URL. Changing version to draft-12.
Caught	2018-09-14 14:44:41.919	error	by controller[5]: This will be required in versions v2.3+
Caught	2018-09-14 14:44:41.919	error	by controller[4]: (also 'npm install --save le-acme-core' as this legacy dependency will soon be removed)
Caught	2018-09-14 14:44:41.919	error	by controller[4]: 'v01' for Let's Encrypt v1 (deprecated)
Caught	2018-09-14 14:44:41.919	error	by controller[3]: or
Caught	2018-09-14 14:44:41.919	error	by controller[3]: ('v02' is an alias of 'draft-12'
Caught	2018-09-14 14:44:41.919	error	by controller[3]: 'draft-12' for Let's Encrypt v2 and ACME draft 12
Caught	2018-09-14 14:44:41.919	error	by controller[2]: Please specify 'version' option:
Caught	2018-09-14 14:44:41.919	error	by controller[2]: ==========================================================
Caught	2018-09-14 14:44:41.919	error	by controller[2]: == greenlock.js (v2.2.0+) ==
Caught	2018-09-14 14:44:41.919	error	by controller[1]: ==========================================================
web.0	2018-09-14 14:44:41.859	error	at Decoder.add (C:\ioBroker\node_modules\iobroker.js-controller\node_modules\socket.io-parser\index.js:246:12)
web.0	2018-09-14 14:44:41.859	error	at Decoder.Emitter.emit (C:\ioBroker\node_modules\iobroker.js-controller\node_modules\component-emitter\index.js:134:20)
web.0	2018-09-14 14:44:41.859	error	at Decoder.<anonymous> (C:\ioBroker\node_modules\iobroker.js-controller\node_modules\component-bind\index.js:21:15)
web.0	2018-09-14 14:44:41.859	error	at Manager.ondecoded (C:\ioBroker\node_modules\iobroker.js-controller\node_modules\socket.io-client\lib\manager.js:332:8)
web.0	2018-09-14 14:44:41.859	error	at Manager.Emitter.emit (C:\ioBroker\node_modules\iobroker.js-controller\node_modules\socket.io-client\node_modules\component-emitter\index.js:133:20)
web.0	2018-09-14 14:44:41.859	error	at Manager.<anonymous> (C:\ioBroker\node_modules\iobroker.js-controller\node_modules\component-bind\index.js:21:15)
web.0	2018-09-14 14:44:41.859	error	at Socket.onpacket (C:\ioBroker\node_modules\iobroker.js-controller\node_modules\socket.io-client\lib\socket.js:236:12)
web.0	2018-09-14 14:44:41.859	error	at Socket.onack (C:\ioBroker\node_modules\iobroker.js-controller\node_modules\socket.io-client\lib\socket.js:312:9)
web.0	2018-09-14 14:44:41.859	error	at Socket.that.getForeignObject (C:\ioBroker\node_modules\iobroker.js-controller\lib\adapter.js:724:21)
web.0	2018-09-14 14:44:41.859	error	at adapter.getCertificates (C:\ioBroker\node_modules\iobroker.web\main.js:239:29)
web.0	2018-09-14 14:44:41.859	error	at initWebServer (C:\ioBroker\node_modules\iobroker.web\main.js:847:28)
web.0	2018-09-14 14:44:41.859	error	at Object.createServer (C:\ioBroker\node_modules\iobroker.js-controller\lib\letsencrypt.js:55:26)
web.0	2018-09-14 14:44:41.859	error	at Object.Greenlock.create (C:\ioBroker\node_modules\iobroker.js-controller\node_modules\greenlock\index.js:258:13)
web.0	2018-09-14 14:44:41.859	error	at promisifyAllSelf (C:\ioBroker\node_modules\iobroker.js-controller\node_modules\greenlock\index.js:15:20)
web.0	2018-09-14 14:44:41.859	error	at Array.forEach (native)
web.0	2018-09-14 14:44:41.859	error	at C:\ioBroker\node_modules\iobroker.js-controller\node_modules\greenlock\index.js:17:33
web.0	2018-09-14 14:44:41.859	error	TypeError: util.promisify is not a function
web.0	2018-09-14 14:44:41.859	error	uncaught exception: util.promisify is not a function
Ich hoffe, ich kann mit der Info zu der Fehlersuche beitragen. Bis zu dem Update gerade eben lief der Adapter absolut fehlerfrei.
Zuletzt geändert von NightWatcher am 15.09.2018, 11:37, insgesamt 2-mal geändert.
Wago 750-881 - mit über 200 Ein- und Ausgängen, DMX512 Art-Net für Beleuchtung, 1-Wire für Umweltsensoren Aussen und Innen, ioBroker als Visualisierung

Benutzeravatar
apollon77
guru
Beiträge: 7104
Registriert: 10.04.2015, 12:27

Re: web Instanz mit SSL startet nach Update auf Version 1.5.1 nicht mehr

Beitrag von apollon77 » 14.09.2018, 14:07

Bitte für jetzt auf 1.4.2 zurückgehen. Sind dran
How-to:
* Debug-Log für einen Adapter/Instanz einschalten? -> Instanzen -> Expertenomodus -> Spalte Loglevel/Log-Stufe

NightWatcher
professional
Beiträge: 241
Registriert: 09.10.2016, 12:44

Re: [erledigt] web Instanz mit SSL startet nach Update auf Version 1.5.1 nicht mehr

Beitrag von NightWatcher » 14.09.2018, 16:18

Okay, habe ich getan. Dann warte ich mal auf eines der kommenden Updates 8-)
Wago 750-881 - mit über 200 Ein- und Ausgängen, DMX512 Art-Net für Beleuchtung, 1-Wire für Umweltsensoren Aussen und Innen, ioBroker als Visualisierung

Benutzeravatar
apollon77
guru
Beiträge: 7104
Registriert: 10.04.2015, 12:27

Re: [erledigt] web Instanz mit SSL startet nach Update auf Version 1.5.1 nicht mehr

Beitrag von apollon77 » 14.09.2018, 22:10

Bitte dann hier viewtopic.php?f=36&t=16798 schauen was es neues gibt
How-to:
* Debug-Log für einen Adapter/Instanz einschalten? -> Instanzen -> Expertenomodus -> Spalte Loglevel/Log-Stufe

NightWatcher
professional
Beiträge: 241
Registriert: 09.10.2016, 12:44

Re: web Instanz mit SSL startet nach Update auf Version 1.5.1 nicht mehr

Beitrag von NightWatcher » 15.09.2018, 11:37

Habe heute auf die 1.5.2 geupdatet. Fehler war leider immer noch. Habe zeitlich auch alle Adapter aktualisiert. Bin dann wieder zurück zur 1.4.2 über den Befehl

Code: Alles auswählen

npm i iobroker.js-controller@1.4.2 --production
Nun bleibt leider ein Fehler und der web Adapter mit SSL startet nicht mehr.

Ich nehme an, dass es womöglich am web Adapter liegt. (Da ja gestern mit dem zurückspielen auf 1.4.2 und alten Adaptern wieder wunderbar funktioniert hatte.

Meldung diesmal:

Code: Alles auswählen

host.SERVER	2018-09-15 12:34:08.628	error	instance system.adapter.web.0 terminated with code 0 (OK)
host.SERVER	2018-09-15 12:34:08.628	error	Caught by controller[10]: Just run that real quick, restart, and everything will work great.
host.SERVER	2018-09-15 12:34:08.612	error	Caught by controller[10]: npm install --save le-acme-core
host.SERVER	2018-09-15 12:34:08.612	error	Caught by controller[10]: Hey, this isn't a big deal, but you need to manually add v1 support:
host.SERVER	2018-09-15 12:34:08.612	error	Caught by controller[9]: === Error (easy-to-fix) ===
host.SERVER	2018-09-15 12:34:08.612	error	Caught by controller[8]: Please update to Let's Encrypt v2 (ACME draft 12)
host.SERVER	2018-09-15 12:34:08.612	error	Caught by controller[8]: Let's Encrypt v1 is deprecated.
host.SERVER	2018-09-15 12:34:08.612	error	Caught by controller[7]: === WARNING ===
host.SERVER	2018-09-15 12:34:08.612	error	Caught by controller[6]: Detected Let's Encrypt v01 URL (deprecated). Changing version to v01.
host.SERVER	2018-09-15 12:34:08.612	error	Caught by controller[5]: This will be required in versions v2.3+
host.SERVER	2018-09-15 12:34:08.612	error	Caught by controller[4]: (also 'npm install --save le-acme-core' as this legacy dependency will soon be removed)
host.SERVER	2018-09-15 12:34:08.612	error	Caught by controller[4]: 'v01' for Let's Encrypt v1 (deprecated)
host.SERVER	2018-09-15 12:34:08.612	error	Caught by controller[3]: or
host.SERVER	2018-09-15 12:34:08.612	error	Caught by controller[2]: ('v02' is an alias of 'draft-12'
host.SERVER	2018-09-15 12:34:08.612	error	Caught by controller[2]: 'draft-12' for Let's Encrypt v2 and ACME draft 12
host.SERVER	2018-09-15 12:34:08.612	error	Caught by controller[2]: Please specify 'version' option:
host.SERVER	2018-09-15 12:34:08.612	error	Caught by controller[1]: ==========================================================
host.SERVER	2018-09-15 12:34:08.612	error	Caught by controller[1]: == greenlock.js (v2.2.0+) ==
host.SERVER	2018-09-15 12:34:08.612	error	Caught by controller[1]: ==========================================================
web.0	2018-09-15 12:34:08.144	info	starting. Version 2.4.1 in C:/ioBroker/node_modules/iobroker.web, node: v6.14.2
Der Web Adapter läuft in der Version 2.4.1
Wago 750-881 - mit über 200 Ein- und Ausgängen, DMX512 Art-Net für Beleuchtung, 1-Wire für Umweltsensoren Aussen und Innen, ioBroker als Visualisierung

Antworten