[HowTo][Anleitung] Installation ioBroker in Docker auf Synology DiskStation

Fragen zur Installation von ioBroker auf unterschiedlichen Plattformen.
Telefisch
professional
Beiträge: 135
Registriert: 20.02.2017, 09:10

Re: [HowTo][Anleitung] Installation ioBroker in Docker auf Synology DiskStation

Beitrag von Telefisch » 22.12.2017, 10:26

Homoran hat geschrieben:Hilft das?
http://forum.iobroker.net/viewtopic.php ... hi#p105421

Gruß Rainer
Leider nein.
Nach wie vor Probleme bei der Namensauflösung.

Update:
hab jetzt nano installiert, mal sehen was mit der hosts machbar ist...

Update 2:
in der Hosts steht loacalhost und der DNS-Name der DS.
Ich kann da zwar drin ändern aber beim nächsten Neustart des Containers wird die Datei wieder zurück geändert.
Selbst wenn ich den Containernamen statt dem DS-Namen angebe, bekomme ich (dieses Mal andere) Fehlermeldungen, sobald ich versuche etwas (wie den Avahi-Dämon) zu installieren.

Ich weiß nicht mehr weiter :(

Gruß Carsten
Synology DS916+ (Docker), 2x Echo, 2x Dot, 2x Show

Telefisch
professional
Beiträge: 135
Registriert: 20.02.2017, 09:10

Re: [HowTo][Anleitung] Installation ioBroker in Docker auf Synology DiskStation

Beitrag von Telefisch » 24.12.2017, 14:43

So, nachdem ich das letzte Image wieder geladen habe, habe ich auch mal versucht dem Container den gleichen Namen wie der DS zu geben.
Ergebnis, die Installation vom ZWave-Adapter bleibt dauerhaft bei dieser Meldung stehen:
$ ./iobroker add zwave
Allen ein frohes Fest :)
Synology DS916+ (Docker), 2x Echo, 2x Dot, 2x Show

Telefisch
professional
Beiträge: 135
Registriert: 20.02.2017, 09:10

Re: [HowTo][Anleitung] Installation ioBroker in Docker auf Synology DiskStation

Beitrag von Telefisch » 25.12.2017, 15:26

ich habe nochmal ein paar weitere Versuche gemacht:

die Hosts-Datei hatte folgende Einträge:
127.0.0.1 localhost
::1 localhost
127.0.0.1 DS-Name
::1 DS-Name

Stimmt das so?
Änderungen werden eh beim Neustart zurückgesetzt, kann ich also nicht beeinflussen? :(


Wenn ich im Terminal "sudo nano /etc/hosts" eingebe bekomme ich folgende antworten:
sudo: Hostname iobroker kann nicht aufgelöst werden
sudo: Die Audit-Nachricht kann nicht gesendet werden: Unbekannter Fehler -1
sudo: pam_open_session: Systemfehler
sudo: Regelwerks-Plugin konnte Sitzung nicht initialisieren


wenn ich nur "nano /etc/hosts" eingebe wird die hosts-Datei halt im Editor geöffnet.
Synology DS916+ (Docker), 2x Echo, 2x Dot, 2x Show

Telefisch
professional
Beiträge: 135
Registriert: 20.02.2017, 09:10

Re: [HowTo][Anleitung] Installation ioBroker in Docker auf Synology DiskStation

Beitrag von Telefisch » 26.12.2017, 15:04

So,
nachdem nichts anderes half habe ich mal komplett neu installiert.
Also aus Image neuen Container erstellt mit allen Einstellungen nach Anweisung (Sind ja nur wenige).
Dann iobroker komplett neu installieren lassen mit den basics die der broker selbst gefunden hat.
Danach versucht ZWave zu installieren:
Spoiler: Show hidden text

Code: Alles auswählen

$ ./iobroker add zwave
npm install iobroker.zwave --unsafe-perm  --production --prefix "/opt/iobroker" (System call)
sudo: Hostname ioBroker2 kann nicht aufgelöst werdensudo: Die Audit-Nachricht kann nicht gesendet werden: Unbekannter Fehler -1
sudo: pam_open_session: Systemfehler
sudo: Regelwerks-Plugin konnte Sitzung nicht initialisieren

/opt/iobroker/node_modules/.staging/iobroker.zwave-936e120a/lib/preinstall.js:15    if (!suppressException) throw e;
                            ^

Error: Command failed: sudo apt-get install libudev-dev -y
sudo: Hostname ioBroker2 kann nicht aufgelöst werden
sudo: Die Audit-Nachricht kann nicht gesendet werden: Unbekannter Fehler -1
sudo: pam_open_session: Systemfehler
sudo: Regelwerks-Plugin konnte Sitzung nicht initialisieren

    at checkExecSyncError (child_process.js:473:13)
    at Object.execSync (child_process.js:513:13)
    at doScript (/opt/iobroker/node_modules/.staging/iobroker.zwave-936e120a/lib/preinstall.js:12:15)
    at Object.<anonymous> (/opt/iobroker/node_modules/.staging/iobroker.zwave-936e120a/lib/preinstall.js:25:7)
    at Module._compile (module.js:570:32)
    at Object.Module._extensions..js (module.js:579:10)
    at Module.load (module.js:487:32)
    at tryModuleLoad (module.js:446:12)
    at Function.Module._load (module.js:438:3)
    at Module.runMain (module.js:604:10)

npm ERR! Linux 3.10.102
npm ERR! argv "/usr/bin/node" "/usr/bin/npm" "install" "iobroker.zwave" "--unsafe-perm" "--production" "--prefix" "/opt/iobroker"npm ERR! node v6.12.2
npm ERR! npm  v3.10.10
npm ERR! code ELIFECYCLE

npm ERR! iobroker.zwave@0.9.0 preinstall: `node lib/preinstall.js`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the iobroker.zwave@0.9.0 preinstall script 'node lib/preinstall.js'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the iobroker.zwave package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node lib/preinstall.js
npm
 ERR! You can get information on how to open an issue for this project with:npm ERR!     npm bugs iobroker.zwave
npm ERR! Or if that isn't available, you can get their info via:
npm ERR!     npm owner ls iobroker.zwave
npm ERR! There is likely additional logging output above.


npm ERR! Please include the following file with any support request:npm ERR!     /opt/iobroker/npm-debug.log

host.ioBroker2 install adapter zwave
npm install iobroker.zwave --unsafe-perm  --production --prefix "/opt/iobroker" (System call)
sudo: Hostname ioBroker2 kann nicht aufgelöst werdensudo: Die Audit-Nachricht kann nicht gesendet werden: Unbekannter Fehler -1
sudo: pam_open_session: Systemfehler
sudo: Regelwerks-Plugin konnte Sitzung nicht initialisieren

/opt/iobroker/node_modules/.staging/iobroker.zwave-936e120a/lib/preinstall.js:15    if (!suppressException) throw e;
                            ^

Error: Command failed: sudo apt-get install libudev-dev -y
sudo: Hostname ioBroker2 kann nicht aufgelöst werden
sudo: Die Audit-Nachricht kann nicht gesendet werden: Unbekannter Fehler -1
sudo: pam_open_session: Systemfehler
sudo: Regelwerks-Plugin konnte Sitzung nicht initialisieren

    at checkExecSyncError (child_process.js:473:13)
    at Object.execSync (child_process.js:513:13)
    at doScript (/opt/iobroker/node_modules/.staging/iobroker.zwave-936e120a/lib/preinstall.js:12:15)
    at Object.<anonymous> (/opt/iobroker/node_modules/.staging/iobroker.zwave-936e120a/lib/preinstall.js:25:7)
    at Module._compile (module.js:570:32)
    at Object.Module._extensions..js (module.js:579:10)
    at Module.load (module.js:487:32)
    at tryModuleLoad (module.js:446:12)
    at Function.Module._load (module.js:438:3)
    at Module.runMain (module.js:604:10)

npm
 ERR! Linux 3.10.102npm ERR! argv "/usr/bin/node" "/usr/bin/npm" "install" "iobroker.zwave" "--unsafe-perm" "--production" "--prefix" "/opt/iobroker"
npm ERR! node v6.12.2
npm ERR! npm  v3.10.10
npm ERR! code ELIFECYCLE


npm ERR! iobroker.zwave@0.9.0 preinstall: `node lib/preinstall.js`npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the iobroker.zwave@0.9.0 preinstall script 'node lib/preinstall.js'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm 
ERR! If you do, this is most likely a problem with the iobroker.zwave package,npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node lib/preinstall.js
npm ERR! You can get information on how to open an issue for this project with:
npm ERR!     npm bugs iobroker.zwave
npm ERR! Or if that isn't available, you can get their info via:
npm ERR!     npm owner ls iobroker.zwave
npm ERR! There is likely additional logging output above.


npm ERR! Please include the following file with any support request:npm ERR!     /opt/iobroker/npm-debug.log

host.ioBroker2 install adapter zwave
npm install iobroker.zwave --unsafe-perm  --production --prefix "/opt/iobroker" (System call)
Also irgendwie ist da am Image was marode :(
Damit bin ich jetzt vollends aufgeschmissen... *heul*
Synology DS916+ (Docker), 2x Echo, 2x Dot, 2x Show

Benutzeravatar
andre
professional
Beiträge: 374
Registriert: 01.12.2015, 21:08
Wohnort: Winsen (Luhe)
Kontaktdaten:

Re: [HowTo][Anleitung] Installation ioBroker in Docker auf Synology DiskStation

Beitrag von andre » 26.12.2017, 18:30

Telefisch hat geschrieben:So,
nachdem nichts anderes half habe ich mal komplett neu installiert.
Also aus Image neuen Container erstellt mit allen Einstellungen nach Anweisung (Sind ja nur wenige).
Dann iobroker komplett neu installieren lassen mit den basics die der broker selbst gefunden hat.
Danach versucht ZWave zu installieren:
Spoiler: Show hidden text

Code: Alles auswählen

$ ./iobroker add zwave
npm install iobroker.zwave --unsafe-perm  --production --prefix "/opt/iobroker" (System call)
sudo: Hostname ioBroker2 kann nicht aufgelöst werdensudo: Die Audit-Nachricht kann nicht gesendet werden: Unbekannter Fehler -1
sudo: pam_open_session: Systemfehler
sudo: Regelwerks-Plugin konnte Sitzung nicht initialisieren

/opt/iobroker/node_modules/.staging/iobroker.zwave-936e120a/lib/preinstall.js:15    if (!suppressException) throw e;
                            ^

Error: Command failed: sudo apt-get install libudev-dev -y
sudo: Hostname ioBroker2 kann nicht aufgelöst werden
sudo: Die Audit-Nachricht kann nicht gesendet werden: Unbekannter Fehler -1
sudo: pam_open_session: Systemfehler
sudo: Regelwerks-Plugin konnte Sitzung nicht initialisieren

    at checkExecSyncError (child_process.js:473:13)
    at Object.execSync (child_process.js:513:13)
    at doScript (/opt/iobroker/node_modules/.staging/iobroker.zwave-936e120a/lib/preinstall.js:12:15)
    at Object.<anonymous> (/opt/iobroker/node_modules/.staging/iobroker.zwave-936e120a/lib/preinstall.js:25:7)
    at Module._compile (module.js:570:32)
    at Object.Module._extensions..js (module.js:579:10)
    at Module.load (module.js:487:32)
    at tryModuleLoad (module.js:446:12)
    at Function.Module._load (module.js:438:3)
    at Module.runMain (module.js:604:10)

npm ERR! Linux 3.10.102
npm ERR! argv "/usr/bin/node" "/usr/bin/npm" "install" "iobroker.zwave" "--unsafe-perm" "--production" "--prefix" "/opt/iobroker"npm ERR! node v6.12.2
npm ERR! npm  v3.10.10
npm ERR! code ELIFECYCLE

npm ERR! iobroker.zwave@0.9.0 preinstall: `node lib/preinstall.js`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the iobroker.zwave@0.9.0 preinstall script 'node lib/preinstall.js'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the iobroker.zwave package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node lib/preinstall.js
npm
 ERR! You can get information on how to open an issue for this project with:npm ERR!     npm bugs iobroker.zwave
npm ERR! Or if that isn't available, you can get their info via:
npm ERR!     npm owner ls iobroker.zwave
npm ERR! There is likely additional logging output above.


npm ERR! Please include the following file with any support request:npm ERR!     /opt/iobroker/npm-debug.log

host.ioBroker2 install adapter zwave
npm install iobroker.zwave --unsafe-perm  --production --prefix "/opt/iobroker" (System call)
sudo: Hostname ioBroker2 kann nicht aufgelöst werdensudo: Die Audit-Nachricht kann nicht gesendet werden: Unbekannter Fehler -1
sudo: pam_open_session: Systemfehler
sudo: Regelwerks-Plugin konnte Sitzung nicht initialisieren

/opt/iobroker/node_modules/.staging/iobroker.zwave-936e120a/lib/preinstall.js:15    if (!suppressException) throw e;
                            ^

Error: Command failed: sudo apt-get install libudev-dev -y
sudo: Hostname ioBroker2 kann nicht aufgelöst werden
sudo: Die Audit-Nachricht kann nicht gesendet werden: Unbekannter Fehler -1
sudo: pam_open_session: Systemfehler
sudo: Regelwerks-Plugin konnte Sitzung nicht initialisieren

    at checkExecSyncError (child_process.js:473:13)
    at Object.execSync (child_process.js:513:13)
    at doScript (/opt/iobroker/node_modules/.staging/iobroker.zwave-936e120a/lib/preinstall.js:12:15)
    at Object.<anonymous> (/opt/iobroker/node_modules/.staging/iobroker.zwave-936e120a/lib/preinstall.js:25:7)
    at Module._compile (module.js:570:32)
    at Object.Module._extensions..js (module.js:579:10)
    at Module.load (module.js:487:32)
    at tryModuleLoad (module.js:446:12)
    at Function.Module._load (module.js:438:3)
    at Module.runMain (module.js:604:10)

npm
 ERR! Linux 3.10.102npm ERR! argv "/usr/bin/node" "/usr/bin/npm" "install" "iobroker.zwave" "--unsafe-perm" "--production" "--prefix" "/opt/iobroker"
npm ERR! node v6.12.2
npm ERR! npm  v3.10.10
npm ERR! code ELIFECYCLE


npm ERR! iobroker.zwave@0.9.0 preinstall: `node lib/preinstall.js`npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the iobroker.zwave@0.9.0 preinstall script 'node lib/preinstall.js'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm 
ERR! If you do, this is most likely a problem with the iobroker.zwave package,npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node lib/preinstall.js
npm ERR! You can get information on how to open an issue for this project with:
npm ERR!     npm bugs iobroker.zwave
npm ERR! Or if that isn't available, you can get their info via:
npm ERR!     npm owner ls iobroker.zwave
npm ERR! There is likely additional logging output above.


npm ERR! Please include the following file with any support request:npm ERR!     /opt/iobroker/npm-debug.log

host.ioBroker2 install adapter zwave
npm install iobroker.zwave --unsafe-perm  --production --prefix "/opt/iobroker" (System call)
Also irgendwie ist da am Image was marode :(
Damit bin ich jetzt vollends aufgeschmissen... *heul*
Hallo Telefisch,
sorry dass ich mich jetzt erst wieder zu Wort melde... aber Weihnachten halt... ;)
Ich kann das ganze Verhalten irgendwie nicht nachvollziehen. Irgendwas scheint mit deiner Namensauflösung im Container nicht zu passen... bevor ich jetzt aber die Logs die du bereit gestellt hast durcharbeite eine kurze Vorabfrage: Welche Versionen hast du im Einsatz? Über die Systemsteuerung findest du ja die DS Version. Bei mir ist das:

Code: Alles auswählen

DSM 6.1.4-15217 Update 5
Über das Paket-Zentrum gibt es dann ja auch noch eine Version des Docker Pakets. Bei mir ist das:

Code: Alles auswählen

17.05.0-0367
Wie sieht das bei dir aus? Stehen ggf. Updates bereit?

MfG,
André
Homematic - Synology DiskStation (DSM6, ioBroker, Docker, Survelliance Station uvm.) - Intel TV Stick (Win10) + ELO Touch Display - Amazon Echo - Denon AVR - Odroid C2 (LibreELEC) - MiLight LED-System - Cubietruck (Armbian) Multihost-Client + RFlink

Telefisch
professional
Beiträge: 135
Registriert: 20.02.2017, 09:10

Re: [HowTo][Anleitung] Installation ioBroker in Docker auf Synology DiskStation

Beitrag von Telefisch » 26.12.2017, 18:58

Hallo André, kein Problem...
Weihnachten gehört der Familie.
Ich habe alles auf aktuellem Stand.
Gleiche Versionen wie bei dir.

Gruß Carsten
Synology DS916+ (Docker), 2x Echo, 2x Dot, 2x Show

Benutzeravatar
andre
professional
Beiträge: 374
Registriert: 01.12.2015, 21:08
Wohnort: Winsen (Luhe)
Kontaktdaten:

Re: [HowTo][Anleitung] Installation ioBroker in Docker auf Synology DiskStation

Beitrag von andre » 26.12.2017, 19:35

Telefisch hat geschrieben:Hallo André, kein Problem...
Weihnachten gehört der Familie.
Ich habe alles auf aktuellem Stand.
Gleiche Versionen wie bei dir.

Gruß Carsten
OK, ich habe zwischenzeitlich das Verhalten nachstellen können. Scheint mir so als komme der Container unter bestimmten Voraussetzungen mit dem Installationsscript des zwave-Adapters nicht klar. Schaue mir das gleich mal genauer an wenn die Kinder im Bett sind. ;)

MfG,
André
Homematic - Synology DiskStation (DSM6, ioBroker, Docker, Survelliance Station uvm.) - Intel TV Stick (Win10) + ELO Touch Display - Amazon Echo - Denon AVR - Odroid C2 (LibreELEC) - MiLight LED-System - Cubietruck (Armbian) Multihost-Client + RFlink

Telefisch
professional
Beiträge: 135
Registriert: 20.02.2017, 09:10

Re: [HowTo][Anleitung] Installation ioBroker in Docker auf Synology DiskStation

Beitrag von Telefisch » 26.12.2017, 21:03

...wie geschrieben funktioniert der YAHKA Adapter auch nicht mehr.
Vermutlich weil Avahi fehlt.
Da habe ich ähnliche Fehlermeldungen wenn ich das installieren möchte.
Der YAHKA hat vor dem Update des Images noch funktioniert.
Synology DS916+ (Docker), 2x Echo, 2x Dot, 2x Show

Benutzeravatar
andre
professional
Beiträge: 374
Registriert: 01.12.2015, 21:08
Wohnort: Winsen (Luhe)
Kontaktdaten:

Re: [HowTo][Anleitung] Installation ioBroker in Docker auf Synology DiskStation

Beitrag von andre » 26.12.2017, 23:19

So, was ich jetzt heraus finden konnte ist, dass ich aktuell keine echte Lösung zum Installationsproblem mit dem zwave adapter anbieten kann. :(
Wie es ausschaut gibt es ein generelles Problem mit der Ausführung von Befehlen per sudo in einem Container der das selbe Netzwerk wie das Hostsystem benutzt. Leider wird im Installationsscript des zwave-Adapters gerade dieser Aufruf verwendet sodass die Installation dann in Fehler läuft.

Ein denkbarer Workaround könnte sein, dass man den Docker Container ohne das Häkchen "Dasselbe Netzwerk wie Docker Host verwenden" erstellt und alle Ports, die ioBroker und dessen Adapter benutzen manuell mappt. So habe ich auch meinen Testcontainer laufen und da geht die Installation ja fehlerfrei durch... Sorry, mehr Optionen konnte ich leider nicht finden...
Telefisch hat geschrieben:...wie geschrieben funktioniert der YAHKA Adapter auch nicht mehr.
Vermutlich weil Avahi fehlt.
Da habe ich ähnliche Fehlermeldungen wenn ich das installieren möchte.
Der YAHKA hat vor dem Update des Images noch funktioniert.
Was Avahi angeht, das kann ich leider nicht nachstellen. Hatte hier irgendwo einen Post, dass sich der Avahi-Dienst im Docker mit dem Avahi-Dienst der DS behakt. Schau mal im DSM unter "Systemsteuerung - Dateidienste - Erweitert" ob der Bonjour-Dienst aktiviert ist. Falls ja, einfach mal den Haken entfernen und den Container neu starten. Wenn dann der Avahi weiterhin nicht startet könntest du mal über die Kommandozeile "/etc/init.d/avahi-daemon start" versuchen und schauen was es dazu als Fehlermeldung gibt...

Wichtigste Erkenntnis von heute Abend: Beim Arbeiten über die Kommandozeile im Container immer ohne "sudo". Zumindest wenn der Container das selbe Netzwerk wie der Host verwendet...

MfG,
André
Homematic - Synology DiskStation (DSM6, ioBroker, Docker, Survelliance Station uvm.) - Intel TV Stick (Win10) + ELO Touch Display - Amazon Echo - Denon AVR - Odroid C2 (LibreELEC) - MiLight LED-System - Cubietruck (Armbian) Multihost-Client + RFlink

Telefisch
professional
Beiträge: 135
Registriert: 20.02.2017, 09:10

Re: [HowTo][Anleitung] Installation ioBroker in Docker auf Synology DiskStation

Beitrag von Telefisch » 27.12.2017, 08:33

Hmm...
Bonjour abgeschaltet und Container neu gestartet, ohne Erfolg.
Versucht Avahi manuell zu starten:
root@iobroker:/# /etc/init.d/avahi-daemon start
[FAIL] Starting Avahi mDNS/DNS-SD Daemon: avahi-daemon failed!
Gibt es irgendwo eine Zusammenfassung welche Ports weitergeleitet werden müssen?
...wird ja nicht nur 8081 und 8082 sein...?

Und danke für Deine Hilfe!

Gruß Carsten
Synology DS916+ (Docker), 2x Echo, 2x Dot, 2x Show

Benutzeravatar
andre
professional
Beiträge: 374
Registriert: 01.12.2015, 21:08
Wohnort: Winsen (Luhe)
Kontaktdaten:

Re: [HowTo][Anleitung] Installation ioBroker in Docker auf Synology DiskStation

Beitrag von andre » 27.12.2017, 09:23

Telefisch hat geschrieben:Hmm...
Bonjour abgeschaltet und Container neu gestartet, ohne Erfolg.
Versucht Avahi manuell zu starten:
root@iobroker:/# /etc/init.d/avahi-daemon start
[FAIL] Starting Avahi mDNS/DNS-SD Daemon: avahi-daemon failed!
Gibt es irgendwo eine Zusammenfassung welche Ports weitergeleitet werden müssen?
...wird ja nicht nur 8081 und 8082 sein...?

Und danke für Deine Hilfe!

Gruß Carsten
Hallo, läuft bei dir im Container ein Prozess mit dem Ausführungsbefehl "dbus-daemon --system"? Falls nicht, versuche mal den Befehl auszuführen. Könnte dann ggf. so aussehen:

Code: Alles auswählen

root@iobroker:/opt/iobroker# dbus-daemon --system
Failed to start message bus: The pid file "/var/run/dbus/pid" exists, if the message bus is not running, remove this file
root@iobroker:/opt/iobroker# rm /var/run/dbus/pid
root@iobroker:/opt/iobroker# dbus-daemon --system
root@iobroker:/opt/iobroker# /etc/init.d/avahi-daemon start
[ ok ] Starting Avahi mDNS/DNS-SD Daemon: avahi-daemon.
root@iobroker:/opt/iobroker#
Der dbus ist Vorraussetzung für den avahi....

Was die Zusammenfassung der ioBroker Ports angeht, da kenne ich zumindest keine Quelle. Der ein oder andere Adapter bringt ja auch noch einen Port mit... schwierig da den Überblick zu behalten... Überlege gerade ob man sowas mal anfangen soll, dann könnte man ggf. den Docker-Container generell (auch für nicht so versierte Benutzer) mit Portforwarding betreiben. Allerdings müsste man mal schauen was das ggf noch für andere Problemchen mitbringen könnte. ;)

MfG,
André
Homematic - Synology DiskStation (DSM6, ioBroker, Docker, Survelliance Station uvm.) - Intel TV Stick (Win10) + ELO Touch Display - Amazon Echo - Denon AVR - Odroid C2 (LibreELEC) - MiLight LED-System - Cubietruck (Armbian) Multihost-Client + RFlink

Telefisch
professional
Beiträge: 135
Registriert: 20.02.2017, 09:10

Re: [HowTo][Anleitung] Installation ioBroker in Docker auf Synology DiskStation

Beitrag von Telefisch » 27.12.2017, 09:59

der dbus-daemon war nicht gestartet.
Ich habe das manuell gemacht und konnte jetzt auch den avahi-daemon starten.
Jetzt ist YAHKA wieder grün.


Ich habe aber zwischenzeitlich auch einen neuen Container erstellt ohne gleiches Netzwerk.
Nachdem ich 9000, 9001, 8081 und 8082 freigegeben hatte konnte ich auch direkt den Yahka installieren.
ZWave ist auch durchgelaufen, da kann ich bisher nur noch keinen USB-Stick auswählen.
Ich denke es sind damit einige Probleme tatsächlich gelöst.
Jetzt versuche ich erstmal den Container wieder auf die alte Installation zu mappen und dann sehen wir weiter.
Kannst Du mir außer den genannten Ports noch welche sagen, die unbedingt nötig sind?
Die speziellen Adapter-Ports muss ich dann ggf. anders herausfinden.
Synology DS916+ (Docker), 2x Echo, 2x Dot, 2x Show

Benutzeravatar
andre
professional
Beiträge: 374
Registriert: 01.12.2015, 21:08
Wohnort: Winsen (Luhe)
Kontaktdaten:

Re: [HowTo][Anleitung] Installation ioBroker in Docker auf Synology DiskStation

Beitrag von andre » 27.12.2017, 10:11

Das klingt ja schon mal nicht so verkehrt.

Was den USB Stick angeht... Soweit ich weiß, hat der Container nur Zugriff auf die USB-Devices wenn er mit erweiterten Rechten ausgeführt wird (Häkchen "Container mit hoher Priorität ausführen"). ist das Häkchen bei dir gesetzt?

Die genannten Ports hören sich gut an. Wüsste jetzt aus dem Stand auch nicht mehr...

MfG,
André
Homematic - Synology DiskStation (DSM6, ioBroker, Docker, Survelliance Station uvm.) - Intel TV Stick (Win10) + ELO Touch Display - Amazon Echo - Denon AVR - Odroid C2 (LibreELEC) - MiLight LED-System - Cubietruck (Armbian) Multihost-Client + RFlink

Telefisch
professional
Beiträge: 135
Registriert: 20.02.2017, 09:10

Re: [HowTo][Anleitung] Installation ioBroker in Docker auf Synology DiskStation

Beitrag von Telefisch » 27.12.2017, 11:21

Das mit dem USB-Stick funktioniert jetzt auch, im Moment kopiere ich grade ein Backup zurück.
Bisher hat der hm-rpc noch nen roten Punkt. Da fehlt wohl der richtige Port, denke ich.
Spoiler: Show hidden text
hm-rpc.0 2017-12-27 11:20:22.560 info Disconnected
hm-rpc.0 2017-12-27 11:20:22.513 info Connected
hm-rpc.0 2017-12-27 11:20:22.433 info xmlrpc -> 192.168.178.183:2010 init ["http://192.168.178.2:2010",""]
hm-rpc.0 2017-12-27 11:20:22.433 error Error: listen EADDRNOTAVAIL 192.168.178.2:2010 at Object.exports._errnoException (util.js:1020:11) at exports._exceptionWithHostPort (util.js:1043:20) at Server._listen2 (net.js:1249:19)
hm-rpc.0 2017-12-27 11:20:22.433 error uncaught exception: listen EADDRNOTAVAIL 192.168.178.2:2010
hm-rpc.0 2017-12-27 11:20:22.433 info xmlrpc client is trying to connect to 192.168.178.183:2010 with ["http://192.168.178.2:2010","hm-rpc.0"]
hm-rpc.0 2017-12-27 11:20:22.432 info xmlrpc server is trying to listen on 192.168.178.2:2010
hm-rpc.0 2017-12-27 11:20:22.327 info starting. Version 1.4.14 in /opt/iobroker/node_modules/iobroker.hm-rpc, node: v6.12.2
2010 scheint aber nicht auszureichen, den hab ich bereits weitergereicht :(

Update: gelöst, Adapteradresse darf nicht auf "auf allen IPs hören" stehen sondern muss auf die Schnittstelle gestellt werden
Zuletzt geändert von Telefisch am 27.12.2017, 20:09, insgesamt 1-mal geändert.
Synology DS916+ (Docker), 2x Echo, 2x Dot, 2x Show

Telefisch
professional
Beiträge: 135
Registriert: 20.02.2017, 09:10

Re: [HowTo][Anleitung] Installation ioBroker in Docker auf Synology DiskStation

Beitrag von Telefisch » 27.12.2017, 20:05

...doppelpost gelöscht
Zuletzt geändert von Telefisch am 27.12.2017, 20:07, insgesamt 1-mal geändert.
Synology DS916+ (Docker), 2x Echo, 2x Dot, 2x Show

Telefisch
professional
Beiträge: 135
Registriert: 20.02.2017, 09:10

Re: [HowTo][Anleitung] Installation ioBroker in Docker auf Synology DiskStation

Beitrag von Telefisch » 27.12.2017, 20:05

Ach verdammt,
irgendwie läuft das noch immer nicht richtig.

Der Homekit-Adapter läuft zwar aber vom iOS aus finde ich keine HomeKit Bridge.

Dann habe ich ein Backup zurückgespielt um nicht alles neu installieren zu müssen aber jetzt kann ich den Zwave-Adapter wieder nicht installieren:
Spoiler: Show hidden text

$ ./iobroker add zwave
npm install iobroker.zwave --unsafe-perm --production --prefix "/opt/iobroker" (System call)
module.js:471 throw err;
^

Error: Cannot find module '../'
at Function.Module._resolveFilename (module.js:469:15)
at Function.Module._load (module.js:417:25)
at Module.require (module.js:497:17)
at require (internal/module.js:20:19)
at Object.<anonymous> (/opt/iobroker/node_modules/.bin/which:2:13)
at Module._compile (module.js:570:32)
at Object.Module._extensions..js (module.js:579:10)
at Module.load (module.js:487:32)
at tryModuleLoad (module.js:446:12)
at Function.Module._load (module.js:438:3)
module.js:471
throw err;
^

Error: Cannot find module '../'
at Function.Module._resolveFilename (module.js:469:15)
at Function.Module._load (module.js:417:25)
at Module.require (module.js:497:17)
at require (internal/module.js:20:19)
at Object.<anonymous> (/opt/iobroker/node_modules/.bin/which:2:13)
at Module._compile (module.js:570:32)
at Object.Module._extensions..js (module.js:579:10)
at Module.load (module.js:487:32)
at tryModuleLoad (module.js:446:12)
at Function.Module._load (module.js:438:3)

gyp: Call to 'which nodejs || which node' returned exit status 1 while in binding.gyp. while trying to load binding.gyp
gyp
ERR! configure error
gyp ERR! stack Error: `gyp` failed with exit code: 1gyp
ERR! stack at ChildProcess.onCpExit (/usr/lib/node_modules/npm/node_modules/node-gyp/lib/configure.js:305:16)gyp ERR! stack at emitTwo (events.js:106:13)
gyp ERR! stack at ChildProcess.emit (events.js:191:7)
gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:219:12)

gyp ERR! System Linux 3.10.102gyp ERR! command "/usr/bin/node" "/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
gyp ERR! cwd /opt/iobroker/node_modules/openzwave-shared
gyp ERR! node -v v6.12.2
gyp ERR! node-gyp -v v3.4.0
gyp ERR! not ok

npm
ERR! Linux 3.10.102npm ERR! argv "/usr/bin/node" "/usr/bin/npm" "install" "iobroker.zwave" "--unsafe-perm" "--production" "--prefix" "/opt/iobroker"
npm ERR! node v6.12.2
npm ERR! npm v3.10.10
npm ERR! code ELIFECYCLE


npm ERR! openzwave-shared@1.4.0 install: `node-gyp rebuild`npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the openzwave-shared@1.4.0 install script 'node-gyp rebuild'.
npm ERR! Make sure you have the latest version of node.js and npm installed.

npm ERR! If you do, this is most likely a problem with the openzwave-shared package,npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node-gyp rebuild
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs openzwave-shared
npm ERR! Or if that isn't available, you can get their info via:
npm ERR! npm owner ls openzwave-shared
npm ERR! There is likely additional logging output above.


npm
ERR! Please include the following file with any support request:npm ERR! /opt/iobroker/npm-debug.log

host.iobroker install adapter zwave
npm install iobroker.zwave --unsafe-perm --production --prefix "/opt/iobroker" (System call)
So langsam verliere ich ernsthaft den Spass am ioBroker :(
Synology DS916+ (Docker), 2x Echo, 2x Dot, 2x Show

Benutzeravatar
andre
professional
Beiträge: 374
Registriert: 01.12.2015, 21:08
Wohnort: Winsen (Luhe)
Kontaktdaten:

Re: RE: Re: [HowTo][Anleitung] Installation ioBroker in Docker auf Synology DiskStation

Beitrag von andre » 28.12.2017, 00:51

Telefisch hat geschrieben:Ach verdammt,
irgendwie läuft das noch immer nicht richtig.

Der Homekit-Adapter läuft zwar aber vom iOS aus finde ich keine HomeKit Bridge.

Dann habe ich ein Backup zurückgespielt um nicht alles neu installieren zu müssen aber jetzt kann ich den Zwave-Adapter wieder nicht installieren:
Spoiler: Show hidden text

$ ./iobroker add zwave
npm install iobroker.zwave --unsafe-perm --production --prefix "/opt/iobroker" (System call)
module.js:471 throw err;
^

Error: Cannot find module '../'
at Function.Module._resolveFilename (module.js:469:15)
at Function.Module._load (module.js:417:25)
at Module.require (module.js:497:17)
at require (internal/module.js:20:19)
at Object.<anonymous> (/opt/iobroker/node_modules/.bin/which:2:13)
at Module._compile (module.js:570:32)
at Object.Module._extensions..js (module.js:579:10)
at Module.load (module.js:487:32)
at tryModuleLoad (module.js:446:12)
at Function.Module._load (module.js:438:3)
module.js:471
throw err;
^

Error: Cannot find module '../'
at Function.Module._resolveFilename (module.js:469:15)
at Function.Module._load (module.js:417:25)
at Module.require (module.js:497:17)
at require (internal/module.js:20:19)
at Object.<anonymous> (/opt/iobroker/node_modules/.bin/which:2:13)
at Module._compile (module.js:570:32)
at Object.Module._extensions..js (module.js:579:10)
at Module.load (module.js:487:32)
at tryModuleLoad (module.js:446:12)
at Function.Module._load (module.js:438:3)

gyp: Call to 'which nodejs || which node' returned exit status 1 while in binding.gyp. while trying to load binding.gyp
gyp
ERR! configure error
gyp ERR! stack Error: `gyp` failed with exit code: 1gyp
ERR! stack at ChildProcess.onCpExit (/usr/lib/node_modules/npm/node_modules/node-gyp/lib/configure.js:305:16)gyp ERR! stack at emitTwo (events.js:106:13)
gyp ERR! stack at ChildProcess.emit (events.js:191:7)
gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:219:12)

gyp ERR! System Linux 3.10.102gyp ERR! command "/usr/bin/node" "/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
gyp ERR! cwd /opt/iobroker/node_modules/openzwave-shared
gyp ERR! node -v v6.12.2
gyp ERR! node-gyp -v v3.4.0
gyp ERR! not ok

npm
ERR! Linux 3.10.102npm ERR! argv "/usr/bin/node" "/usr/bin/npm" "install" "iobroker.zwave" "--unsafe-perm" "--production" "--prefix" "/opt/iobroker"
npm ERR! node v6.12.2
npm ERR! npm v3.10.10
npm ERR! code ELIFECYCLE


npm ERR! openzwave-shared@1.4.0 install: `node-gyp rebuild`npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the openzwave-shared@1.4.0 install script 'node-gyp rebuild'.
npm ERR! Make sure you have the latest version of node.js and npm installed.

npm ERR! If you do, this is most likely a problem with the openzwave-shared package,npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node-gyp rebuild
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs openzwave-shared
npm ERR! Or if that isn't available, you can get their info via:
npm ERR! npm owner ls openzwave-shared
npm ERR! There is likely additional logging output above.


npm
ERR! Please include the following file with any support request:npm ERR! /opt/iobroker/npm-debug.log

host.iobroker install adapter zwave
npm install iobroker.zwave --unsafe-perm --production --prefix "/opt/iobroker" (System call)
So langsam verliere ich ernsthaft den Spass am ioBroker :(
Hallo Carsten,
sorry dass es bei dir immernoch nicht richtig rund läuft. Ich bin gerne bereit wo es geht zu unterstützen und falls nötig auch das Image anzupassen, aber was homekit und zwave angeht, da stochere ich, mangels passender Hardware, echt im Nebel...
Was ich halt nur machen kann, sind die Informationen über die Adapter (von git) nehmen und das ganze in meinem Image bestmöglich vorbereiten.

Wenn ich jetzt (so teste ich) ein frisches Image nehme, einen Container starte und ausschließlich die Option "mit erhöhten Rechten ausführen" und eine Portweiterleitung 9091 -> 8081 konfiguriere, startet ioBroker normal und die Weboberfläche ist über Port 9091 erreichbar. Anschließend kann ich sowohl zwave (dauert recht lange) als auch homekit installieren. Homekit wird auch grün, zwave ja nicht, weil ich ja keinen Stick dran habe. Auswählen könnte ich die verschiedenen Usb Ports aber.
An dem Punkt ist in Sache testen der Funktion bei mir leider Schluss.

Was deinen aktuellen Fehler bei der Installation des Zwave angeht, könntest du es nochmal so versuchen:

Code: Alles auswählen

npm install iobroker.zwave --unsafe-perm  --production
Manchmal hilft das...

Beim homekit könnte noch ein Port fehlen... Eventuell braucht es da noch ein Forwarding für den avahi?

Im Falle des zwave Adapters und der Netztwerkproblematik im Docker habe ich mich auch schon bei den Entwicklern zu Wort gemeldet. Leider lässt sich die Installationsroutine nicht so ohne Weiteres anpassen. Wenn ich Zeit finde, werde ich mal den Adapter forken und versuchen eine Docker-taugliche Version zu zaubern...

MfG,
Andre

PS: Vielleicht wäre es ja für dich denkbar für die problematischen Adapter mit einem Satelliten zu arbeiten (Stichwort Multihost). Ich habe zum Beispiel für alles was Hardware braucht (bei mir sind das Bluetooth Scanner und rflink) einen separaten Host laufen. Ist bei mir ein Cubietruck, könnte aber auch ein raspberry pi sein.
Grund: Ich wollte keine USB-Devices an der DS und (da meine DS nicht zentral steht) eine optimale Sende und Empfangsposition für Bluetooth und rflink.

Gesendet von meinem Smartphone mit Tapatalk
Homematic - Synology DiskStation (DSM6, ioBroker, Docker, Survelliance Station uvm.) - Intel TV Stick (Win10) + ELO Touch Display - Amazon Echo - Denon AVR - Odroid C2 (LibreELEC) - MiLight LED-System - Cubietruck (Armbian) Multihost-Client + RFlink

Telefisch
professional
Beiträge: 135
Registriert: 20.02.2017, 09:10

Re: [HowTo][Anleitung] Installation ioBroker in Docker auf Synology DiskStation

Beitrag von Telefisch » 28.12.2017, 09:07

Guten Morgen Andre,
erstmal riesen Dankeschön für Deine Hilfe.
Leider funktioniert die ZWave Installation noch immer nicht.

Ich hatte gehofft, dass Du mit den Meldungen was anfangen kannst.
Die Installation des ZWave läuft bei Dir ja offensichtlich auch durch, also habe ich anscheinend (wiedermal) ne Ausnahmesituation. Schade ist das Ganze, weil es vor dem letzten Update (bis auf ZWave) monatelang lief.
Nunja, was auch immer Docker oder Synology geändert haben, wir werden es nicht beeinflussen.

Ich habe schon in Erwägung gezogen die Synology gänzlich vom iobroker zu befreien und auf eine eigene Plattform, nur für den Broker umzusteigen.
Mit den RPIs habe ich allerdings nur schlechte Erfahrungen. Hatte da ne Homebridge installiert die immer stabil lief, bis man mal wieder nach Wochen ne neue Karte installieren durfte. Das ist alles nur so halbgar.
Womit betreibst Du den Cubitruck? mit Festplatte oder SD-Karte?
Ich hatte auch schon nen NUC in Erwägung gezogen, bin mir nur noch nicht sicher welche Leistungsklasse da Sinnvoll ist.

Gruß Carsten
Synology DS916+ (Docker), 2x Echo, 2x Dot, 2x Show

Benutzeravatar
andre
professional
Beiträge: 374
Registriert: 01.12.2015, 21:08
Wohnort: Winsen (Luhe)
Kontaktdaten:

Re: RE: Re: [HowTo][Anleitung] Installation ioBroker in Docker auf Synology DiskStation

Beitrag von andre » 30.12.2017, 08:45

Telefisch hat geschrieben:Womit betreibst Du den Cubitruck? mit Festplatte oder SD-Karte?
Ich hatte auch schon nen NUC in Erwägung gezogen, bin mir nur noch nicht sicher welche Leistungsklasse da Sinnvoll ist.
Ich habe im Cubie eine SSD Festplatte drin. Die SD steckt nurnoch drin damit das Ding von Festplatte booten kann. Läuft jetzt sein nem Jahr ohne Probleme, sind aber auch nur 5 Adapter drauf installiert.
Intel NUC hatte ich auch schon mal auf dem Einkaufszettel. Allerdings würde ich da einen recht leistungsfähigen nehmen um genug Leistung für ein paar virtuelle Maschinen zu haben. :)

MfG,
André



Gesendet von meinem Smartphone mit Tapatalk
Homematic - Synology DiskStation (DSM6, ioBroker, Docker, Survelliance Station uvm.) - Intel TV Stick (Win10) + ELO Touch Display - Amazon Echo - Denon AVR - Odroid C2 (LibreELEC) - MiLight LED-System - Cubietruck (Armbian) Multihost-Client + RFlink

Benutzeravatar
Homoran
guru
Beiträge: 12335
Registriert: 08.08.2014, 16:50

Re: [HowTo][Anleitung] Installation ioBroker in Docker auf Synology DiskStation

Beitrag von Homoran » 30.12.2017, 10:13

andre hat geschrieben:Allerdings würde ich da einen recht leistungsfähigen nehmen um genug Leistung für ein paar virtuelle Maschinen zu haben.
Wie man hier sieht ist die Nutzung in virtuellen maschinen nicht immer ganz einfach. Ich habe eine Installation auf einem NUC5PPYH laufen, selbst der ist für iobroker allein völlig unterfordert.
andre hat geschrieben:Ich habe im Cubie eine SSD Festplatte drin.
Ich hatte da seit Jahren eine 500gb hdd drin, die natürlich nicht für 5 Jahre 24/7 ausgelegt war und irgendwann mit Lagerschaden ausgefallen war. Jetzt ist auch eine SSD drin. Der cubie ist mit seinem DualCore natürlich nicht mit einem Nuc zu vergleichen. Bei mir läuft noch ein MySQL server drauf.
Screenshot_20171230-101247.jpg
Gruß Rainer

Der abgetrennte Teil zum Thema Virtualisierung - und evtl. Probleme dazu befindet sich jetzt hier:
http://forum.iobroker.net/viewtopic.php?f=34&t=10159
kein Support per PN!
Fragen im Forum stellen - es gibt fast nichts, was nicht auch für andere interessant ist.

Antworten