(Erledigt) Fehlerhafte Installationsanleitung ??

Fragen zur Installation von ioBroker auf unterschiedlichen Plattformen.
Antworten
Kyocera007
starter
Beiträge: 44
Registriert: 15.02.2018, 13:14
Wohnort: Dierdorf

(Erledigt) Fehlerhafte Installationsanleitung ??

Beitrag von Kyocera007 » 17.02.2018, 10:59

Hallo und guten morgen,
Ich installiere jetzt zum vierten mal ioBrocker. (Ich geb nicht auf :D )
Mein Raspi ist mit dem aktuellen Raspi-Stretch installiert und upgedatet.
Meine S.USV am Raspi ist installiert.
Jetzt geht es an die Installation von ioBrocker
Da fällt mir in der Anleitung eine auf das da was fehlen könnte.
http://www.iobroker.net/docu/?page_id=5106&lang=de

In folgendem Abschnitt:

Code: Alles auswählen

Installation Node.js
Diese Anleitung bezieht sich auf nodejs 6.x

Die Nutzung von Nodejs 8.x wäre ebenfalls möglich, jedoch muss das dort mitgelieferte npm 5.x unbedingt auf v4.x downgegradet werden mit

sudo npm install -g npm@4

npm 5.x enthält noch einen Bug, der bei ioBroker zu massiven Problemen führt.
Da fehlt doch der Installationsbefehl von nodejs 6.x,
sudo npm install -g npm@4 bezieht sich doch auf das Upgrade von npm5.x

oder täusche ich mich da ???

Gruß Werner
Zuletzt geändert von Kyocera007 am 17.02.2018, 12:37, insgesamt 1-mal geändert.
Auch wenn man Älter wird, kann man besser werden :D

Benutzeravatar
eric2905
guru
Beiträge: 3293
Registriert: 23.03.2015, 18:41
Wohnort: Wuppertal

Re: Fehlerhafte Installationsanleitung ??

Beitrag von eric2905 » 17.02.2018, 11:04

Moin,

Du täuscht Dich.

Der zitierte Absatz ist für diejenigen, die bereits Node installiert haben und dabei ein zu hohe Version haben (mit npm 5).

Schau doch mal unter Punkt 5 der Anleitung.
Ich lese da die Installation von Node 6.

Gruß,
Eric


Von unterwegs getippert
-----------------------------------------------------------------------------------------------
Roses are red, violets are blue,
if I listen to heavy metal, my neighbours do too

Kyocera007
starter
Beiträge: 44
Registriert: 15.02.2018, 13:14
Wohnort: Dierdorf

Re: Fehlerhafte Installationsanleitung ??

Beitrag von Kyocera007 » 17.02.2018, 11:10

moin Eric,
ich fange oben an zu Installieren, das heißt doch dann der Punkt 5 sollte auch oben stehen.
oder ???

Wie kann ich Punkt 2 ausführen wenn ich Punkt 5 noch nicht gemacht habe ?? ;)

Gruß Werner
Zuletzt geändert von Kyocera007 am 17.02.2018, 11:23, insgesamt 2-mal geändert.
Auch wenn man Älter wird, kann man besser werden :D

Kyocera007
starter
Beiträge: 44
Registriert: 15.02.2018, 13:14
Wohnort: Dierdorf

Re: Fehlerhafte Installationsanleitung ??

Beitrag von Kyocera007 » 17.02.2018, 11:16

Die Installationsanleitung bezieht sich wie in der Anleitung oben Beschrieben auf eine Neuinstallation auf dem Raspi.
Wie kann dann schon node installiert sein ??
Verstehe mich nicht falsch, ich versuche nur gerade als Anfänger eine Installation mit einem frischen Raspi durchzuführen.
Ich denke andere neue User werden evtl. auch darüber stolpern oder auch nicht und arbeiten die Installation von oben ab.
Aber als aller erstes müsste ich ja jetzt mit punkt 5 anfangen

Gruß Werner
Auch wenn man Älter wird, kann man besser werden :D

Benutzeravatar
eric2905
guru
Beiträge: 3293
Registriert: 23.03.2015, 18:41
Wohnort: Wuppertal

Re: Fehlerhafte Installationsanleitung ??

Beitrag von eric2905 » 17.02.2018, 11:35

Ok, dann versuchen wir es mal bildlich und bunt :)

Bild

Der grün markierte Teil ist die Anleitung an sich und der rot markierte Bereich der eingeschobene Teil für diejenigen, die schon Node 8 (mit npm 5) installiert haben.

So besser verständlich?

Gruß,
Eric


Von unterwegs getippert
-----------------------------------------------------------------------------------------------
Roses are red, violets are blue,
if I listen to heavy metal, my neighbours do too

Kyocera007
starter
Beiträge: 44
Registriert: 15.02.2018, 13:14
Wohnort: Dierdorf

Re: Fehlerhafte Installationsanleitung ??

Beitrag von Kyocera007 » 17.02.2018, 11:45

Sorry, der nächste Punkt den ich nicht ganz verstehe ist.

Code: Alles auswählen

Punkt 7. als Root über Putty anmelden
dann

Code: Alles auswählen

Installation ioBroker
ioBroker installieren
sudo mkdir /opt/iobroker
sudo chmod 777 /opt/iobroker
cd /opt/iobroker
sudo npm install iobroker --unsafe-perm
Ich bin als root über Putty eingeloggt.
Dann benutze ich trotzdem "sudo" Befehle ??

Die Anleitung verwirrt mich
Ich möchte versuchen, ein sauberes ioBroker zu installieren, nach Anleitung der Entwickler.

Gruß Werner
Auch wenn man Älter wird, kann man besser werden :D

Kyocera007
starter
Beiträge: 44
Registriert: 15.02.2018, 13:14
Wohnort: Dierdorf

Re: Fehlerhafte Installationsanleitung ??

Beitrag von Kyocera007 » 17.02.2018, 11:51

Eric es geht nicht um bildlich und bunt

Lies meinen Text
Es geht darum einen möglichen Fehler in der Installationsanleitung für Neulinge, meinerseits aufzuzeigen.

Es ist ganz oben beschrieben wie ein Raspberry mit einem neun Betriebssystem zu installieren ist und dann geht es mit der Installation von "node" weiter.

Wie kann dann bei einem neu installierten Raspi schon eine "nodeJs." installiert sein.

Gruß Werner
Auch wenn man Älter wird, kann man besser werden :D

Benutzeravatar
eric2905
guru
Beiträge: 3293
Registriert: 23.03.2015, 18:41
Wohnort: Wuppertal

Re: Fehlerhafte Installationsanleitung ??

Beitrag von eric2905 » 17.02.2018, 12:01

Hallo Werner,
Kyocera007 hat geschrieben:Lies meinen Text
lies bitte die Anleitung inkl. der Überschrift.

Diese lautet „Linux Schnellstart (auch für Raspberry Pi)“.
Die Anleitung gilt also auch für Nicht-Raspi-Linux-Installationen und da kann durchaus auch mal Node 8 dabei sein.

Gruß,
Eric


Von unterwegs getippert
-----------------------------------------------------------------------------------------------
Roses are red, violets are blue,
if I listen to heavy metal, my neighbours do too

Benutzeravatar
Homoran
guru
Beiträge: 12335
Registriert: 08.08.2014, 16:50

Re: Fehlerhafte Installationsanleitung ??

Beitrag von Homoran » 17.02.2018, 12:03

Jetzt mische ich mich mal ein!

Dieser gesamte Text:
Installation Node.js
Diese Anleitung bezieht sich auf nodejs 6.x

Die Nutzung von Nodejs 8.x wäre ebenfalls möglich, jedoch muss das dort mitgelieferte npm 5.x unbedingt auf v4.x downgegradet werden mit

sudo npm install -g npm@4

npm 5.x enthält noch einen Bug, der bei ioBroker zu massiven Problemen führt.
Ist die Einleitung, dass der gesamte folgende Teil zu einer Installation von nodejs6 führt.
Jeder der unbedingt etwas höheres installieren will soll daher diese Hinweise beachten.

Ansonsten ist der folgende Teil einfach abzuarbeiten und fürhrt zu nodejs 6.x und npm 3.x, mit dem alles einwandfrei läuft.


Daher kann ich die Aussagen:
Kyocera007 hat geschrieben:Wie kann ich Punkt 2 ausführen wenn ich Punkt 5 noch nicht gemacht habe ??
nicht nachvollziehen.
Die Einleitung mit dem Warnhinweis hat keine Nummer.


Gruß
Rainer
kein Support per PN!
Fragen im Forum stellen - es gibt fast nichts, was nicht auch für andere interessant ist.

Kyocera007
starter
Beiträge: 44
Registriert: 15.02.2018, 13:14
Wohnort: Dierdorf

Re: Fehlerhafte Installationsanleitung ??

Beitrag von Kyocera007 » 17.02.2018, 12:15

Ich kann nur sagen das diese Anleitung für einen Anfänger verwirrend ist.
Als Experte ist das natürlich völlig klar ;)

Was aber ist mit dem "sudo" in meinem Post 6 ??
Durchführen mit oder ohne "sudo" als root-User

Gruß Werner
Auch wenn man Älter wird, kann man besser werden :D

Benutzeravatar
Homoran
guru
Beiträge: 12335
Registriert: 08.08.2014, 16:50

Re: Fehlerhafte Installationsanleitung ??

Beitrag von Homoran » 17.02.2018, 12:20

Es gibt immer noch User, die unbedingt als User Pi arbeiten wollen. (Was in gewissem Rahmen auch geht)
Diese beschweren sich dann, dass die Anleitung falsch ist, weil kein sudo davor steht.

Ein zusätzliches sudo stört dagegen bei einem Zugriff als root nicht.
Kyocera007 hat geschrieben:Ich kann nur sagen das diese Anleitung für einen Anfänger verwirrend ist.
so besser?
http://www.iobroker.net/docu/?page_id=5106&lang=de


Gruß
Rainer
kein Support per PN!
Fragen im Forum stellen - es gibt fast nichts, was nicht auch für andere interessant ist.

Benutzeravatar
eric2905
guru
Beiträge: 3293
Registriert: 23.03.2015, 18:41
Wohnort: Wuppertal

Re: Fehlerhafte Installationsanleitung ??

Beitrag von eric2905 » 17.02.2018, 12:25

Ich verstehe nicht wirklich, was da nicht verständlich ist.

Wenn ich kein Node ≠ 6 installiert habe, überspringe ich den Warnhinweise.
Wenn ich einen Raspi habe, steige ich bei dem Punkt ein.
Wenn ich keinen Raspi habe, überspringe ich den Teil (warum sollte ich Raspian auf einem i386 installieren) und starte mit der Installation von Node 6 (mit npm 3)

Danach kommt dann die ioBroker-Installation.

Wenn Dich das sudo stört, lass es weg - es tut nicht weh. Es ist zur Sicherheit aufgeführt, da es immer wieder User gibt, die sich nicht als root anmelden.

Gruß,
Eric



Von unterwegs getippert
-----------------------------------------------------------------------------------------------
Roses are red, violets are blue,
if I listen to heavy metal, my neighbours do too

Kyocera007
starter
Beiträge: 44
Registriert: 15.02.2018, 13:14
Wohnort: Dierdorf

(Erledigt)Re: Fehlerhafte Installationsanleitung ??

Beitrag von Kyocera007 » 17.02.2018, 12:36

ok, ich mache dann mal weiter mit meiner Installation

Danke euch beiden und ein schönes Wochenende, bis zu meinen nächsten Fragen

Gruß Werner

PS: 7. sagt ganz klar als "als Root über Putty anmelden"
Ich weiß es ist schwierig für jeden eine klare verständliche Installationsanleitung zu schreiben ;)
Auch wenn man Älter wird, kann man besser werden :D

Antworten