NEWS

Zigbee CC2531 funktioniert nicht mehr


  • Hallo, habe eine CC2531 Adapter der aufgehort hat zu funktionieren...Vielleicht hat jemand einen schnellen Tipp?
    Installation Raspi 3, Zigbee Adapter 1.4.3.
    ls -la /dev/serial/by-id bringt:

    lrwxrwxrwx 1 root root 13 Feb 11 21:16 usb-Texas_Instruments_TI_CC2531_USB_CDC___0X00124B0018E208A1-if00 -> ../../ttyACM0
    

    Log sagt folgendes:

    
    zigbee.0	2021-02-11 21:31:41.040	error	at /opt/iobroker/node_modules/@serialport/stream/lib/index.js:242:12
    zigbee.0	2021-02-11 21:31:41.040	error	at SerialPort._error (/opt/iobroker/node_modules/@serialport/stream/lib/index.js:198:14)
    zigbee.0	2021-02-11 21:31:41.040	error	at SerialPort.<anonymous> (/opt/iobroker/node_modules/iobroker.zigbee/node_modules/zigbee-herdsman/dist/adapter/z-stack/znp/znp.js:134:49)
    zigbee.0	2021-02-11 21:31:41.040	error	at __awaiter (/opt/iobroker/node_modules/iobroker.zigbee/node_modules/zigbee-herdsman/dist/adapter/z-stack/znp/znp.js:23:12)
    zigbee.0	2021-02-11 21:31:41.040	error	at new Promise (<anonymous>)
    zigbee.0	2021-02-11 21:31:41.040	error	at /opt/iobroker/node_modules/iobroker.zigbee/node_modules/zigbee-herdsman/dist/adapter/z-stack/znp/znp.js:27:71
    zigbee.0	2021-02-11 21:31:41.040	error	at Generator.next (<anonymous>)
    zigbee.0	2021-02-11 21:31:41.040	error	at Znp.<anonymous> (/opt/iobroker/node_modules/iobroker.zigbee/node_modules/zigbee-herdsman/dist/adapter/z-stack/znp/znp.js:136:32)
    zigbee.0	2021-02-11 21:31:41.040	error	(5766) Error: Error while opening serialport 'Error: Error Resource temporarily unavailable Cannot lock port'
    zigbee.0	2021-02-11 21:31:41.037	error	(5766) Failed to start Zigbee
    zigbee.0	2021-02-11 21:31:35.747	info	(5766) Installed Version: https://github.com/ioBroker/ioBroker.zigbee/commit/master
    zigbee.0	2021-02-11 21:31:35.723	info	(5766) Starting Zigbee npm ...
    zigbee.0	2021-02-11 21:31:35.721	info	(5766) Try to reconnect. 1 attempts left
    zigbee.0	2021-02-11 21:31:25.719	error	at processTimers (internal/timers.js:497:7)
    zigbee.0	2021-02-11 21:31:25.719	error	at listOnTimeout (internal/timers.js:554:17)
    zigbee.0	2021-02-11 21:31:25.719	error	at Timeout._onTimeout (/opt/iobroker/node_modules/iobroker.zigbee/node_modules/zigbee-herdsman/dist/utils/waitress.js:46:35)
    zigbee.0	2021-02-11 21:31:25.719	error	(5766) Error: AREQ - ZDO - activeEpRsp after 10000ms
    zigbee.0	2021-02-11 21:31:25.716	error	(5766) Failed to start Zigbee
    zigbee.0	2021-02-11 21:31:07.800	info	(5766) Installed Version: https://github.com/ioBroker/ioBroker.zigbee/commit/master
    zigbee.0	2021-02-11 21:31:07.577	info	(5766) Starting Zigbee npm ...
    zigbee.0	2021-02-11 21:31:07.437	info	(5766) starting. Version 1.4.3 in /opt/iobroker/node_modules/iobroker.zigbee, node: v12.20.2, js-controller: 3.1.6
    host.ioBroker-Worms	2021-02-11 21:31:04.591	info	Do not restart adapter system.adapter.zigbee.0 because desired by instance
    
  • Developer Most Active

    @zgadgeter sagte in Zigbee CC2531 funktioniert nicht mehr:

    Error: Error while opening serialport 'Error: Error Resource temporarily unavailable Cannot lock port'

    da steht es doch.. und du bist nit der erste mit dem Problem.. schaue doch mal bitte im Forum nach..


  • @arteck So, jetzt habe ich wirklich alle post durchgelesen, einiges probiert was da drin steht, aber keine Loessung. Ich bin mttlerweile soweit das ich nicht weiss ob der Stick kaputt ist, oder sonst was. Ich habe auch ein backup eingespielt von wo ich genau weis der Stick hat funktionert, aber auch nichts. Ich weiss jetzt nicht mehr weiter....

  • Developer Most Active

    @zgadgeter hast mal

    zigbee Adapter anhalten
    stick abziehen
    30 sekunden warten
    stick anstecken
    zigbee adapter starten

    probiert.. wobei bei deiner aktion jetzt kann sein das da was verloren gegangen ist


  • @arteck ja, das habe ich schon einige male probiert. Keine Abänderung, leider.

  • Most Active

    @zgadgeter
    Wie sieht denn das LogFile aktuell aus, wenn du den Adapter neustartest?


  • @thomas-braun said in Zigbee CC2531 funktioniert nicht mehr:

    @zgadgeter
    Wie sieht denn das LogFile aktuell aus, wenn du den Adapter neustartest?

    
    zigbee.0	2021-02-15 21:29:28.799	error	(24096) Error: Error while opening serialport 'Error: Error Resource temporarily unavailable Cannot lock port' at Znp.<anonymous> (/opt/iobroker/node_modules/iobroker.zigbee/node_modules/zigbee-he
    zigbee.0	2021-02-15 21:29:28.795	error	(24096) Failed to start Zigbee
    zigbee.0	2021-02-15 21:29:23.532	info	(24096) Installed Version: iobroker.zigbee@1.3.1
    zigbee.0	2021-02-15 21:29:23.503	info	(24096) Starting Zigbee npm ...
    zigbee.0	2021-02-15 21:29:23.500	info	(24096) Try to reconnect. 1 attempts left
    zigbee.0	2021-02-15 21:29:13.497	error	(24096) Error: Failed to connect to the adapter (Error: SRSP - SYS - ping after 6000ms) at ZStackAdapter.<anonymous> (/opt/iobroker/node_modules/iobroker.zigbee/node_modules/zigbee-herdsman/dist/a
    zigbee.0	2021-02-15 21:29:13.491	error	(24096) Failed to start Zigbee
    zigbee.0	2021-02-15 21:28:33.640	info	(24096) Installed Version: iobroker.zigbee@1.3.1
    zigbee.0	2021-02-15 21:28:33.382	info	(24096) Starting Zigbee npm ...
    zigbee.0	2021-02-15 21:28:33.235	info	(24096) starting. Version 1.4.3 in /opt/iobroker/node_modules/iobroker.zigbee, node: v12.20.2, js-controller: 3.1.6
    host.ioBroker-Worms	2021-02-15 21:28:30.153	info	instance system.adapter.zigbee.0 started with pid 24096
    host.ioBroker-Worms	2021-02-15 21:28:21.219	info	Do not restart adapter system.adapter.zigbee.0 because desired by instance
    host.ioBroker-Worms	2021-02-15 21:28:21.216	error	instance system.adapter.zigbee.0 terminated by request of the instance itself and will not be restarted, before user restarts it.
    host.ioBroker-Worms	2021-02-15 21:28:00.118	info	Restart adapter system.adapter.zigbee.0 because enabled
    host.ioBroker-Worms	2021-02-15 21:28:00.117	error	instance system.adapter.zigbee.0 terminated with code 7 (ADAPTER_ALREADY_RUNNING)
    zigbee.0	2021-02-15 21:27:59.582	warn	(23949) Terminated (ADAPTER_ALREADY_RUNNING): Without reason
    zigbee.0	2021-02-15 21:27:59.578	error	(23949) zigbee.0 already running
    host.ioBroker-Worms	2021-02-15 21:27:56.777	info	instance system.adapter.zigbee.0 started with pid 23949
    
  • Most Active

    @zgadgeter Bitte das LogFile aus /opt/iobroker/log/iobroker.current.log nehmen. Deins ist abgeschnitten.

  • Developer Most Active

    heute ist wieder ein Tag.....

    @zgadgeter starte mal die kiste neu ..


  • @thomas-braun
    Hallo, also ich wusste nicht das es sowas gibt...

    2021-02-15 21:27:56.731  - info: host.ioBroker-Worms "system.adapter.zigbee.0" enabled
    2021-02-15 21:27:56.777  - info: host.ioBroker-Worms instance system.adapter.zigbee.0 started with pid 23949
    2021-02-15 21:27:59.578  - error: zigbee.0 (23949) zigbee.0 already running
    2021-02-15 21:27:59.582  - warn: zigbee.0 (23949) Terminated (ADAPTER_ALREADY_RUNNING): Without reason
    2021-02-15 21:28:00.117  - error: host.ioBroker-Worms instance system.adapter.zigbee.0 terminated with code 7 (ADAPTER_ALREADY_RUNNING)
    2021-02-15 21:28:00.118  - info: host.ioBroker-Worms Restart adapter system.adapter.zigbee.0 because enabled
    2021-02-15 21:28:21.216  - error: host.ioBroker-Worms instance system.adapter.zigbee.0 terminated by request of the instance itself and will not be restarted, before user restarts it.
    2021-02-15 21:28:21.219  - info: host.ioBroker-Worms Do not restart adapter system.adapter.zigbee.0 because desired by instance
    2021-02-15 21:28:30.153  - info: host.ioBroker-Worms instance system.adapter.zigbee.0 started with pid 24096
    2021-02-15 21:28:33.235  - info: zigbee.0 (24096) starting. Version 1.4.3 in /opt/iobroker/node_modules/iobroker.zigbee, node: v12.20.2, js-controller: 3.1.6
    2021-02-15 21:28:33.382  - info: zigbee.0 (24096) Starting Zigbee  npm ...
    2021-02-15 21:28:33.640  - info: zigbee.0 (24096) Installed Version: iobroker.zigbee@1.3.1
    2021-02-15 21:29:13.491  - error: zigbee.0 (24096) Failed to start Zigbee
    2021-02-15 21:29:13.497  - error: zigbee.0 (24096) Error: Failed to connect to the adapter (Error: SRSP - SYS - ping after 6000ms)
        at ZStackAdapter.<anonymous> (/opt/iobroker/node_modules/iobroker.zigbee/node_modules/zigbee-herdsman/dist/adapter/z-stack/adapter/zStackAdapter.js:94:31)
        at Generator.throw (<anonymous>)
        at rejected (/opt/iobroker/node_modules/iobroker.zigbee/node_modules/zigbee-herdsman/dist/adapter/z-stack/adapter/zStackAdapter.js:25:65)
    2021-02-15 21:29:23.500  - info: zigbee.0 (24096) Try to reconnect. 1 attempts left
    2021-02-15 21:29:23.503  - info: zigbee.0 (24096) Starting Zigbee  npm ...
    2021-02-15 21:29:23.532  - info: zigbee.0 (24096) Installed Version: iobroker.zigbee@1.3.1
    2021-02-15 21:29:28.795  - error: zigbee.0 (24096) Failed to start Zigbee
    2021-02-15 21:29:28.799  - error: zigbee.0 (24096) Error: Error while opening serialport 'Error: Error Resource temporarily unavailable Cannot lock port'
        at Znp.<anonymous> (/opt/iobroker/node_modules/iobroker.zigbee/node_modules/zigbee-herdsman/dist/adapter/z-stack/znp/znp.js:136:32)
        at Generator.next (<anonymous>)
        at /opt/iobroker/node_modules/iobroker.zigbee/node_modules/zigbee-herdsman/dist/adapter/z-stack/znp/znp.js:27:71
        at new Promise (<anonymous>)
        at __awaiter (/opt/iobroker/node_modules/iobroker.zigbee/node_modules/zigbee-herdsman/dist/adapter/z-stack/znp/znp.js:23:12)
        at SerialPort.<anonymous> (/opt/iobroker/node_modules/iobroker.zigbee/node_modules/zigbee-herdsman/dist/adapter/z-stack/znp/znp.js:134:49)
        at SerialPort._error (/opt/iobroker/node_modules/@serialport/stream/lib/index.js:198:14)
        at /opt/iobroker/node_modules/@serialport/stream/lib/index.js:242:12
    

  • @arteck said in Zigbee CC2531 funktioniert nicht mehr:

    heute ist wieder ein Tag.....

    @zgadgeter starte mal die kiste neu ..

    gesagt getan


  • @zgadgeter Hat sich bei dir nun was getan?

Suggested Topics

  • 2
  • 4
  • 81
  • 1
  • 9
  • 58
  • 11
  • 28

1.9k
Online

36.8k
Users

42.5k
Topics

588.5k
Posts