NEWS


  • @joergeli hab ich schon verstanden!


  • Die Zeiten sind mir eigentlich egal, grob weis ich beim Slicen (egal welcher Slicer) wie lange es dauert. Oft druckt der Drucker bei mir Nachts oder bis in den nächsten Morgen, daher habe ich dann bei 100% Progress den Drucker nach 5min Nachlaufzeit ausgeschaltet inkl. Pi und Licht.

    Das aktuelle Problem: ioBroker ist so gut wie immer 1% dem Octoprint vorraus.
    Hier ein Beispiel. Das war kein Zufallstreffer!
    octoprint.png

    Der Druck hat also vorher beendet da im iobroker schon 100% erreicht waren, OcotoPrint stand noch bei 99%. Spezielle Plugins um die Zeiten zu korrigieren habe ich nicht installiert (soweit ich weis). Kann aber gerne mal eine Liste ausgeben was installiert ist.

    Werde den Tipp von @joergeli anwenden und die Bett Temperatur als zweiten Faktor dazu nehmen.


  • @BeNeDeLuX
    Ist schon komisch, bei meinem Anycubic ist es genau umgekehrt:
    Der Druckkopf ist meist schon in die "Habe fertig-Position" gefahren und ioBroker ist meist noch bei 99%.
    Andererseits schalte ich den Drucker auch nicht via iobroker automatisch aus, sondern lasse den Octoprint-Raspi manuell per Script runterfahren und dann den Drucker ausschalten.
    Das der Drucker dann u.U. ein/zwei Stunden im Leerlauf vor sich hin träumt, stört mich dabei nicht.

    Aber wie schon gesagt, mit dem zweiten Kriterium "Hotbed-Temp" solltest Du auf der sicheren Seite beim automatischen Runterfahren sein.

    Gruß
    Jörg


  • @joergeli said in Test Adapter OctoPrint 0.0.6:

    lasse den Octoprint-Raspi manuell per Script runterfahren

    wozu? strom weg und gut ists. seit 1,5 jahren 0 probleme.


  • @da_Woody
    .... 1000 Mal berührt, 1000 Mal is nix passiert und dann hat es zooooom gemacht 😊
    Nee, nee, ich lasse den Octoprint-Raspi lieber sauber via Script und SSH mit "shutdown -h now" runterfahren.


  • @joergeli braver bub! 😄
    "shutdown -h now" und am näxten tag geht nix, weil die SD angenippelt ist... 😉 weil sie -h wie husten bekommen hat.🤠


  • @da_Woody
    ... ist ja bei einem Octoprint-Raspi nicht ganz so schlimm, weil er rel. schnell neu aufgesetzt ist.
    Aber der brave Bub hat auch noch ein SD-Image auf seinem NAS liegen. 😁
    Aber lassen wir das, wird OffTopic.


  • @joergeli sagte in Test Adapter OctoPrint 0.0.6:

    Entscheidend sind für mich die Zeiten, die Octoprint ausgibt und da gab es halt Diskrepanzen.

    Das habe ich schon verstanden. Aber ich kann nur anzeigen, was mir die OctoPrint API gibt. Wenn da weiterhin die falschen/normalen Werte aus der Standard-Berechnung geliefert werden, kann ich mir die anderen nicht herzaubern 🙂


  • @haus-automatisierung
    Ist schon klar, deshalb hatte ich ja geschrieben, daß es nicht am Adapter liegt, bzw. lag.
    Ich hätte wohl besser einen eigenen Thread für das Thema aufmachen sollen.

    Sorry, wenn ich Verwirrung gestiftet haben sollte.
    Jörg


  • Jetzt gibt es zu dem Adapter auch noch ein Video auf YouTube:

    https://www.youtube.com/watch?v=NiTXB4lZv0A


  • @haus-automatisierung Ich bekomme jede Minute (aktualisierungsintervall 60 sec.) folgende Meldung im Log:
    415d7acc-081f-49d8-bf18-66d3c285a44e-grafik.png

    Dass eine Meldung kommt, weil die Octoprint-VM nicht läuft ist schon klar, aber warum "timeout of 2000ms exceeded"?


  • @guergen is normal. nur eine info, zum vergessen.

  • Starter

    @haus-automatisierung said in Test Adapter OctoPrint 1.0.1:

    Jetzt gibt es zu dem Adapter auch noch ein Video auf YouTube:

    https://www.youtube.com/watch?v=NiTXB4lZv0A

    Bin auf das Video gestoßen weil ich auf der Suche nach einer Lösung für mein Problem mit dem Adapter bin. Der Adapter wird bei mir immer "gelb angezeigt. Hab mir jetzt nochmal das Video angeschaut und den Port von 80 auf 5000 gesetzt. Hatte gehofft das bringt was. Leider nicht. Grundsätzlich werden die Temperaturen usw. unter Objekte angezeigt weshalb mich die gelbe Ample noch nicht mal stören würde. Allerdings wird unter "printer_status" folgendes angezeigt "API not connected". Ich brauch den state leider für ein Logik um zu prüfen ob octoprint hochgefahren ist und bereit.

    Das ist der Log zu octoprint:

    octoprint.0	2020-12-24 15:19:05.543	info	(28285) connect ECONNREFUSED 192.168.17.7:5000
    octoprint.0	2020-12-24 15:18:35.522	info	(28285) connect ECONNREFUSED 192.168.17.7:5000
    octoprint.0	2020-12-24 15:18:05.501	info	(28285) connect ECONNREFUSED 192.168.17.7:5000
    octoprint.0	2020-12-24 15:17:35.482	info	(28285) connect ECONNREFUSED 192.168.17.7:5000
    octoprint.0	2020-12-24 15:17:05.676	info	(28285) connect ECONNREFUSED 192.168.17.7:5000
    octoprint.0	2020-12-24 15:16:35.655	info	(28285) connect ECONNREFUSED 192.168.17.7:5000
    octoprint.0	2020-12-24 15:16:05.629	info	(28285) connect ECONNREFUSED 192.168.17.7:5000
    octoprint.0	2020-12-24 15:15:35.605	info	(28285) connect ECONNREFUSED 192.168.17.7:5000
    octoprint.0	2020-12-24 15:15:05.583	info	(28285) connect ECONNREFUSED 192.168.17.7:5000
    octoprint.0	2020-12-24 15:14:35.557	info	(28285) connect ECONNREFUSED 192.168.17.7:5000
    octoprint.0	2020-12-24 15:14:05.533	info	(28285) connect ECONNREFUSED 192.168.17.7:5000
    octoprint.0	2020-12-24 15:13:35.511	info	(28285) connect ECONNREFUSED 192.168.17.7:5000
    octoprint.0	2020-12-24 15:13:05.486	info	(28285) connect ECONNREFUSED 192.168.17.7:5000
    octoprint.0	2020-12-24 15:12:35.462	info	(28285) OctoPrint API not connected
    octoprint.0	2020-12-24 15:12:35.455	info	(28285) connect ECONNREFUSED 192.168.17.7:5000
    octoprint.0	2020-12-24 15:12:35.167	info	(28285) starting. Version 1.0.3 in /opt/iobroker/node_modules/iobroker.octoprint, node: v10.17.0, js-controller: 3.1.6
    

    Gibt es ein Lösung für das Problem? Danke für eure Hilfe

  • Starter

    @DasLukas Jetzt mit dem Port 5000 werden nicht mal mehr die aktuellen Temperaturen von Hotbed und Hotend übertragen. Wenn ich zurück auf Port 80 stelle bekomm ich wieder Updates und folgenden Log:

    octoprint.0	2020-12-24 15:41:43.146	error	(29628) Cannot read property 'toFixed' of null
    octoprint.0	2020-12-24 15:41:13.080	error	(29628) Cannot read property 'toFixed' of null
    octoprint.0	2020-12-24 15:40:43.055	error	(29628) Cannot read property 'toFixed' of null
    octoprint.0	2020-12-24 15:40:13.078	error	(29628) Cannot read property 'toFixed' of null
    octoprint.0	2020-12-24 15:40:12.372	info	(29628) starting. Version 1.0.3 in /opt/iobroker/node_modules/iobroker.octoprint, node: v10.17.0, js-controller: 3.1.6
    

  • @DasLukas ne, port 80 stimmt schon. der adapter ist gelb, wenn der drucker abgedreht ist, sobald er aufgedreht ist, wird der adapter grün.
    hast du den API-key eingetragen und stimmt er?

  • Starter

    @da_Woody API Key jetzt nochmal neu erzeugt. Kopiert und in iobroker eingefügt. Gleiches Ergebnis.

    octoprint.0	2020-12-24 16:22:49.234	error	(523) Cannot read property 'toFixed' of null
    octoprint.0	2020-12-24 16:22:19.110	error	(523) Cannot read property 'toFixed' of null
    octoprint.0	2020-12-24 16:21:49.092	error	(523) Cannot read property 'toFixed' of null
    octoprint.0	2020-12-24 16:21:19.019	error	(523) Cannot read property 'toFixed' of null
    octoprint.0	2020-12-24 16:20:49.102	error	(523) Cannot read property 'toFixed' of null
    octoprint.0	2020-12-24 16:20:48.446	info	(523) starting. Version 1.0.3 in /opt/iobroker/node_modules/iobroker.octoprint, node: v10.17.0, js-controller: 3.1.6
    

    Hier einmal die Infos aus octoprint:

    browser.user_agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/14.0 Safari/605.1.15
    connectivity.connection_check: 8.8.8.8:53
    connectivity.connection_ok: true
    connectivity.enabled: true
    connectivity.online: true
    connectivity.resolution_check: octoprint.org
    connectivity.resolution_ok: true
    env.hardware.cores: 4
    env.hardware.freq: 1200
    env.hardware.ram: 917016576
    env.os.bits: 32
    env.os.id: linux
    env.os.platform: linux
    env.plugins.pi_support.model: Raspberry Pi 3 Model B Rev 1.2
    env.plugins.pi_support.octopi_version: 0.17.0
    env.plugins.pi_support.throttle_state: 0x0
    env.python.pip: 20.2.3
    env.python.version: 3.7.3
    env.python.virtualenv: true
    octoprint.safe_mode: false
    octoprint.version: 1.5.2
    printer.firmware: Klipper
    

  • @DasLukas said in Test Adapter OctoPrint 1.0.1:

    starting. Version 1.0.3 in /opt/iobroker/node_modules/iobroker.octoprint, node: v10.17.0, js-controller: 3.1.6 
    

    sieht bei mir so aus:

     starting. Version 1.0.5 in /opt/iobroker/node_modules/iobroker.octoprint, node: v12.20.0, js-controller: 3.1.6
    

    octoprint aktuell? war ja vor kurzem ein update...

  • Starter

    @da_Woody Okay, node wie hier beschrieben aktualisiert. Dann im iobroker admin nochmal geschaut ob unter Adapter ein update für octoprint bereitsteht. Negativ. octoprint unter Adapter deinstalliert und per GitHub manuell installiert. Die Version 1.0.5 wird dort jetzt auch angezeigt. Großes Problem ist das es keine octoprint Instanz mehr gibt. Die Logs sagen auch nicht. Jemand eine Idee?

    Bildschirmfoto 2020-12-24 um 22.00.11.png

  • Starter

    @DasLukas Selber die Lösung gefunden. Nachdem manuellen installieren über GitHub ist es anscheinend notwendig auch manuell eine Instanz zu erstellen. Bin noch neu beim iobroker.

    Jetzt läuft alles und die API läuft auch. Danke.


  • @DasLukas na siehste, kleines xmas gift... 😉 gern geschehn!
    jup, das ist vielen schon passiert nach einer github install... 😄

Suggested Topics

2.2k
Online

35.2k
Users

41.1k
Topics

566.1k
Posts