NEWS

[gelöst] js-controller 3.0.19 upgrade Fehler - Iobroker tot

  • Starter

    Bei mir geht auch nichts mehr. Raspi Pi4

  • Starter

    @wendy2702 Wie komm ich an das Logfile wenn das System nicht mehr Hochfährt?

  • Developer

    @smart-home. Liegt im iobroker verzeichnis unter logs

    Der Fehler muss durch einen Entwickler behoben werden. Sleber könnt ihr nur versuchen das pcket iobroker.objects-redis zu löschen und dann in version 3.3.2 zu installieren.
    Das sollten nur die unter euch machen die wissen was sie tun, daher keine Anleitung von mir.


  • @Jey-Cee

    Da die Installation nun ja sowieso tot ist, kann ja nicht mehr viel passieren.
    könntest du trotzdem eine "Anleitung" posten? Natürlich auf eigene Gefahr

    kann man eventuell wieder auf 3.0.18 zurück?

  • Starter

    @f0rd42 Bzgl. "Zurück auf 3.0.18": Hab ich schon probiert - ändert nichts (zumindest bei mir)

  • Starter

    2020-04-28 10:52:00.793 - error: history.0 (19709) uncaught exception: allback is not defined
    2020-04-28 10:52:00.802 - error: history.0 (19709) ReferenceError: allback is not defined
    at _0x411ccb._applyViewFunc (/opt/iobroker/node_modules/iobroker.objects-redis/index.js:1:115051)
    at process._tickCallback (internal/process/next_tick.js:68:7)
    2020-04-28 10:52:01.172 - info: host.athomepi4 instance system.adapter.mercedesme.0 started with pid 19728
    2020-04-28 10:52:01.181 - info: history.0 (19709) terminating
    2020-04-28 10:52:01.183 - info: history.0 (19709) Terminated (NO_ERROR): Without reason
    2020-04-28 10:52:01.709 - error: host.athomepi4 Caught by controller[0]: This error originated either by t
    hrowing inside of an async function without a catch block, or by rejecting a promise which was not handled with .ca
    tch(). The promise rejected with the reason:
    2020-04-28 10:52:01.710 - error: host.athomepi4 Caught by controller[0]: ReferenceError: allback is not de
    fined
    2020-04-28 10:52:01.710 - error: host.athomepi4 Caught by controller[0]: at _0x411ccb._applyViewFunc (
    /opt/iobroker/node_modules/iobroker.objects-redis/index.js:1:115051)
    2020-04-28 10:52:01.710 - error: host.athomepi4 Caught by controller[0]: at process._tickCallback (int
    ernal/process/next_tick.js:68:7)
    2020-04-28 10:52:01.710 - info: host.athomepi4 instance system.adapter.history.0 terminated with code 0 (N
    O_ERROR)
    2020-04-28 10:52:01.711 - info: host.athomepi4 Restart adapter system.adapter.history.0 because enabled


  • Warum steht da im Fehler eigentlich immer "Allback' Anstalt "Callback"?

  • Developer

    @f0rd42 Genau das ist das Problem 🙂


  • @AlCalzone Dann warten wir auf den Entwickler, sollte ja kein "grosses" Problem sein 🙂

  • Starter

    2020-04-28 10:17:27.955 - ^[[32minfo^[[39m: discovery.0 (519) starting. Version 2.3.3 in /opt/iobroker/node_modules/iobroker.discovery, node: v10.16.3, js-controller: 3.0.19
    2020-04-28 10:17:29.936 - ^[[32minfo^[[39m: knx.0 (530) starting. Version 1.0.41 in /opt/iobroker/node_modules/iobroker.knx, node: v10.16.3, js-controller: 3.0.19
    2020-04-28 10:17:29.963 - ^[[33mwarn^[[39m: knx.0 (530) adapter.objects.getObjectView is deprecated, and will be removed in the future. Please use adapter.getObjectView/Async. Report this to Developer!
    2020-04-28 10:17:30.037 - ^[[31merror^[[39m: knx.0 (530) uncaught exception: allback is not defined
    2020-04-28 10:17:30.038 - ^[[31merror^[[39m: knx.0 (530) ReferenceError: allback is not defined
    at _0x411ccb._applyViewFunc (/opt/iobroker/node_modules/iobroker.objects-redis/index.js:1:115051)
    at process._tickCallback (internal/process/next_tick.js:68:7)

    hier mal ein ausschnitt aus meinem Log. Zumindestens steht da "Report this to Developer!"😊


  • Bitte kurz warten ... controller 3.0.20 baut gerade um das zu fixen ... melde mich sobald verfügbar


  • Hallo zusammen,

    da ich das oben beschriebene Problem alleine nicht lösen kann, habe ich mich hier im Forum angemeldet.
    Ich hoffe es kann mir jemand helfen - die Hausautomation läuft leider nicht mehr.
    Nach dem js-controller Upgrade startet das System nicht mehr.

    Folgendes habe ich in der Konsole ausgeführt:

    iobroker stop
    iobroker update
    iobroker upgrade self
    iobroker start
    

    Der js-controller hat jetzt die neue Version.
    iobroker info liefert folgendes Ergebnis:

    (node:32704) UnhandledPromiseRejectionWarning: ReferenceError: allback is not defined
        at _0x411ccb._applyViewFunc (/opt/iobroker/node_modules/iobroker.objects-redis/index.js:1:115051)
        at process._tickCallback (internal/process/next_tick.js:68:7)
    (node:32704) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 1)
    (node:32704) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.
    

    Environment:
    Rpi4
    node 10.17.0
    mpm 6.14.4

    Vielen Dank im Voraus.

    LG Wolfgang


  • 3.0.20 ist auf npm und kommt jetzt bald ins latest. Imzweifel bitte IM ioBroker VERZEICHNIS !!!! per "npm install iobroker.js-controller@3.0.20" installieren

  • Most Active


  • @haselchen Habe den Controller auf 3.0.20 upgedated, läuft.
    Super, danke.
    LG Wolfgang

  • Forum Testing Most Active

    @Schuchty sagte in Problem nach js-controller Upgrade von 3.0.18 auf 3.0.19:

    (node:32704) UnhandledPromiseRejectionWarning: ReferenceError: allback is not defined

    allback

    und genau da lag der Fehler. Es fehlte ein C 😏


  • @apollon77
    Ich hatte das gleiche Problem und habe mitgelesen 🙂
    Nach "npm install iobroker.js-controller@3.0.20" funktioniert bei mir wieder alles.

    Vielen Dank!

  • Starter

    Bei mir funktioniert es leider nicht:

    pi@ioBroker-RasPi4:/opt/iobroker $ npm install iobroker.js-controller@3.0.20
    npm WARN deprecated request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142
    npm WARN deprecated fsevents@1.2.12: fsevents 1 will break on node v14+ and could be using insecure binaries. Upgrade to fsevents 2.
    npm WARN checkPermissions Missing write access to /opt/iobroker/node_modules/chokidar/node_modules/fsevents
    npm WARN checkPermissions Missing write access to /opt/iobroker/node_modules/iobroker.loxone/node_modules/chokidar/node_modules/fsevents
    npm WARN checkPermissions Missing write access to /opt/iobroker/node_modules/chokidar/node_modules/fsevents/node_modules
    npm WARN checkPermissions Missing write access to /opt/iobroker/node_modules/iobroker.loxone/node_modules/chokidar/node_modules/fsevents/node_modules
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@~2.1.2 (node_modules/iobroker.js-controller/node_modules/chokidar/node_modules/fsevents):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"arm"})
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.2.7 (node_modules/chokidar/node_modules/fsevents):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.12: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"arm"})
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.2.7 (node_modules/iobroker.loxone/node_modules/chokidar/node_modules/fsevents):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.12: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"arm"})
    npm WARN enoent ENOENT: no such file or directory, open '/opt/iobroker/node_modules/fsevents/package.json'
    npm WARN enoent ENOENT: no such file or directory, open '/opt/iobroker/node_modules/iobroker.loxone/node_modules/fsevents/package.json'
    npm WARN ws@7.2.1 requires a peer of bufferutil@^4.0.1 but none is installed. You must install peer dependencies yourself.
    npm WARN ws@7.2.1 requires a peer of utf-8-validate@^5.0.2 but none is installed. You must install peer dependencies yourself.

    npm ERR! path /opt/iobroker/node_modules/chokidar/node_modules/fsevents
    npm ERR! code EACCES
    npm ERR! errno -13
    npm ERR! syscall access
    npm ERR! Error: EACCES: permission denied, access '/opt/iobroker/node_modules/chokidar/node_modules/fsevents'
    npm ERR! { [Error: EACCES: permission denied, access '/opt/iobroker/node_modules/chokidar/node_modules/fsevents']
    npm ERR! stack:
    npm ERR! 'Error: EACCES: permission denied, access '/opt/iobroker/node_modules/chokidar/node_modules/fsevents'',
    npm ERR! errno: -13,
    npm ERR! code: 'EACCES',
    npm ERR! syscall: 'access',
    npm ERR! path: '/opt/iobroker/node_modules/chokidar/node_modules/fsevents' }
    npm ERR!
    npm ERR! The operation was rejected by your operating system.
    npm ERR! It is likely you do not have the permissions to access this file as the current user
    npm ERR!
    npm ERR! If you believe this might be a permissions issue, please double-check the
    npm ERR! permissions of the file and its containing directories, or try running
    npm ERR! the command again as root/Administrator (though this is not recommended).

    npm ERR! A complete log of this run can be found in:
    npm ERR! /home/pi/.npm/_logs/2020-04-28T10_11_11_846Z-debug.log
    pi@ioBroker-RasPi4:/opt/iobroker $

    und jetzt hab ich glaube ich noch ein größeres Problem:

    pi@ioBroker-RasPi4:/opt/iobroker $ sudo iobroker update
    internal/modules/cjs/loader.js:638
    throw err;
    ^

    Error: Cannot find module '/opt/iobroker/node_modules/iobroker.js-controller/iob roker.js'
    at Function.Module._resolveFilename (internal/modules/cjs/loader.js:636:15)
    at Function.Module._load (internal/modules/cjs/loader.js:562:25)
    at Function.Module.runMain (internal/modules/cjs/loader.js:831:12)
    at startup (internal/bootstrap/node.js:283:19)
    at bootstrapNodeJSCore (internal/bootstrap/node.js:622:3)

  • Developer Most Active

    @smart-home lass den fixer drüber laufen dann nochma update

  • Starter

    @arteck

    pi@ioBroker-RasPi4:/opt/iobroker $ curl -sL https://iobroker.net/fix.sh | bash -
    library: loaded
    Library version=2020-04-12
    ioBroker is not installed in /opt/iobroker! Cannot fix anything...
    pi@ioBroker-RasPi4:/opt/iobroker $

Suggested Topics

1.7k
Online

35.1k
Users

41.0k
Topics

564.0k
Posts