NEWS


  • @simatec sagte:

    ich kann es gerne noch einmal in der Anleitung als Hinweis aufnehmen

    Unbedingt !!

  • Developer Most Active

    @paul53 erledigt ...

  • Forum Testing Most Active Global Moderator Administrators

    @paul53 sagte in [HowTo] ioBroker Restore unter Linux durchführen:

    Woher weiß ioBroker, welche Adapter zu installieren sind mit welchen Instanzen ?

    Die Konfiguration der Instanzen befinden sich in dem Backup.

    Die dazugehörenden Adapterdateien werden sukzessive in den neuesten Versionen des ausgewählten Repositories installiert.

  • Developer Most Active

    @paul53 sagte in [HowTo] ioBroker Restore unter Linux durchführen:

    @simatec sagte:

    iobroker start
    Auch hier werden nun alle Adapter einzeln von ioBroker über npm neu installiert.

    Wenn die Objekte in einer Redis-DB gespeichert wurden, muss man dann nicht vorher die DB wieder herstellen ?

    Hier noch mal ein Log, in dem zu sehen ist, dass sowohl Objekte als auch states im iobroker backup gesichert werden.

    Dementsprechend sollten hier auch die States und Objekte nach dem restore wieder hergestellt werden und auch dann in die Redis db geschrieben werden.

    backitup.0	2019-12-02 21:13:22.084	debug	(24548) [iobroker/iobroker] host.iobroker-test 2689 objects saved
    backitup.0	2019-12-02 21:13:22.063	debug	(24548) [iobroker/iobroker] host.iobroker-test 2401 states saved
    

    @apollon77
    Eventuell kannst du hier noch etwas zu erklären.
    Aber so wie ich es verstehe, muss hier vor einem Restore des iobroker Backups nicht zwingend die alte Redis DB wiederhergestellt werden.

    Wichtig ist nur, dass der Redis Server läuft, wenn das Backup auf einem System mit Redis erstellt wurde.


  • @simatec korrekt


  • Hallo,
    vielleicht ist es für Mac User Interessant.
    Mein IoBroker läuft auf der aktuellen MacMini Generation.
    Habe mal zum Test IoBroker auf meinen MacBook mit Catalina installiert und mit einen Backup aus dem Backit up Adapter wiederhergestellt. Nach 10min lief alles.
    Also unter MacOS mit Mojave wie auch der aktuellen Version Catalina funktioniert es.
    Vielen Dank dafür.

    Gruß


  • Ich hatte ein Admin-Adapter durchgeführt. Seit dem kann ich über den Browser gar nicht mehr zugreifen (Webseite nicht erreichbar). Heißt das, daß die Iobrokerinstallation zerstört ist? Dann würde ja ein Restore auch nicht helfen. Oder?

  • Forum Testing Most Active Global Moderator Administrators

    @joergfrde sagte in [HowTo] ioBroker Restore unter Linux durchführen:

    Ich hatte ein Admin-Adapter durchgeführt.

    Update nehme ich an 😉

    @joergfrde sagte in [HowTo] ioBroker Restore unter Linux durchführen:

    Heißt das, daß die Iobrokerinstallation zerstört ist?

    nein!

    geh bitte über putty auf den ioBroker-Server und gib ein

    iobroker status
    iobroker list instances
    

    und poste hier das Ergebnis


  • @Homoran Ok, werde ich machen. Aber wahrscheinlich erst am WE.


  • Hallo habe ein ähnliches Problem,

    habe ein zweites System aufgesetzt und wollte ein Backup einspielen. Laut iobroker status läuft das system auch:

    artur@ioBroker2:~$ iobroker status
    iobroker is running on this host.
    
    At least one iobroker host is running.
    
    Objects type: file
    States  type: file
    

    die Instanzen sind auch alle eingerichtet (natürlich nicht gestartet weil ich ja noch das erste System betreibe:

    artur@ioBroker2:~$ iobroker list instances
    + system.adapter.admin.0                 : admin                 -  enabled, port: 8081, bind: 192.168.168.114, run as: admin
      system.adapter.alexa2.0                : alexa2                - disabled
    + system.adapter.backitup.0              : backitup              -  enabled
      system.adapter.cloud.0                 : cloud                 - disabled
      system.adapter.deconz.0                : deconz                - disabled
      system.adapter.discovery.0             : discovery             - disabled
      system.adapter.feiertage.0             : feiertage             - disabled
      system.adapter.flot.0                  : flot                  - disabled
      system.adapter.hm-rpc.0                : hm-rpc                - disabled, port: 12001
      system.adapter.hm-rpc.1                : hm-rpc                - disabled, port: 0
      system.adapter.hm-rpc.2                : hm-rpc                - disabled, port: 0
      system.adapter.ical.0                  : ical                  - disabled
      system.adapter.icons-fatcow-hosting.0  : icons-fatcow-hosting  - disabled
      system.adapter.icons-icons8.0          : icons-icons8          - disabled
      system.adapter.icons-mfd-png.0         : icons-mfd-png         - disabled
      system.adapter.icons-mfd-svg.0         : icons-mfd-svg         - disabled
      system.adapter.icons-ultimate-png.0    : icons-ultimate-png    - disabled
      system.adapter.info.0                  : info                  - disabled
      system.adapter.javascript.0            : javascript            - disabled
      system.adapter.javascript.1            : javascript            - disabled
      system.adapter.modbus.0                : modbus                - disabled
      system.adapter.modbus.1                : modbus                - disabled
      system.adapter.ping.0                  : ping                  - disabled
      system.adapter.shuttercontrol.0        : shuttercontrol        - disabled
      system.adapter.sql.0                   : sql                   - disabled, port: 3306
      system.adapter.systeminfo.0            : systeminfo            - disabled
      system.adapter.tankerkoenig.0          : tankerkoenig          - disabled
      system.adapter.telegram.0              : telegram              - disabled, port: 8443, bind: 0.0.0.0
      system.adapter.vis-bars.0              : vis-bars              - disabled
      system.adapter.vis-canvas-gauges.0     : vis-canvas-gauges     - disabled
      system.adapter.vis-colorpicker.0       : vis-colorpicker       - disabled
      system.adapter.vis-fancyswitch.0       : vis-fancyswitch       - disabled
      system.adapter.vis-google-fonts.0      : vis-google-fonts      - disabled
      system.adapter.vis-history.0           : vis-history           - disabled
      system.adapter.vis-hqwidgets.0         : vis-hqwidgets         - disabled
      system.adapter.vis-jqui-mfd.0          : vis-jqui-mfd          - disabled
      system.adapter.vis-justgage.0          : vis-justgage          - disabled
      system.adapter.vis-metro.0             : vis-metro             - disabled
      system.adapter.vis-rgraph.0            : vis-rgraph            - disabled
      system.adapter.vis-timeandweather.0    : vis-timeandweather    - disabled
      system.adapter.vis-weather.0           : vis-weather           - disabled
      system.adapter.vis.0                   : vis                   - disabled
      system.adapter.weatherunderground.0    : weatherunderground    - disabled
      system.adapter.web.0                   : web                   -  enabled, port: 8082, bind: 192.168.168.114, run as: admin
    
    + instance is alive
    

    Ich kann aber nicht auf die admin oberfläche per Webbrowser zugreifen:
    947f1e51-72f4-4ffa-98ad-055bfb29c930-image.png

    Kann mir jemand hier einen Hinweis geben was ich machen muss?

    Vielen Dank,

    Artur

  • Most Active

    @LoxDUS sagte in [HowTo] ioBroker Restore unter Linux durchführen:

    Kann mir jemand hier einen Hinweis geben was ich machen muss?

    Die richtige IP verwenden. 😉

    Der ioBroker hört nur auf 192.168.168.114:8081, du versuchst es aber über 192.168.178.114:8081. Das kann nicht funktionieren!

    Du solltest im Admin die IP auf 0.0.0.0 binden. Dann wird es auch funktionieren wenn du auf eine andere IP umziehst.


  • ....-----^^^^ Oh man, das ist mir nicht aufgefallen ^^^^-----.....

    OK, ich habe jetzt mit

    iobroker set admin.0 --bind 0.0.0.0
    

    Das binding geändert und schwups .... es läuft.

    artur@ioBroker2:~$ iobroker list instances
    [sudo] Passwort für artur:
    + system.adapter.admin.0                 : admin                 -  enabled, port: 8081, bind: 0.0.0.0, run as: admin
      system.adapter.alexa2.0                : alexa2                - disabled
    + system.adapter.backitup.0              : backitup              -  enabled
      system.adapter.cloud.0                 : cloud                 - disabled
    

    Vielen Dank für die schnelle Hilfe.
    Grüße,

    Artur

  • Developer Most Active

    @joergfrde sagte in [HowTo] ioBroker Restore unter Linux durchführen:

    Ich hatte ein Admin-Adapter durchgeführt. Seit dem kann ich über den Browser gar nicht mehr zugreifen (Webseite nicht erreichbar). Heißt das, daß die Iobrokerinstallation zerstört ist? Dann würde ja ein Restore auch nicht helfen. Oder?

    Schaue dir mal das Log an.
    Da wird sich ein Fehler bei starten von admin auftauchen..
    Hast du eventuell die Testversion von Zigbee installiert?

  • Most Active

    Versuche nun auch mein Glück. Bisher ohne Erfolg.

    Kurz zur Ausgangslage. Docker auf Synology. Damit ich in der dockerübersicht das ganze besser aufeinander halten kann heißt der alte ioBroker_v2 und der neue ioBroker_v4

    Auf dem alten System ist node in Version 8.x und js-controler in Version 1.x (ich glaube 1.42) Backitup ist auf beiden 1.32. Also Backup auf den alten. Push kam das alles geklappt hat. Danach die Datei einfach in das neue Verzeichnis für den ioBroker_V4 kopiert. Ales System gestoppt und neues gestartet. Im neuen System (Node 10.x und js.controler 2.1.1) die Backupdaten ausgewählt und auf das kleine icon ganz rechts geklickt. Danach kommt der Hinweis das ioBroker neu starten muss und dann kommt:

    Bildschirmfoto 2019-12-07 um 12.04.17.png

    Mehr passiert da einfach nicht. Die CPU-Last ist gegen 0,0. an Prozessen sind nur der admin,jscontroller, info,backiptup gestartet. Öffne ich ioBroker auf einen anderen Browser läuft er auch ganz normal (das heißt der Neustart hat er anscheinend gemacht. Nur mehr eben nicht. Im normalen ioBroker Log ist auch alles ruhig. Klar es steht hier dauert. Aber wenn die cpu keine last zeigt passiert an der Stelle eben auch nichts oder?

    Was kann ich probieren. Ist es evtl problematisch das der Host nun nicht mehr ioBroker_v2 heißt?

  • Most Active

    Bin nun einen Schritt weiter. Über die Kommandozeile kam sehr schnell:

    restrote succesfully
    
    

    Nach Start von ioBroker lädt er jetzt alle Adapter gerade runter.

    Was mich wundert ist aber das zum einen meine angelegten eigenen Objekte auf der obersten Ebene nicht sichtbar sind und das ich nach jeden Adapterinstallation das Fenster vom Adapter schließen muss?

  • Most Active

    ok. Es scheint alles geklappt zu haben. Die eigene Objekte habe ich nicht gesehen. Da vermute ich mal ein Cache Problem. Alle Adapter sind erstmal grün bis auf der iot-Adapter. Da muss ich mal schauen woran das wohl liegen könnte...

    Probleme hat auch yahka. Der Adapter ist grün aber in HomeKit sind die Geräte alle nicht erreichbar? Kann mir hier evtl jemand einen Tipp geben?
    Alexa hat anscheinend auch einen Totalausfall? Wobei das natürlich an den ist-Adapter liegen könnte?

    Update: Ok beim iot-Adapter musste ich ein neues Zertifikat anfordern und damit wurde der Adapter dann sofort grün. Und somit funktioniert Alexa natürlich auch wieder.

    Jetzt bleibt nur noch HomeKit.


  • Hallo,
    Ich möchte ein altes Backup (mit einer alten Version von iobroker) auf einer neuen Version von iobroker installieren?

    Ist das problematisch?
    Ich habe die Methode mit "backitup" ausprobiert, nach einer Wiederherstellung hatte ich keinen Zugriff auf die Weboberfläche (http://192.168.178.10:8081/).

    danke

  • Developer Most Active

    @Esmax666
    Was sagen folgende Befehle über die Konsole?

    iobroker status
    iobroker list instances
    

  • @Esmax666 und was steht im logfile?


  • @Esmax666

    es geht jetzt danke 🙂 jemand hat mich geholfen 🙂

    Iobrocker setup war nichr richtig 😭

    iobroker setup custom
    erste Frage dann ein f
    dritte ...9001
    vierte f
    sechste...9000

    Und jetzt geht, er hat leider nichtdas adapter zwave nicht instaliert :S
    447125de-117b-4c7a-8410-72e5a5067809-grafik.png

    aber unter instance ist er da 🈂 soll per had versucher z wave zu installieren ?
    8fd9feb4-2e5b-4f05-92dd-666b6e4e3255-grafik.png

    und wenn ich auf play drücke gekomme ich das in mein log:

    2019-12-15 12:42:44.180 - info: host.raspberrypi "system.adapter.zwave.0" enabled
    2019-12-15 12:42:44.185 - warn: host.raspberrypi startInstance cannot find adapter "zwave@1.3.1". Try to install it... 1 attempt
    2019-12-15 12:42:44.185 - info: host.raspberrypi iobroker install zwave@1.3.1 using installedVersion
    2019-12-15 12:42:47.820 - info: host.raspberrypi iobroker npm-install: NPM version: 6.11.3
    2019-12-15 12:42:47.822 - info: host.raspberrypi iobroker npm-install: npm install iobroker.zwave@1.3.1 --unsafe-perm --loglevel error --prefix "/opt/iobroker" (System call)
    2019-12-15 12:43:05.880 - info: host.raspberrypi iobroker npm-install: find: ‘/tmp/ssh-ylIYRwZ3yhiD’: Keine Berechtigungfind: ‘/tmp/ssh-swkz9eaJm1hC’: Keine Berechtigungfind: ‘/tmp/dhcpcd-pi’: Keine Berechtigungfind: ‘/tmp/systemd-private-aec9f13ea5594bd6b2009eb166837044-systemd-timesyncd.service-ufjIhF’: Keine Berechtigung
    2019-12-15 12:43:11.822 - info: host.raspberrypi iobroker npm-install: % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed
    0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
    100 125 0 125 0 0 425 0 --:--:-- --:--:-- --:--:-- 425
    100 2377 0 2377 0 0 3362 0 --:--:-- --:--:-- --:--:-- 3362
    100 2451k 0 2451k 0 0 1387k 0 --:--:-- 0:00:01 --:--:-- 2314k
    100 9130k 0 9130k 0 0 3392k 0 --:--:-- 0:00:02 --:--:-- 4600k
    100 13.0M 0 13.0M 0 0 3971k 0 --:--:-- 0:00:03 --:--:-- 5026k
    2019-12-15 12:43:13.782 - info: host.raspberrypi iobroker npm-install: % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed
    0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
    100 147 0 147 0 0 490 0 --:--:-- --:--:-- --:--:-- 490
    0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
    100 16081 0 16081 0 0 15156 0 --:--:-- 0:00:01 --:--:-- 26405
    2019-12-15 12:43:13.785 - info: host.raspberrypi iobroker npm-install: /opt/iobroker/node_modules/iobroker.zwave/lib/preinstall.js:16 if (!suppressException) throw e; ^Error: Command failed: cd open-zwave-master && curl -O -L https://github.com/OpenZWave/open-zwave/pull/1125.patch && patch -p1 < 1125.patch % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed
    0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
    100 147 0 147 0 0 490 0 --:--:-- --:--:-- --:--:-- 490
    0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
    100 16081 0 16081 0 0 15156 0 --:--:-- 0:00:01 --:--:-- 26405 at checkExecSyncError (child_process.js:629:11) at Object.execSync (child_process.js:666:13) at doScript (/opt/iobroker/node_modules/iobroker.zwave/lib/preinstall.js:13:15) at installOpenZwaveFromSource (/opt/iobroker/node_modules/iobroker.zwave/lib/preinstall.js:147:3) at installOpenZwave (/opt/iobroker/node_modules/iobroker.zwave/lib/preinstall.js:139:3) at Object. (/opt/iobroker/node_modules/iobroker.zwave/lib/preinstall.js:27:7) at Module._compile (internal/modules/cjs/loader.js:778:30) at Object.Module._extensions..js (internal/modules/cjs/loader.js:789:10) at Module.load (internal/modules/cjs/loader.js:653:32) at tryModuleLoad (internal/modules/cjs/loader.js:593:12)
    2019-12-15 12:43:16.112 - info: host.raspberrypi iobroker npm-install: npm ERR! code ELIFECYCLE
    2019-12-15 12:43:16.116 - info: host.raspberrypi iobroker npm-install: npm ERR! errno 1npm ERR! iobroker.zwave@1.3.1 preinstall: `node lib/preinstall.js`npm ERR! Exit status 1npm ERR! npm ERR! Failed at the iobroker.zwave@1.3.1 preinstall script.npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
    2019-12-15 12:43:16.147 - info: host.raspberrypi iobroker npm-install: npm ERR! A complete log of this run can be found in:npm ERR! /home/iobroker/.npm/_logs/2019-12-15T11_43_16_131Z-debug.log
    2019-12-15 12:43:16.173 - error: host.raspberrypi iobroker npm-install: host.raspberrypi Cannot install iobroker.zwave@1.3.1: 1
    2019-12-15 12:43:17.197 - info: host.raspberrypi iobroker npm-install: exit 25
    2019-12-15 12:43:18.198 - warn: host.raspberrypi startInstance cannot find adapter "zwave@1.3.1". Try to install it... 2 attempt
    2019-12-15 12:43:18.199 - info: host.raspberrypi iobroker install zwave@1.3.1 using installedVersion
    2019-12-15 12:43:21.806 - info: host.raspberrypi iobroker npm-install: NPM version: 6.11.3
    2019-12-15 12:43:21.810 - info: host.raspberrypi iobroker npm-install: npm install iobroker.zwave@1.3.1 --unsafe-perm --loglevel error --prefix "/opt/iobroker" (System call)
    2019-12-15 12:43:40.231 - info: host.raspberrypi iobroker npm-install: find: ‘/tmp/ssh-ylIYRwZ3yhiD’: Keine Berechtigungfind: ‘/tmp/ssh-swkz9eaJm1hC’: Keine Berechtigungfind: ‘/tmp/dhcpcd-pi’: Keine Berechtigungfind: ‘/tmp/systemd-private-aec9f13ea5594bd6b2009eb166837044-systemd-timesyncd.service-ufjIhF’: Keine Berechtigung
    2019-12-15 12:43:46.191 - info: host.raspberrypi iobroker npm-install: % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed
    0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
    100 125 0 125 0 0 506 0 --:--:-- --:--:-- --:--:-- 506
    0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
    100 867k 0 867k 0 0 664k 0 --:--:-- 0:00:01 --:--:-- 907k
    100 6307k 0 6307k 0 0 2641k 0 --:--:-- 0:00:02 --:--:-- 3096k
    100 12.7M 0 12.7M 0 0 3957k 0 --:--:-- 0:00:03 --:--:-- 4426k
    100 13.0M 0 13.0M 0 0 3997k 0 --:--:-- 0:00:03 --:--:-- 4464k
    2019-12-15 12:43:47.810 - info: host.raspberrypi iobroker npm-install: % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed
    0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
    0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
    100 147 0 147 0 0 501 0 --:--:-- --:--:-- --:--:-- 500
    100 16081 0 16081 0 0 22028 0 --:--:-- --:--:-- --:--:-- 22028
    2019-12-15 12:43:47.815 - info: host.raspberrypi iobroker npm-install: /opt/iobroker/node_modules/iobroker.zwave/lib/preinstall.js:16 if (!suppressException) throw e; ^Error: Command failed: cd open-zwave-master && curl -O -L https://github.com/OpenZWave/open-zwave/pull/1125.patch && patch -p1 < 1125.patch % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed
    0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
    0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
    100 147 0 147 0 0 501 0 --:--:-- --:--:-- --:--:-- 500
    100 16081 0 16081 0 0 22028 0 --:--:-- --:--:-- --:--:-- 22028 at checkExecSyncError (child_process.js:629:11) at Object.execSync (child_process.js:666:13) at doScript (/opt/iobroker/node_modules/iobroker.zwave/lib/preinstall.js:13:15) at installOpenZwaveFromSource (/opt/iobroker/node_modules/iobroker.zwave/lib/preinstall.js:147:3) at installOpenZwave (/opt/iobroker/node_modules/iobroker.zwave/lib/preinstall.js:139:3) at Object. (/opt/iobroker/node_modules/iobroker.zwave/lib/preinstall.js:27:7) at Module._compile (internal/modules/cjs/loader.js:778:30) at Object.Module._extensions..js (internal/modules/cjs/loader.js:789:10) at Module.load (internal/modules/cjs/loader.js:653:32) at tryModuleLoad (internal/modules/cjs/loader.js:593:12)
    2019-12-15 12:43:50.284 - info: host.raspberrypi iobroker npm-install: npm
    2019-12-15 12:43:50.289 - info: host.raspberrypi iobroker npm-install: ERR! code ELIFECYCLEnpm ERR! errno 1npm ERR! iobroker.zwave@1.3.1 preinstall: `node lib/preinstall.js`npm ERR! Exit status 1
    2019-12-15 12:43:50.292 - info: host.raspberrypi iobroker npm-install: npm ERR! npm ERR! Failed at the iobroker.zwave@1.3.1 preinstall script.npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
    2019-12-15 12:43:50.321 - info: host.raspberrypi iobroker npm-install: npm ERR! A complete log of this run can be found in:npm ERR! /home/iobroker/.npm/_logs/2019-12-15T11_43_50_306Z-debug.log
    2019-12-15 12:43:50.348 - error: host.raspberrypi iobroker npm-install: host.raspberrypi Cannot install iobroker.zwave@1.3.1: 1
    2019-12-15 12:43:51.368 - info: host.raspberrypi iobroker npm-install: exit 25
    2019-12-15 12:43:52.371 - warn: host.raspberrypi startInstance cannot find adapter "zwave@1.3.1". Try to install it... 3 attempt
    2019-12-15 12:43:52.372 - info: host.raspberrypi iobroker install zwave@1.3.1 using installedVersion
    2019-12-15 12:43:55.911 - info: host.raspberrypi iobroker npm-install: NPM version: 6.11.3
    2019-12-15 12:43:55.915 - info: host.raspberrypi iobroker npm-install: npm install iobroker.zwave@1.3.1 --unsafe-perm --loglevel error --prefix "/opt/iobroker" (System call)
    2019-12-15 12:44:14.462 - info: host.raspberrypi iobroker npm-install: find: ‘/tmp/ssh-ylIYRwZ3yhiD’: Keine Berechtigungfind: ‘/tmp/ssh-swkz9eaJm1hC’: Keine Berechtigungfind: ‘/tmp/dhcpcd-pi’: Keine Berechtigungfind: ‘/tmp/systemd-private-aec9f13ea5594bd6b2009eb166837044-systemd-timesyncd.service-ufjIhF’: Keine Berechtigung
    2019-12-15 12:44:20.281 - info: host.raspberrypi iobroker npm-install: % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed
    0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
    0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
    100 125 0 125 0 0 423 0 --:--:-- --:--:-- --:--:-- 422
    100 235k 0 235k 0 0 221k 0 --:--:-- 0:00:01 --:--:-- 221k
    100 6390k 0 6390k 0 0 2959k 0 --:--:-- 0:00:02 --:--:-- 5620k
    100 12.2M 0 12.2M 0 0 4152k 0 --:--:-- 0:00:03 --:--:-- 6287k
    100 13.0M 0 13.0M 0 0 4237k 0 --:--:-- 0:00:03 --:--:-- 6277k
    2019-12-15 12:44:22.248 - info: host.raspberrypi iobroker npm-install: % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed
    0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
    100 147 0 147 0 0 393 0 --:--:-- --:--:-- --:--:-- 394
    0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
    100 16081 0 16081 0 0 15014 0 --:--:-- 0:00:01 --:--:-- 163k
    2019-12-15 12:44:22.252 - info: host.raspberrypi iobroker npm-install: /opt/iobroker/node_modules/iobroker.zwave/lib/preinstall.js:16 if (!suppressException) throw e; ^Error: Command failed: cd open-zwave-master && curl -O -L https://github.com/OpenZWave/open-zwave/pull/1125.patch && patch -p1 < 1125.patch % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed
    0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
    100 147 0 147 0 0 393 0 --:--:-- --:--:-- --:--:-- 394
    0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
    100 16081 0 16081 0 0 15014 0 --:--:-- 0:00:01 --:--:-- 163k at checkExecSyncError (child_process.js:629:11) at Object.execSync (child_process.js:666:13) at doScript (/opt/iobroker/node_modules/iobroker.zwave/lib/preinstall.js:13:15) at installOpenZwaveFromSource (/opt/iobroker/node_modules/iobroker.zwave/lib/preinstall.js:147:3) at installOpenZwave (/opt/iobroker/node_modules/iobroker.zwave/lib/preinstall.js:139:3) at Object. (/opt/iobroker/node_modules/iobroker.zwave/lib/preinstall.js:27:7) at Module._compile (internal/modules/cjs/loader.js:778:30) at Object.Module._extensions..js (internal/modules/cjs/loader.js:789:10) at Module.load (internal/modules/cjs/loader.js:653:32) at tryModuleLoad (internal/modules/cjs/loader.js:593:12)
    2019-12-15 12:44:24.469 - info: host.raspberrypi iobroker npm-install: npm ERR! code ELIFECYCLE
    2019-12-15 12:44:24.473 - info: host.raspberrypi iobroker npm-install: npm ERR! errno 1npm ERR! iobroker.zwave@1.3.1 preinstall: `node lib/preinstall.js`npm ERR! Exit status 1npm ERR! npm ERR! Failed at the iobroker.zwave@1.3.1 preinstall script.npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
    2019-12-15 12:44:24.500 - info: host.raspberrypi iobroker npm-install: npm ERR! A complete log of this run can be found in:npm ERR! /home/iobroker/.npm/_logs/2019-12-15T11_44_24_483Z-debug.log
    2019-12-15 12:44:24.526 - error: host.raspberrypi iobroker npm-install: host.raspberrypi Cannot install iobroker.zwave@1.3.1: 1
    2019-12-15 12:44:25.545 - info: host.raspberrypi iobroker npm-install: exit 25
    2019-12-15 12:44:26.546 - warn: host.raspberrypi startInstance cannot find adapter "zwave@1.3.1". Try to install it... 4 attempt
    2019-12-15 12:44:26.547 - info: host.raspberrypi iobroker install zwave@1.3.1 using installedVersion
    2019-12-15 12:44:30.124 - info: host.raspberrypi iobroker npm-install: NPM version: 6.11.3npm install iobroker.zwave@1.3.1 --unsafe-perm --loglevel error --prefix "/opt/iobroker" (System call)
    2019-12-15 12:44:49.340 - info: host.raspberrypi iobroker npm-install: find: ‘/tmp/ssh-ylIYRwZ3yhiD’: Keine Berechtigungfind: ‘/tmp/ssh-swkz9eaJm1hC’: Keine Berechtigungfind: ‘/tmp/dhcpcd-pi’: Keine Berechtigungfind: ‘/tmp/systemd-private-aec9f13ea5594bd6b2009eb166837044-systemd-timesyncd.service-ufjIhF’: Keine Berechtigung
    2019-12-15 12:44:55.394 - info: host.raspberrypi iobroker npm-install: % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed
    0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
    0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
    100 125 0 125 0 0 473 0 --:--:-- --:--:-- --:--:-- 471
    100 221k 0 221k 0 0 192k 0 --:--:-- 0:00:01 --:--:-- 192k
    100 5606k 0 5606k 0 0 2605k 0 --:--:-- 0:00:02 --:--:-- 5380k
    100 11.4M 0 11.4M 0 0 3713k 0 --:--:-- 0:00:03 --:--:-- 5740k
    100 13.0M 0 13.0M 0 0 3935k 0 --:--:-- 0:00:03 --:--:-- 5848k
    2019-12-15 12:44:57.362 - info: host.raspberrypi iobroker npm-install: % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed
    0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
    100 147 0 147 0 0 261 0 --:--:-- --:--:-- --:--:-- 261
    0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
    100 16081 0 16081 0 0 15658 0 --:--:-- 0:00:01 --:--:-- 155k
    2019-12-15 12:44:57.365 - info: host.raspberrypi iobroker npm-install: /opt/iobroker/node_modules/iobroker.zwave/lib/preinstall.js:16 if (!suppressException) throw e; ^Error: Command failed: cd open-zwave-master && curl -O -L https://github.com/OpenZWave/open-zwave/pull/1125.patch && patch -p1 < 1125.patch % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed
    0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
    100 147 0 147 0 0 261 0 --:--:-- --:--:-- --:--:-- 261
    0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
    100 16081 0 16081 0 0 15658 0 --:--:-- 0:00:01 --:--:-- 155k at checkExecSyncError (child_process.js:629:11) at Object.execSync (child_process.js:666:13) at doScript (/opt/iobroker/node_modules/iobroker.zwave/lib/preinstall.js:13:15) at installOpenZwaveFromSource (/opt/iobroker/node_modules/iobroker.zwave/lib/preinstall.js:147:3) at installOpenZwave (/opt/iobroker/node_modules/iobroker.zwave/lib/preinstall.js:139:3) at Object. (/opt/iobroker/node_modules/iobroker.zwave/lib/preinstall.js:27:7) at Module._compile (internal/modules/cjs/loader.js:778:30) at Object.Module._extensions..js (internal/modules/cjs/loader.js:789:10) at Module.load (internal/modules/cjs/loader.js:653:32) at tryModuleLoad (internal/modules/cjs/loader.js:593:12)
    2019-12-15 12:44:59.669 - info: host.raspberrypi iobroker npm-install: npm
    2019-12-15 12:44:59.671 - info: host.raspberrypi iobroker npm-install:
    2019-12-15 12:44:59.674 - info: host.raspberrypi iobroker npm-install: ERR! code ELIFECYCLEnpm
    2019-12-15 12:44:59.678 - info: host.raspberrypi iobroker npm-install: ERR! errno 1
    2019-12-15 12:44:59.681 - info: host.raspberrypi iobroker npm-install: npm ERR! iobroker.zwave@1.3.1 preinstall: `node lib/preinstall.js`npm
    2019-12-15 12:44:59.685 - info: host.raspberrypi iobroker npm-install: ERR! Exit status 1npm
    2019-12-15 12:44:59.688 - info: host.raspberrypi iobroker npm-install: ERR! npm ERR! Failed at the iobroker.zwave@1.3.1 preinstall script.
    2019-12-15 12:44:59.692 - info: host.raspberrypi iobroker npm-install: npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
    2019-12-15 12:44:59.718 - info: host.raspberrypi iobroker npm-install:
    2019-12-15 12:44:59.719 - info: host.raspberrypi iobroker npm-install: npm
    2019-12-15 12:44:59.722 - info: host.raspberrypi iobroker npm-install: ERR! A complete log of this run can be found in:npm ERR! /home/iobroker/.npm/_logs/2019-12-15T11_44_59_702Z-debug.log
    2019-12-15 12:44:59.759 - error: host.raspberrypi iobroker npm-install: host.raspberrypi Cannot install iobroker.zwave@1.3.1: 1
    2019-12-15 12:45:00.778 - info: host.raspberrypi iobroker npm-install: exit 25
    2019-12-15 12:45:01.780 - error: host.raspberrypi Cannot download and install adapter "zwave@1.3.1". To retry it disable/enable the adapter or restart host. Also check the error messages in the log!
    
    
    

    Edit: ich kann jetzt Zwave starten und es geht. Aber es ist sehr komisch, Die weboberfläche zeigt kein Iobroker adater als installiet :S

    ad18535e-8631-42a1-a886-a6e40fc4fec2-grafik.png

    Instance läuft :s

    4a8877df-a9a2-4210-af93-38e83fb07588-grafik.png

    soll ich dann lieber Zwave adapter löchen und neu instalieren. Falls ja, wie ? und dann kann ich trozdem die instances und objet konfiguration behalten ?

    Logfiles:logs - ioBroker.txt

    und Instances:
    7d5d38d6-961c-4775-8b1c-1b378c8bb718-grafik.png
    Danke 🙂

    robbiet480 created this issue in OpenZWave/open-zwave

    closed CentralScene support #1125

    robbiet480 created this issue in OpenZWave/open-zwave

    closed CentralScene support #1125

    robbiet480 created this issue in OpenZWave/open-zwave

    closed CentralScene support #1125

    robbiet480 created this issue in OpenZWave/open-zwave

    closed CentralScene support #1125

Suggested Topics

1.4k
Online

38.3k
Users

43.7k
Topics

611.2k
Posts