NEWS

  • Starter

    @Dutchman top geht, echt geile arbeit

  • Developer Most Active Administrators

    @denjo sagte in [Aufruf] Neuer Adaper Tado:

    @Dutchman top geht, echt geile arbeit

    super danke für die Rückmeldung

  • Starter

    @Dutchman echt wirklich ich hab echt 2 jahre drauf gewartet


  • @Dutchman Super vielen leben Dank. Eigentlich müsste man damit auch den Modus ändern können (Aus, Auto, Manuell Betrieb) und nicht nur die Temperatur 😉

  • Starter

    @Stormbringer und wie?


  • @denjo war als antwort für dutchman gedacht, weil er gemeint hat nur temperatur steuern reicht 😉

  • Starter

    @Stormbringer Acchso okay 😄


  • @Stormbringer sind wir gerade dran


  • @senger1985 alles gut. super. seid eh voll flott. wollte nur angemerkt haben 😉bin gespannt wie sich der adapter verhält bei modus und temperaturänderungen 😉


  • @Stormbringer sorry, sollte nicht so "agro" rüberkommen.
    Wünsche erstmal eine gute Nacht. 😉

  • Developer Most Active Administrators

    @Stormbringer sagte in [Aufruf] Neuer Adaper Tado:

    @Dutchman Super vielen leben Dank. Eigentlich müsste man damit auch den Modus ändern können (Aus, Auto, Manuell Betrieb) und nicht nur die Temperatur 😉

    sind dran die API ist leider schlecht dokumentiert.


  • Wir sind heute ein gutes Stück voran gekommen.
    Die Tage geht es weiter.


  • Guten Morgen,

    erstmal ein fettes Danke an @Dutchman und @senger1985 das Ihr den tado-Adapter umgesetzt habt. Spart bei mir nun zwei zusätzliche Adapter.

    Ich habe ihn ausgiebig gestestet (schlaf wird eh überbewertet) und im großen und ganzen scheint alles zu funktionieren.

    Steuerung der Thermostate übder die Datenpunkte funktioniert. Die Temperatur wird angenommen und verarbeitet.
    Steuerung über my.tado.com funktioniert auch. Die Daten werden übernommen.
    Ebenso werden Änderungen, die in der tado-App gemacht werden, übernommen

    Offenes Fenster wird erkannt, allerdings steht dann im Datenpunkt openWindow nur [object Object]. Könnt Ihr da etwas "aussagekräftigeres" einbauen?
    f18505d8-2976-45de-b19f-6172b0978ed1-grafik.png

    Wenn Manuell eine Temperatur eingestellt wird erscheint im Datenpunkt overlayType "MANUAL". Im normalen Betrieb - also Regelung über den tado-Zeitplan - erscheint null. Könnt Ihr da auch etwas ändern?
    66e836d6-cd0e-43ab-a8f9-e42fdff65bf6-grafik.png

    Gestern hat der Adapter einmal einen Fehler geworfen, ich weiß aber nicht wo der herkommt, und er trat auch bis dato nicht mehr auf

    2019-10-12 21:29:39.455  - error: tado.0 Temperature changed for room : 10 in home : 96374
    2019-10-12 21:29:39.455  - error: tado.0 Temperature change message to API : 96374, 10,0, 23
    2019-10-12 21:29:39.457  - error: tado.0 State change detected from different source then adapter
    2019-10-12 21:29:39.457  - error: tado.0 state tado.0.96374.Rooms.10.setting.temperature changed: 23 (ack = false)
    

    Danke noch einmal für den Adapter, habe lange darauf gewartet. Ihr seit Spitze!


  • @CKMartens Du meinst @senger1985 😉 nicht mich g


  • @Stormbringer Ähhhhh ja 😇


  • @Dutchman Kanns mir vorstellen, das HAM Plugin war auch so wirr. Hilft euch das, wenn wir die Modusarten von dem Plug in hier schreiben. Also welche Zahl welchen Modus bedeutet hat?

    Wär nur super, wenn der fiese Modus 2 (nicht heizend) eindeutig auf den manuellen Modus zurückzuführen wäre. In der alten Plugin Version war nämlich Modus 2 nicht heizend sowohl für automatik als auch für den manuellen Modus. Das war echt blöd zum Skripten. In der neuen Version ist es jetzt eindeutig auf manuell zurückzuführen.


  • Guten Morgen,

    vielen Dank für diesen Adapter. Ich warte wie viele denke ich mal schon lang darauf das sich hier etwas bewegt 🙂

    Folgenden Fehler bekomme ich:

    host.iobroker	2019-10-13 09:53:02.061	error	instance system.adapter.tado.0 terminated with code 1 ()
    host.iobroker	2019-10-13 09:53:02.061	error	Caught by controller[0]: at Function.Module._load (internal/modules/cjs/loader.js:585:3)
    host.iobroker	2019-10-13 09:53:02.061	error	Caught by controller[0]: at tryModuleLoad (internal/modules/cjs/loader.js:593:12)
    host.iobroker	2019-10-13 09:53:02.061	error	Caught by controller[0]: at Module.load (internal/modules/cjs/loader.js:653:32)
    host.iobroker	2019-10-13 09:53:02.061	error	Caught by controller[0]: at Object.Module._extensions..js (internal/modules/cjs/loader.js:787:10)
    host.iobroker	2019-10-13 09:53:02.060	error	Caught by controller[0]: at Module._compile (internal/modules/cjs/loader.js:776:30)
    host.iobroker	2019-10-13 09:53:02.060	error	Caught by controller[0]: at Object.<anonymous> (/opt/iobroker/node_modules/iobroker.tado/main.js:29:15)
    host.iobroker	2019-10-13 09:53:02.060	error	Caught by controller[0]: at require (internal/modules/cjs/helpers.js:25:18)
    host.iobroker	2019-10-13 09:53:02.060	error	Caught by controller[0]: at Module.require (internal/modules/cjs/loader.js:690:17)
    host.iobroker	2019-10-13 09:53:02.060	error	Caught by controller[0]: at Function.Module._load (internal/modules/cjs/loader.js:562:25)
    host.iobroker	2019-10-13 09:53:02.060	error	Caught by controller[0]: at Function.Module._resolveFilename (internal/modules/cjs/loader.js:636:15)
    host.iobroker	2019-10-13 09:53:02.060	error	Caught by controller[0]: Error: Cannot find module 'axios'
    host.iobroker	2019-10-13 09:53:02.060	error	Caught by controller[0]: ^
    host.iobroker	2019-10-13 09:53:02.060	error	Caught by controller[0]: throw err;
    host.iobroker	2019-10-13 09:53:02.059	error	Caught by controller[0]: internal/modules/cjs/loader.js:638
    host.iobroker	2019-10-13 09:53:01.114	info	instance system.adapter.tado.0 started with pid 15627
    host.iobroker	2019-10-13 09:52:31.078	info	Restart adapter system.adapter.tado.0 because enabled
    

  • @mech

    Problem hat sich erledigt. Lag daran das ich vor kurzem ein Backup eingespielt habe und das Modul nicht geladen wurde.


  • @CKMartens das mit "openWindow" haben wir gestern versucht zu testen und ich habe den ganzen Tag mein Fenster offen gehabt und mir alles abgefroren, nur wollte mein Thermostat nicht reagieren, das schauen wir uns nochmal an. Sowie den "Overlay Type", das konnte ich auch gerade reproduzieren.

    @Stormbringer das Plugin Haben wir uns auch mehrmals angeschaut. Ich und so wie ich @Dutchman verstanden habe, sind uns nicht schlüssig gewesen, wo diese Zahlen herkommen, da diese von der API nicht wiedergegeben werden und wir nur auf die Daten zurückgreifen können, die die API ausspuckt.

    Aber ich habe auch nur das alte Plugin gehabt, vielleicht hilft es uns doch weiter, wenn du uns mal den Link dazu geben könntest.


  • @senger1985 Wegen dem "openWindow" Problem weiß ich nicht ob das ein Problem vom Adapter ist, glaub das ist eher tado wie es leibt und lebt ;D hatte das nur anfangs und hat nie zuverlässig funktioniert. Nach einer Woche habe ich das dann mit Fensterkontakten geregelt und über ioBroker ausschalten lassen ;o)

    Der Link zum aktuellen Plugin wäre der hier:

    https://www.npmjs.com/package/homebridge-tado-platform

    Ansteuerung der Modi erfolgt über den Datenpunkt "Target-Heating-Cooling-State". Und die kryptischen Zahlen bedeuten:

    0 = Aus
    1 = Manueller Modus (heizend)
    2 = Manueller Modus (nicht heizend)
    3 = Automatik Modus (heizen nach Zeitplan)

    Wenn man vom Automatikmodus in den manuellen wechseln will muss man den "Target Temperature" Punkt ansprechen, dann wechselt der Modus direkt auf manuell. Wenn die Ist-Temperatur über der Sollwert-Temperatur liegt setzt er Modus 2 (nicht heizend), wenn Sollwert höher ist als Raumtemperatur Modus 1 (heizend). Aus und Automatik direkt über den "Target-Heating-Cooling-State" Punkt.

    Hoffe das hilft euch weiter g Falls ich noch was helfen kann einfach schreien 😉

Suggested Topics

1.7k
Online

35.0k
Users

41.0k
Topics

563.2k
Posts