NEWS


  • Systemdata Bitte Ausfüllen
    Hardwaresystem: IoBroker 3.b
    Arbeitsspeicher: 926MB
    Festplattenart: SD-Karte 15GB
    Betriebssystem: Ubuntu
    Node-Version: 10.x.x
    Nodejs-Version: 10.15.3
    NPM-Version: 6.10.1
    Installationsart: Skript;Manuell
    Image genutzt: Ja
    Ort/Name der Imagedatei: Link

    Hi zusammen,

    ich bin brauche mal bitte eure Hilfe. Es geht um den TR064 Adapter der lässt sich bei mir nicht Installieren aber das System sagt es wäre einer vorhanden, wenn ich ihn löschen will sagt das System aber das er es nicht löschen kann. Irgenwie drehe ich mich nur im Kreis und kann es weder löschen noch installieren, seit dem Update.

    Alle Befehle gebe ich mit dem Super User ein .... also vorher Sudo SU.

    root@raspberrypi:/opt/iobroker# iobroker upgrade tr-064
    Update tr-064 from @0.4.0 to @0.4.18
    NPM version: 6.10.1
    npm install iobroker.tr-064@0.4.18 --production --save --prefix "/opt/iobroker"                                                                                                              (System call)
    npm WARN checkPermissions Missing write access to /opt/iobroker/node_modules/iob                                                                                                             roker.tr-064
    npm ERR! path /opt/iobroker/node_modules/iobroker.tr-064
    npm ERR! code EACCES
    npm ERR! errno -13
    npm ERR! syscall access
    npm ERR! Error: EACCES: permission denied, access '/opt/iobroker/node_modules/io                                                                                                             broker.tr-064'
    npm ERR!  { [Error: EACCES: permission denied, access '/opt/iobroker/node_module                                                                                                             s/iobroker.tr-064']
    npm ERR!   stack:
    npm ERR!    'Error: EACCES: permission denied, access \'/opt/iobroker/node_modul                                                                                                             es/iobroker.tr-064\'',
    npm ERR!   errno: -13,
    npm ERR!   code: 'EACCES',
    npm ERR!   syscall: 'access',
    npm ERR!   path: '/opt/iobroker/node_modules/iobroker.tr-064' }
    npm ERR!
    npm ERR! The operation was rejected by your operating system.
    npm ERR! It is likely you do not have the permissions to access this file as the                                                                                                              current user
    npm ERR!
    npm ERR! If you believe this might be a permissions issue, please double-check t                                                                                                             he
    npm ERR! permissions of the file and its containing directories, or try running
    npm ERR! the command again as root/Administrator (though this is not recommended                                                                                                             ).
    
    npm ERR! A complete log of this run can be found in:
    npm ERR!     /home/iobroker/.npm/_logs/2019-09-25T16_50_17_598Z-debug.log
    host.raspberrypi Cannot install iobroker.tr-064@0.4.18: 243
    
    

    Vielleicht wisst ihr ja einen Rat.
    Vielen Dank

  • Developer

    Versuch mal den https://github.com/iobroker-community-adapters/ioBroker.tr-064-community, der andfere ist veraltet, hast du in der letzten Zeit dein iobroker (js controller) geupdatet? falls es mit dem adapter immer nopch nicht klappt, führe mal den installations-fixer aus. mfg


  • @Meistertr
    Vielen dank,
    geupdatet hatte ich soweit nix, lief alles bis wie geschrieben, das Update kam.
    Was ist denn bitte: der Installations Fixer, kenne mich noch nicht so gut aus. 🤷‍♂️

  • Forum Testing Most Active


  • @crunchip
    @Meistertr
    Super vielen Dank euch beiden, anscheinend konnte ich mit dem Fixer irgendwas reparieren und jetzt kann ich es wieder deinstallieren und den Adapter neu Installieren, Vielen dank euch.😌

  • Developer

    bitte auf gelößt umstellen


  • @Thunder1504
    Na damit hast die fehlenden Zugriffsrechte gefixt die im Log angemeckert werden.

  • Global Moderator

    @Thunder1504 sagte in Iobroker Adapter TR-064:

    @crunchip
    @Meistertr
    Super vielen Dank euch beiden, anscheinend konnte ich mit dem Fixer irgendwas reparieren und jetzt kann ich es wieder deinstallieren und den Adapter neu Installieren, Vielen dank euch.😌

    Wenn ein Thema gelöst wurde bitte den Beitrag der die Lösung beinhaltet als gelöst markieren.
    -> 3 Punkte Menü rechts unten am Beitrag -> Mark this post as the correct answer

Suggested Topics

1.1k
Online

35.0k
Users

41.0k
Topics

562.4k
Posts