js-controller 1.5.14 im Stable Repository



  • Hi,

    nach dem Release der 1.5.11 im Stable (https://forum.iobroker.net/topic/22803/js-controller-1-5-11-ab-sofort-im-stable-repository) und der neuen Empfehlung nodejs 10 als Standard zu nehmen haben wir aufgrund des Feedbacks und einiger nerviger Fehler beim Installieren der 1.5 unter Nodejs 10 entschieden hier noch eine Version mit weiteren Fixes und Änderungen nachzuschieben. Auch nötige Änderungen sei Release von Nodejs 10.16 mit höheren Anforderungen an SSL-Keys sind hier eingeflossen, sodass ioBroker wieder bis zu den aktuellsten LTS Node.js Versionen funktioniert.

    Die Installation dieser Version prüft die in ioBroker seit längerem hinterlegten Standard-SSL-Zertifikate und ersetzt diese durch eine neue wieder länger gültige Version mit einem 2048bit Key. Dies erfolgt allerdings nur wenn die Zertifikate nicht geändert wurden! Wer also die Standard-Zertifikate durch ein eigenes ersetzt hat muss bitte ab Node.js 10.16 selbst dafür sorge tragen das der Private-key mehr als 1024bit hat!

    Ich freue mich das ab sofort der js-controller 1.5.14 im Stable Repository verfügbar ist und bedanke mich bei allen die für die letzten Versionen Feedback gegeben haben und Ihre Erfahrungen geteilt haben und bei den Tests der Änderungen unterstützt haben.

    Bei Fragen, Problemen und Diskussionen bitte nutzt bitte einfach den Thread https://forum.iobroker.net/topic/24056/diskussion-js-controller-1-5-14-im-stable-repo

    Changelog (seit 1.5.11):

    • (Apollon77) Install instance of info adapter too on first setup of controller
    • (Stabilostick) Make sure Info Adapter Tab is displayed automatically on install
    • (Stabilostick) Add CLI host commands to CLI usage help
    • (Stabilostick) Replace winston-syslog dependency to prevent build errors on node.js 10+ when installing or updating iobroker (not needed in 2.0.0)
    • (Stabilostick) Replace default self signed SSL certificate to prevent errors in Node.Js 10.16+
    • (Apollon77) Also replace default certificate used for all Web and Admin instances if the old cerfificate was used on installation of js-controller , so after restart will use the new certificate
    • (Stabilostick) update diskusage dependency to prevent build errors and support Node.js 12
    • (Apollon77) Fix Error on setup when defaultCertificate was deleted

    Ingo


Log in to reply
 

Suggested Topics

  • 158
  • 5
  • 4
  • 85
  • 947
  • 54
  • 5

586
Online

21.8k
Users

26.6k
Topics

325.2k
Posts