NEWS


  • So hatte den Raspberry Pi jetzt 2 Tage ohne IoBroker laufe und ist nicht abgestürzt.
    Im Anhang lade ich den Apt Log hoch und Syslog.
    Kann man da irgendwas rauslesen?
    Ein Fehler etc. ?
    syslog
    Apt update Log:
    history.log

    term.log


  • Könnt ihr mir weiterhelfen und die Logs vielleicht auswerten und wie soll ich jetzt weiter hern gehen ??
    Danke

  • Forum Testing Most Active Global Moderator Administrators

    @marcuskl
    Wenn er nicht abstürzt kann auch nichts im log stehen.

    @marcuskl sagte in Raspberry Pi abstürze hören nicht auf:

    wie soll ich jetzt weiter hern gehen ??

    @wendy2702 sagte in Raspberry Pi abstürze hören nicht auf:

    Deaktiviere mal alle deine Scripte.


  • @marcuskl sagte in Raspberry Pi abstürze hören nicht auf:

    So hatte den Raspberry Pi jetzt 2 Tage ohne IoBroker laufe und ist nicht abgestürzt.

    Also wenn der Pi ohne ioBroker jetzt läuft werden wir in den logs nichts finden. Es liegt scheinbar an deiner Installation.

    Ich denke ein Backup iobroker / SD-Karte hast du schon gemacht.

    Dann würde ich mal ioBroker wieder starten und erstmal nur 2-3 Instanzen starten.

    Edit: Rainer war schneller


  • Ok werde beides mal versuchen.
    Backup ist erstellt.


  • Ich hab jetzt alles laufen außer JavaScript.
    Er läuft Stabil die letzten Tage.
    Ich warte mal noch ab, die nächsten Tage, aber wie es aussieht sind es wahrscheinlich die Scripts oder ein Script.


  • Jetzt ist er Wochen lang gut gelaufen und heute 2 mal ein Abstürz und Log voll.
    Was bedeutet das ?
    iobroker.2019-04-03.log


  • Steht zu diesen Zeiten etwas im Linux Syslog?

    2019-04-03 02:20:44.981  - info: info.0 Popup-News readed...
    2019-04-03 02:50:44.909  - info: info.0 Popup-News readed...
    2019-04-03 03:08:41.346  - error: Caught by controller[0]: Stacktrace:
    2019-04-03 03:08:41.348  - error: Caught by controller[0]:    magic1=bbbbbbbb 
    

    Mal zum testen den Info Adapter gestoppt?


  • syslog

    Ja ees ist was zu finden um die Uhrzeit Ca. Aber sagt mir nichts.
    Im Anhang der log, fast ganz am Ende zu finden.
    Wie kann des sein, das der info Adapter Probleme macht ?


  • Es gab mal ein Problem mit einer Version des Info Adapters. Weiß aber gerade nicht mehr welche das wahr. Steht irgendwo im Forum.

    Hast du hier etwas aus dem Syslog entfernt:

    Apr  2 21:31:11 raspberrypi systemd[1]: Started Cleanup of Temporary Directories.
    Apr  3 03:08:41 raspberrypi bash[435]: Stacktrace:
    

    Sieht für mich so aus als wenn es ein Problem mit dem Winston Syslog gibt....

    Hast du deine Installation mal so geändert das dein iobroker log auch in das Linux Syslog geschrieben wird?

    Wie voll ist die Speicherkarte?

    Deine Node Version "node: v8.15.1" hat glaube ich ein Speicherproblem wenn ich mich richtig erinnere. In Verbindung mit JS-Controller 1.5.7 solltest du dir überlegen auf Node 10.x zu wechseln oder zumindest dein Node 8 Version zu aktualisieren.

  • Developer

    @wendy2702 sagte in Raspberry Pi abstürze hören nicht auf:

    Deine Node Version "node: v8.15.1" hat glaube ich ein Speicherproblem wenn ich mich richtig erinnere.

    Nein. Node 8.11 und darunter hat das Problem, ab 8.12 ist alles gut.


  • 😁

    Deshalb hatte ich „glaube“ geschrieben 😎


  • @wendy2702 sagte in Raspberry Pi abstürze hören nicht auf:

    Es gab mal ein Problem mit einer Version des Info Adapters. Weiß aber gerade nicht mehr welche das wahr. Steht irgendwo im Forum.

    Hast du hier etwas aus dem Syslog entfernt:

    Apr  2 21:31:11 raspberrypi systemd[1]: Started Cleanup of Temporary Directories.
    Apr  3 03:08:41 raspberrypi bash[435]: Stacktrace:
    

    Sieht für mich so aus als wenn es ein Problem mit dem Winston Syslog gibt....

    Hast du deine Installation mal so geändert das dein iobroker log auch in das Linux Syslog geschrieben wird?

    Wie voll ist die Speicherkarte?

    Deine Node Version "node: v8.15.1" hat glaube ich ein Speicherproblem wenn ich mich richtig erinnere. In Verbindung mit JS-Controller 1.5.7 solltest du dir überlegen auf Node 10.x zu wechseln oder zumindest dein Node 8 Version zu aktualisieren.

    Habe nichts im Syslog entfernt.

    Wie mache ich das es noch ins Syslog geschrieben wird ?

    10% sind belegt von 32GB

Suggested Topics

  • 3
  • 2
  • 18
  • 2
  • 3
  • 13
  • 1
  • 6

911
Online

36.7k
Users

42.4k
Topics

586.7k
Posts